Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 61506 - LiveCD does not boot on IBM Power Blade Server JS20
Summary: LiveCD does not boot on IBM Power Blade Server JS20
Alias: None
Product: Gentoo Release Media
Classification: Unclassified
Component: Everything (show other bugs)
Hardware: PPC64 Linux
: High blocker (vote)
Assignee: ppc64 architecture team
Depends on:
Reported: 2004-08-24 06:30 UTC by Anders Fredriksson
Modified: 2005-03-31 09:40 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---

New JS20 Config (js20,22.88 KB, text/plain)
2004-09-28 16:32 UTC, Omkhar Arasaratnam (RETIRED)

Note You need to log in before you can comment on or make changes to this bug.
Description Anders Fredriksson 2004-08-24 06:30:49 UTC
We just bought a BladeCenter with two Power Blade JS20 servers to go with it. I have updated all the firmwares and got all the management utils up and running.
Communication to the power blades are restricted to serial console.

When booting, I arrive to the yaboot menu. If I select the serial console version, the server doesn't even boot at all. If I select the standard kernel, the kernel boots, but it can't find anything to use as root partition.

When in the Busybox shell. I don't see any IDE devices! These blades are using IDE for their internal disks and for the CD. 

Could it be that there is no IDE support in the LiveCD kernel? I guess IDE is quite uncommon for pseries platforms... 

Reproducible: Always
Steps to Reproduce:
1. Insert the LiveCD into the CD player of the BladeCenter
2. Switch the Media Tray control to the blade server you are booting
3. boot the server in the Serial over Lan console:
   - env -T system:blade[xx]
   - boot -c
4. In order to reset in serial console mode, hit: ESC R ESC r ESC R

Actual Results:  
When booting, I arrive to the yaboot menu. If I select the serial console
version, the server doesn't even boot at all. If I select the standard kernel,
the kernel boots, but it can't find anything to use as root partition.

When in the Busybox shell. I don't see any IDE devices! These blades are using
IDE for their internal disks.

Expected Results:  
The system should boot.

IBM Blade Center running Power Blade JS20 w/:

2: Power 970 processors
3. 512 MB Memory
4. 2x40 GB IDE disks
Comment 1 Tom Gall (RETIRED) gentoo-dev 2004-08-26 05:24:08 UTC
this is a ppc64 specific problem ...  probably not solved in the current beta4 cd, but I think something we can certainly resolve in a reasonable fashion
Comment 2 Tom Gall (RETIRED) gentoo-dev 2004-08-28 07:12:01 UTC
by the sounds of it .. need console on /dev/hvc0

and a new kernel built from the defconfig specific for the js20.

Any volunteers to test?
Comment 3 Anders Fredriksson 2004-08-28 10:23:30 UTC
I am more than willing to test it once compiled. I am not able to compile it myself though (since my pSeries isn't booting :).

Just supply me a link to an ISO and I will test it ASAP.
Comment 4 Tom Gall (RETIRED) gentoo-dev 2004-08-29 10:03:52 UTC
Thanks Anders, I'll put something together this evening!  (Aug 29th / CST)
Comment 5 Tom Gall (RETIRED) gentoo-dev 2004-08-30 19:17:47 UTC
the pSeries livecd (beta5) now has a js20 kernel on it. 

Not sure I have the console bits done correctly so please test.

if you do get to a login prompt:  root   pw : gentoo

Enjoy, looking forward to your feedback!
Comment 6 Anders Fredriksson 2004-09-01 02:13:37 UTC
It works better now but doesn't come all the way through. When I check the devices list, I now see both hda, hdc and also and sda. However, I can't seem to find the cd anywhere. Not even under the /dev/ide directory which only seems to include my two internal disks.

The closest match is the /dev/sda, which reports "no medium found" when I try to boot it. When I check the device-tree/aliases, the alias for cdrom is: 


I donno if this helps or if I am missing some other way around it.
Comment 7 Hiroki Ito 2004-09-06 05:21:28 UTC

I have a same problem.
When I tried to boot my JS20 in the same way as Anders does,
I got the message like below.

NET: Registered protocol family 1
NET: Registered protocol family 17
Loading modules...
Mounting filesystems
Attempting to mount CD:- /newroot/dev/cdroms/*
Attempting to mount CD:- /newroot/dev/ide/cd/*
Could not find CD to boot, something else needed!
Determining root device...^[[0m
The root block device is unspecified or not detected.
Please specify a device to boot, or "shell" for a shell...
boot ():

Comment 8 Tom Gall (RETIRED) gentoo-dev 2004-09-15 20:29:10 UTC
beta 6 of the livecds with JS20 support has just been released.

Hopefully it's a step in the right direction. 

I am still a bit concerned that the root device isn't quite right. I would really like to understand where the cdrom is in /dev space. Or perhaps if there are udev rules that are missing that are needed for this device. Sadly this is one of those situations if I had access to a JS20 it would probably only take perhaps an afternoon to get this sorted out.

For those that commented on this bug, if you are presented with that prompt again, enter :

shell <return>

then cd /dev and look to see if there is a usb directory or akin that would seem to indicate the usb cdrom. Thanks!
Comment 9 Tom Gall (RETIRED) gentoo-dev 2004-09-16 20:11:34 UTC
Greetings, I have made some further adjustments and am uploading beta7 now for js20 and power5 hardware.  Please test and post your experiences! Thanks!
Comment 10 Anders Fredriksson 2004-09-17 07:06:35 UTC
Sorry, there is nothing indicating any usb device. During bootup, the usb init seems ok though. Finds a hub and such things.

When trying to mount sda, I get "no medium found". This could be connected to the remote disk feature that BladeCenters come with.

In the docs about how to configure SuSe, IBM mentions a cd on /dev/sdc. Maybe we need som ide-scsi -like emulation?



listing of /dev
discs  loop   loop3  loop7  ram0   ram12  ram2   ram6   rd
hda    loop0  loop4  md     ram1   ram13  ram3   ram7   sda
hdc    loop1  loop5  md0    ram10  ram14  ram4   ram8
ide    loop2  loop6  null   ram11  ram15  ram5   ram9
Comment 11 Tom Gall (RETIRED) gentoo-dev 2004-09-17 09:47:44 UTC
I gather from your /dev directory you have two IDE hard drives?
Comment 12 Omkhar Arasaratnam (RETIRED) gentoo-dev 2004-09-17 10:19:29 UTC

JS20's are funky beasts.

1) The SOL (Serial Over LAN) is done via private vLAN off eth1 so depending on how the module goes in there maybe a temporary loss in SOL connectivity on bringup
2) The HDD's are indeed IDE
3) The CDROM, (and KVM functionality in HSx0 land) are all done over USB - so if the bringup isn't mounting root it could be due to a lack of the usb mass storage kernel module.

Either way I'll try and grab a blade and have a look see (should be later today if Matt wakes up :-)

btw console -T blade[x] is an easier way of switching to the blade
Comment 13 Tom Gall (RETIRED) gentoo-dev 2004-09-24 20:07:51 UTC
appears we need some combo of hotplug and USB support.  Next livecd will contain USB storage support.  (tho I gotta figure out if we need hotplug in the initrd, I hope not)  

So keep your eyes peeled for beta 8!
Comment 14 Tom Gall (RETIRED) gentoo-dev 2004-09-25 21:00:21 UTC
beta 8 is released!  
Comment 15 Omkhar Arasaratnam (RETIRED) gentoo-dev 2004-09-27 16:00:20 UTC
Still doesn't bring up the boot CD properly - debugging continues
Comment 16 Omkhar Arasaratnam (RETIRED) gentoo-dev 2004-09-27 18:18:24 UTC
Ok this is super wierd, if we jump to a shell from the busybox prompt the following shows up:


However there appears to be no /dev/ entry

I will continue sniffing around
Comment 17 Omkhar Arasaratnam (RETIRED) gentoo-dev 2004-09-27 19:56:02 UTC
Just checked the Red Hat RHEL3 kernel and confirmed there are no JS20 specific kernel patches for USB - the search for my missing USB CDROM continues ;-(
Comment 18 Omkhar Arasaratnam (RETIRED) gentoo-dev 2004-09-28 16:32:37 UTC
Created attachment 40668 [details]
New JS20 Config

Here she is - please include in beta9
Comment 19 Omkhar Arasaratnam (RETIRED) gentoo-dev 2004-09-30 09:09:49 UTC
spoke with greg_kh - heading down the wrong path on this - more to come
Comment 20 Omkhar Arasaratnam (RETIRED) gentoo-dev 2004-10-04 13:18:28 UTC
Looks like we're missing some udev goodies in the initrd - tgall will have to respin the CD.
Comment 21 Omkhar Arasaratnam (RETIRED) gentoo-dev 2004-10-14 11:34:35 UTC
OK - spoke to gregkh at work today and seems last night's drop of udev should resolve the issue <yay greg>

tgall - Can you please spin up a new live cd (with all the udev goodies we need in the initrd) when you get a chance?

Comment 22 Tom Gall (RETIRED) gentoo-dev 2004-10-23 19:40:24 UTC
alrighty, 2004.3 has udev support in catalyst so shouldn't have to be fighting upstream as it were. I've generated a new pSeries js20 power5 etc etc etc livecd, please test!
Comment 23 Tom Gall (RETIRED) gentoo-dev 2004-11-10 19:43:35 UTC
reopening ...  based on current testing update2 from 2004.3 is having issues on the js20.  Time to go into concentrated debug on this one!
Comment 24 Omkhar Arasaratnam (RETIRED) gentoo-dev 2004-12-31 18:11:51 UTC
Holiday seasons lead to drinking.
Drinking leads to not working on defects.
Lets (IBMers) concentrate on the this defect once new years celebrations are over.

Comment 25 Markus Rothe (RETIRED) gentoo-dev 2005-03-13 03:30:31 UTC
can you please test latest livecd available here:
Comment 26 Markus Rothe (RETIRED) gentoo-dev 2005-03-15 06:40:39 UTC
come on guys! You want to test this, don't you?
Comment 27 Holger Wolf 2005-03-23 04:34:15 UTC
did test on a JS20 and a openpower720. Boot stopped, still got no prompt on the SOL.

 * Not Loading APM Bios support....  [ ok ]
 * Network device  eth0
  eth1 detected, DHCP broadcasting for IP....  [ ok ]
 * Starting hdparm...  [ ok ]
 * Running hdparm on /dev/discs/disc0/disc... * Auto-scrambling root password for security...  [ ok ]
 * Starting local...  [ ok ]
tg3: tg3_stop_block timed out, ofs=4000 enable_bit=2
INIT: Id "c1" respawning too fast: disabled for 5 minutes
INIT: no more processes left in this runlevel
INIT: Id "c1" respawning too fast: disabled for 5 minutes
... Just repeats the last message
Comment 28 Holger Wolf 2005-03-30 02:28:46 UTC
now it works on JS20 and got a shell. looks good.

Comment 29 Markus Rothe (RETIRED) gentoo-dev 2005-03-30 10:59:59 UTC
thx for the info. please reopen if anything changes.
Comment 30 Tom Gall (RETIRED) gentoo-dev 2005-03-31 09:40:15 UTC
I've had several reports of success on the JS20 on 2005.0 .. closing this bug out