Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 614262 - =media-video/vlc-2.2.4-r1[lua]'s subtitle downloader (vlsub) hangs and/or misbehaves
Summary: =media-video/vlc-2.2.4-r1[lua]'s subtitle downloader (vlsub) hangs and/or mis...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: media-video herd
URL: https://github.com/exebetche/vlsub/is...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-03-30 04:36 UTC by Greg Turner
Modified: 2017-06-12 20:02 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
vlsub-fix.patch (vlsub-fix.patch,19.07 KB, patch)
2017-03-30 04:52 UTC, Greg Turner
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Greg Turner 2017-03-30 04:36:18 UTC
This bug has been around literally for years.  It's a resolved upstream-upstream bug insofar as the VLSub.lua bundled with vlc-2.2.4 tarball is old and has problems but the upstream-upstream bleeding-edge vlsub.lua works much better and despite the wierd capitalization change is suitable as a drop-in replacement:

https://github.com/exebetche/vlsub/blob/dcb7eaae4837a7d53b903a3b09acc2b01a09e099/vlsub.lua

Attached patch "backports" this revision into the 2.2.4-r1 vlc source tree unpacked by portage.

I chose this revision, the un-relased head of the vlsub master branch, because, as I investigated, I came across (but did not verify) several reports that the HTTP 1.1 change in the tip commit above happens to be important for some users (something to do with Cloudflare, they said, iirc).

Anyhow, since we seem to be staying here on 2.2.4 for a while -- and since, for that matter, it's not known to me whether vlc has even updated the vendored VLSub.lua in their own git (assuming that's how it gets there).

So, i.e., =media-video/vlc-9999 might well, or, equally, might well not, still suffer from this same problem, and, for all I know, still respond positively to the same medicine.  Anyhow it fixes this longstanding bug for me and a couple other people out there on github
Comment 1 Greg Turner 2017-03-30 04:52:33 UTC
Created attachment 468618 [details, diff]
vlsub-fix.patch

oops, forgot the patch.  One other note -- this is not /exactly/ upstreams version -- I change the value of the shortdesc variable to "Download Subtitles" on line 73 because vlc puts this value into its menus.

Since vlc developers have presumably chosen to put the option to download subtitles in the most counter-intuitive place they could think of, having the menu item text change from "Download Subtitles" to "VLSub" would represent a an unacceptable regression as only a dev would ever know what that means.