Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 613884 - x11-drivers/nvidia-drivers-340 fail to compile with kernel-4.10
Summary: x11-drivers/nvidia-drivers-340 fail to compile with kernel-4.10
Status: RESOLVED DUPLICATE of bug 610058
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Jeroen Roovers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-03-26 10:14 UTC by Sven Müller
Modified: 2017-03-30 12:38 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Patch to compile x11-drivers/nvidia-drivers-340.120 with kernel-4.10 (nvidia-4.10.patch,2.05 KB, patch)
2017-03-26 10:17 UTC, Sven Müller
Details | Diff
updated Patch (nvidia-4.10-r1.patch,4.42 KB, patch)
2017-03-28 18:35 UTC, Sven Müller
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Sven Müller 2017-03-26 10:14:30 UTC
I use an old Nvidia Quadro FX 3800, which runs with nvidia-drivers-340.x. The last available version in this slot in Portage is 340.120, which doesn't compile with kernel-4.10.x. 

Last part of the error message:
make[2]: *** [/usr/src/linux-4.10.5-gentoo/Makefile:1490: _module_/var/tmp/portage/x11-drivers/nvidia-drivers-340.102/work/kernel] Error 2
make[2]: Leaving directory '/usr/src/linux-4.10.5-gentoo'
make[1]: *** [Makefile:150: sub-make] Error 2
make[1]: Leaving directory '/usr/src/linux-4.10.5-gentoo'
NVIDIA: left KBUILD.
nvidia.ko failed to build!
make: *** [Makefile:185: nvidia.ko] Error 1
 * ERROR: x11-drivers/nvidia-drivers-340.102::gentoo failed (compile phase):
 *   emake failed
 * 
 * If you need support, post the output of `emerge --info '=x11-drivers/nvidia-drivers-340.102::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=x11-drivers/nvidia-drivers-340.102::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/x11-drivers/nvidia-drivers-340.102/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-drivers/nvidia-drivers-340.102/temp/environment'.
 * Working directory: '/var/tmp/portage/x11-drivers/nvidia-drivers-340.102/work/kernel'
 * S: '/var/tmp/portage/x11-drivers/nvidia-drivers-340.102/work/'

 * Messages for package x11-drivers/nvidia-drivers-340.102:

 * Gentoo supports kernels which are supported by NVIDIA
 * which are limited to the following kernels:
 * <sys-kernel/gentoo-sources-4.10
 * <sys-kernel/vanilla-sources-4.10
 * 
 * You are free to utilize eapply_user to provide whatever
 * support you feel is appropriate, but will not receive
 * support as a result of those changes.
 * 
 * Do not file a bug report about this.
 *
Comment 1 Sven Müller 2017-03-26 10:17:16 UTC
Created attachment 468346 [details, diff]
Patch to compile x11-drivers/nvidia-drivers-340.120 with kernel-4.10

I took this patch:

https://devtalk.nvidia.com/default/topic/994087/linux/387-13-patch-for-4-10-0-rc8-linus-master-/

and removed the stuff, which isn't available in the 340-branch. For me it compiles and runs fine so far. 

Please check, if it usable for general purpose.
Comment 2 Sven Müller 2017-03-28 18:35:13 UTC
Created attachment 468528 [details, diff]
updated Patch

Newer patch taken from here:
https://gist.github.com/tpruzina/c4d9c0ca6bdbb6e78ab2126a7cdf8f1c
Comment 3 Jeroen Roovers gentoo-dev 2017-03-30 12:38:54 UTC

*** This bug has been marked as a duplicate of bug 610058 ***