Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 61287 - sys-darwin/bootstrap_cmds-44.ebuild (New Package)
Summary: sys-darwin/bootstrap_cmds-44.ebuild (New Package)
Status: VERIFIED DUPLICATE of bug 58597
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: PPC Linux
: High normal (vote)
Assignee: osx porters
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-08-22 12:58 UTC by Thomas Stratmann
Modified: 2005-02-06 13:33 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
sys-darwin/bootstrap_cmds-44.ebuild intial submission (bootstrap_cmds-44.ebuild,697 bytes, text/plain)
2004-08-22 13:01 UTC, Thomas Stratmann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Stratmann 2004-08-22 12:58:03 UTC
darwin bootstrap_cmds-44. they are supposed to be needed for the creation of a gentoo-darwin livecd, maybe more.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.




!!! Using `which gcc` to gcc locate version, this may break
!!! DISTCC, installing gcc-config and setting your current gcc
!!! profile will fix this
Portage 20040726 (default-macos-10.3, gcc-3.3, unavailable, 7.4.0 Power
Macintosh powerpc)
=================================================================
System uname: 7.4.0 Power Macintosh powerpc
macos-20040726
distcc 2.0.1-zeroconf powerpc-apple-darwin7.0 (protocol 1) (default port 3632)
[disabled]
Autoconf: 
Automake: 
Binutils: 
ACCEPT_KEYWORDS="macos"
AUTOCLEAN="yes"
CFLAGS="-O2 -pipe"
CHOST="powerpc-apple-darwin"
COMPILER="gcc3"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config
/usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="collision-protect cvs keepwork"
GENTOO_MIRRORS="http://gentoo.osuosl.org/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/portage-overlay"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="macos"
Comment 1 Thomas Stratmann 2004-08-22 13:01:11 UTC
Created attachment 37961 [details]
sys-darwin/bootstrap_cmds-44.ebuild intial submission
Comment 2 Thomas Stratmann 2004-08-23 13:29:11 UTC
Bug 58597 was already open on this issue, I overlooked it. Sorry for that.

The current version (attachment 37158 [details]) installs temporary files in /tmp during compilation, this is normal darwin makefiles behaviour. The above attachement solves that, but is generally less clean.
Comment 3 Thomas Stratmann 2004-08-23 14:18:47 UTC

*** This bug has been marked as a duplicate of 58597 ***
Comment 4 Hasan Khalil (RETIRED) gentoo-dev 2005-02-06 13:33:26 UTC
Closing out bugs that've been resolved for a while now...