Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 612616 - x11-terms/xfce4-terminal: Middle-click pasted text displays with a delay
Summary: x11-terms/xfce4-terminal: Middle-click pasted text displays with a delay
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: XFCE Team
Depends on:
Reported: 2017-03-14 13:16 UTC by David Mudrák
Modified: 2017-04-12 11:23 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

Output of emerge --info (emerge-info.txt,6.06 KB, text/plain)
2017-03-14 13:16 UTC, David Mudrák

Note You need to log in before you can comment on or make changes to this bug.
Description David Mudrák 2017-03-14 13:16:25 UTC
Created attachment 467016 [details]
Output of emerge --info

After the recent world upgrade, I am experiencing an annoying behaviour of the middle button paste feature.

In xfce4-terminal, when I select a text and paste it with the middle button click, there is a significant (yet random) delay before the text actually appears.

Sometimes the text is displayed almost instantly, sometimes there is (by guessing) like 0.5 - 1.0 second delay before it appears.

There is no delay in GUI applications (e.g. pasting into the address bar in a browser). This seems to affect CLI applications only.

I also realised that when I middle-click paste and then quickly press a key on the keyboard (such as a spacebar), the pasted text always appears, followed by the pressed key.

That made me think there is some kind of input buffer and the middle-click does not trigger the output update immediately (whereas the pressed key on the keyboard does).

It also seems to affect my trackball only (ID 046d:c408 Logitech, Inc. Marble Mouse, 4-button) while pasting with the touchpad seems to work same as it was before (triple-fingers simulation of the middle button click).

There were many packages upgraded during that world upgrade, among others there was ncurses upgrade from 5.9 to 6.0 and kernel upgrade to 4.9.6.

Unfortunately I can't downgrade ncurses to 5.9 any more. Attempting to mask and uninstall the 6.0-rc1 version led to unsatisfied dependencies and I was lucky enough to be able to install it back before everything broke.

I tried to search this tracker and google for various variants of "middle click paste delay ncurses" etc but with no success.
Comment 1 Mart Raudsepp gentoo-dev 2017-03-14 13:22:30 UTC
What input driver do you use? xf86-input-evdev as suggested by emerge --info, or perhaps also got xf86-input-libinput and ending up using that instead?
Just a question to try to narrow it down to what actually could have affected what you are seeing.
Comment 2 David Mudrák 2017-03-14 16:02:12 UTC
Thanks Mart. I don't have xf86-input-libinput installed and as you have correctly noticed, I have just

    INPUT_DEVICES="synaptics evdev"

The Xorg.0.log reports

    (II) Using input driver 'evdev' for 'Logitech USB Trackball'
    (II) Using input driver 'synaptics' for 'SynPS/2 Synaptics TouchPad'
Comment 3 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2017-04-08 06:22:55 UTC
Do I correctly understand that this only happens with xfce4-terminal? Could you possibly try some other Terminal emulator (x11-terms/)?
Comment 4 David Mudrák 2017-04-10 13:47:54 UTC
Yes, it may be specific to xfce4-terminal only. I can't reproduce it in x11-terms/rxvt where the pasted text is displayed instantly. Currently I have x11-terms/xfce4-terminal-0.6.3 and I will try to upgrade to latest 0.8.4
Comment 5 David Mudrák 2017-04-12 09:03:15 UTC
I can't reproduce it any more after upgrading to xfce4-terminal 0.8.4
Comment 6 David Mudrák 2017-04-12 11:23:11 UTC
(In reply to David Mudrak from comment #5)
> I can't reproduce it any more after upgrading to xfce4-terminal 0.8.4

Sorry I was wrong. The random delays are still present even with this new version (and I found that 0.8.4 does not open URLs by middle-clicking them any more so I will downgrade again).

It seems to me that problem is not present if I run X on the discrete GPU, only when I am on the integrated one.