Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 612378 - dev-python/pygobject-3.22.0: build fails due to wrong PYTHON_LIBS
Summary: dev-python/pygobject-3.22.0: build fails due to wrong PYTHON_LIBS
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo/Alt
Classification: Unclassified
Component: Prefix Support (show other bugs)
Hardware: All OS X
: Normal normal (vote)
Assignee: Gentoo Prefix
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-03-11 23:42 UTC by *
Modified: 2017-09-21 21:11 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
environment (environment,169.47 KB, text/plain)
2017-03-11 23:42 UTC, *
Details
build.log (build.log.xz,6.19 KB, application/x-xz)
2017-03-11 23:43 UTC, *
Details
pygobject-3.22.0.ebuild (pygobject-3.22.0.ebuild,2.92 KB, text/plain)
2017-03-11 23:43 UTC, *
Details
pygobject-3.22.0-libs.patch (pygobject-3.22.0-libs.patch,457 bytes, patch)
2017-03-11 23:43 UTC, *
Details | Diff
0001-testhelper-only-link-against-libpython-on-Windows.patch (0001-testhelper-only-link-against-libpython-on-Windows.patch,2.41 KB, patch)
2017-09-13 07:03 UTC, Gilles Dartiguelongue
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description * 2017-03-11 23:42:21 UTC
My system is macOS Sierra (10.12.3) built from the latest bootstrap-prefix.sh. The build for pygobject fails with the following:

ld: -stack_size option can only be used when linking a main executable
clang-3.9: error: linker command failed with exit code 1 (use -v to see invocation)

That appears to be caused by configure using python-config --ldflags instead of python-config --libs, which on macOS gives the following:
-lpython3.5 -lintl -ldl -framework CoreFoundation -Wl,-stack_size,1000000 -framework CoreFoundation

pygobject is pulled in by media-libs/vips.

Reproducible: Always
Comment 1 * 2017-03-11 23:42:45 UTC
Created attachment 466748 [details]
environment
Comment 2 * 2017-03-11 23:43:08 UTC
Created attachment 466750 [details]
build.log
Comment 3 * 2017-03-11 23:43:29 UTC
Created attachment 466752 [details]
pygobject-3.22.0.ebuild
Comment 4 * 2017-03-11 23:43:51 UTC
Created attachment 466754 [details, diff]
pygobject-3.22.0-libs.patch
Comment 5 Fabian Groffen gentoo-dev 2017-03-19 16:28:54 UTC
@maintainers: is this patch OK with you?
Comment 6 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2017-03-19 16:42:21 UTC
Was this reported upstream? The patch seems quite upstreamable to me.
Comment 7 * 2017-03-20 04:51:18 UTC
Sorry it looks like it was here:
https://bugzilla.gnome.org/show_bug.cgi?id=773803
Comment 8 Mart Raudsepp gentoo-dev 2017-03-21 00:56:59 UTC
I'd like to see some upstream ACK on it, or dig into it a bit later. I've CCed gnome team on the upstream bug to get notified when something moves there.
Comment 9 Fabian Groffen gentoo-dev 2017-06-21 08:28:25 UTC
Judging from this commit we have to wait for a next release:

https://git.gnome.org/browse/pygobject/commit/?id=b0476e2db4577e12b52caa3163ccb69575221d6c
Comment 10 Gilles Dartiguelongue gentoo-dev 2017-09-13 07:03:23 UTC
Created attachment 494294 [details, diff]
0001-testhelper-only-link-against-libpython-on-Windows.patch

Could you test this patch, it is a backport of the one that landed in 3.25.1.