Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 611418 - xfce-extra/xfce4-diskperf-plugin-2.6.1 : devperf.c:69:21: error: 'major' redeclared as different kind of symbol
Summary: xfce-extra/xfce4-diskperf-plugin-2.6.1 : devperf.c:69:21: error: 'major' rede...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: XFCE Team
URL:
Whiteboard:
Keywords:
: 639776 (view as bug list)
Depends on:
Blocks: glibc-sysmacros glibc-2.26-stable
  Show dependency tree
 
Reported: 2017-03-02 17:08 UTC by Toralf Förster
Modified: 2018-10-15 17:13 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,5.91 KB, text/plain)
2017-03-02 17:09 UTC, Toralf Förster
Details
config.log.tbz2 (config.log.tbz2,9.45 KB, application/x-bzip)
2017-03-02 17:09 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,338.04 KB, text/plain)
2017-03-02 17:09 UTC, Toralf Förster
Details
environment (environment,90.50 KB, text/plain)
2017-03-02 17:09 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,54.87 KB, application/x-bzip)
2017-03-02 17:09 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,24.88 KB, application/x-bzip)
2017-03-02 17:09 UTC, Toralf Förster
Details
xfce-extra:xfce4-diskperf-plugin-2.6.1:20170302-110404.log (xfce-extra:xfce4-diskperf-plugin-2.6.1:20170302-110404.log,21.23 KB, text/plain)
2017-03-02 17:09 UTC, Toralf Förster
Details
updated ebuild file which applies two patches (xfce4-diskperf-plugin-2.6.1.ebuild,1.35 KB, text/plain)
2018-01-28 14:25 UTC, Nico R.
Details
patch taken from upstream Git, with small change to patch configure.ac instead of configure.ac.in (xfce4-diskperf-plugin-2.6.1-upstream-fix-for-glibc-update.patch,1.11 KB, patch)
2018-01-28 14:26 UTC, Nico R.
Details | Diff
patch which avoids variables named ‘major’ or ‘minor’ (xfce4-diskperf-plugin-2.6.1-work-around-glibc-namespace-pollution.patch,2.14 KB, patch)
2018-01-28 14:27 UTC, Nico R.
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2017-03-02 17:08:58 UTC
  iMinorNo = minor(p_iDevice);
             ^
devperf.c:69:21: error: 'major' redeclared as different kind of symbol
     unsigned int    major, minor, rsect, wsect, ruse, wuse, use;
                     ^
devperf.c:65:32: note: previous implicit declaration of 'major' was here

  -----------------------------------------------------------------

  This is an unstable amd64 chroot image (named desktop-libressl_20170224-103028) at a hardened host acting as a tinderbox.

  -----------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-5.4.0 *
llvm-config:
3.9.1
Available Python interpreters, in order of preference:
  [1]   python3.4
  [2]   python2.7 (fallback)
  [3]   jython2.7 (fallback)

java-config:
The following VMs are available for generation-2:
*)	IcedTea JDK 3.3.0 [icedtea-bin-8]
Available Java Virtual Machines:
  [1]   icedtea-bin-8  system-vm
Comment 1 Toralf Förster gentoo-dev 2017-03-02 17:09:01 UTC
Created attachment 465764 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2017-03-02 17:09:04 UTC
Created attachment 465766 [details]
config.log.tbz2
Comment 3 Toralf Förster gentoo-dev 2017-03-02 17:09:07 UTC
Created attachment 465768 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2017-03-02 17:09:10 UTC
Created attachment 465770 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2017-03-02 17:09:13 UTC
Created attachment 465772 [details]
etc.portage.tbz2
Comment 6 Toralf Förster gentoo-dev 2017-03-02 17:09:17 UTC
Created attachment 465774 [details]
temp.tbz2
Comment 7 Toralf Förster gentoo-dev 2017-03-02 17:09:20 UTC
Created attachment 465776 [details]
xfce-extra:xfce4-diskperf-plugin-2.6.1:20170302-110404.log
Comment 8 Andreas K. Hüttel gentoo-dev 2017-10-20 20:27:57 UTC
Ping - this is now blocking glibc-2.25 stabilization.
Comment 9 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2017-10-20 22:04:41 UTC
I'm going to take a look at it now.
Comment 10 Nico R. 2018-01-28 14:25:07 UTC
Created attachment 516996 [details]
updated ebuild file which applies two patches
Comment 11 Nico R. 2018-01-28 14:26:06 UTC
Created attachment 516998 [details, diff]
patch taken from upstream Git, with small change to patch configure.ac instead of configure.ac.in
Comment 12 Nico R. 2018-01-28 14:27:01 UTC
Created attachment 517000 [details, diff]
patch which avoids variables named ‘major’ or ‘minor’
Comment 13 Nico R. 2018-01-28 14:47:18 UTC
The attached ebuild and patches allow the package to be emerged.

Upstream patch is <https://git.xfce.org/panel-plugins/xfce4-diskperf-plugin/commit/?id=0787a8972be2b95fac26c502a82427299e7e48c0> from Michał Górny, see <https://bugzilla.xfce.org/show_bug.cgi?id=13940#c5>.

Whether glibc should export symbols named ‘major’ and ‘minor’ at all, polluting developers’ namespaces, is subject of a different discussion.
Comment 14 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2018-01-28 16:30:00 UTC
*** Bug 639776 has been marked as a duplicate of this bug. ***
Comment 15 Larry the Git Cow gentoo-dev 2018-05-04 17:57:35 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=a78bbc4236ed08c205b57be153c900f9f6e7d32c

commit a78bbc4236ed08c205b57be153c900f9f6e7d32c
Author:     Andreas K. Hüttel <dilfridge@gentoo.org>
AuthorDate: 2018-05-04 17:57:15 +0000
Commit:     Andreas K. Hüttel <dilfridge@gentoo.org>
CommitDate: 2018-05-04 17:57:15 +0000

    xfce-extra/xfce4-diskperf-plugin: Add patch to avoid name clash, bug 611418
    
    Patch by Nico R.
    
    Closes: https://bugs.gentoo.org/611418
    Package-Manager: Portage-2.3.31, Repoman-2.3.9

 .../xfce4-diskperf-plugin-2.6.1-majorminor.patch   | 58 ++++++++++++++++++++++
 .../xfce4-diskperf-plugin-2.6.1.ebuild             |  2 +
 2 files changed, 60 insertions(+)