Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 610662 - net-libs/libnet-1.2_rc3-r1 - configure:2580: error: possibly undefined macro: AC_MSW_RESULT
Summary: net-libs/libnet-1.2_rc3-r1 - configure:2580: error: possibly undefined macro:...
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: ARM Linux
: Normal normal (vote)
Assignee: Netmon Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-02-23 09:21 UTC by herminio.hernandezjr
Modified: 2017-02-26 10:08 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
log file (libnet.log,3.05 KB, text/plain)
2017-02-23 09:21 UTC, herminio.hernandezjr
Details

Note You need to log in before you can comment on or make changes to this bug.
Description herminio.hernandezjr 2017-02-23 09:21:33 UTC
Created attachment 464824 [details]
log file

I am trying to build lxc on an RPI3 and this dependancy is failing to build. It looks like it is failing at the autoconf portion. Below is my emerge --info and will attach my log file.

gentoo-rpi3 rican-linux # emerge --info
Portage 2.3.0 (python 3.4.5-final-0, default/linux/arm/13.0/armv7a, gcc-4.9.4, glibc-2.23-r3, 4.4.16-v7+ armv7l)
=================================================================
System uname: Linux-4.4.16-v7+-armv7l-ARMv7_Processor_rev_4_-v7l-with-gentoo-2.3
KiB Mem:      947748 total,    472856 free
KiB Swap:    1048572 total,   1035148 free
Timestamp of repository gentoo: Fri, 27 Jan 2017 07:30:01 +0000
sh bash 4.3_p48-r1
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.3_p48-r1::gentoo
dev-lang/perl:            5.22.3_rc4::gentoo
dev-lang/python:          2.7.12::gentoo, 3.4.5::gentoo
dev-util/cmake:           3.5.2-r1::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/openrc:          0.22.4::gentoo
sys-apps/sandbox:         2.10-r1::gentoo
sys-devel/autoconf:       2.69::gentoo
sys-devel/automake:       1.11.6-r1::gentoo, 1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.9.4::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6-r2::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.4::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r3::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000

ACCEPT_KEYWORDS="arm"
ACCEPT_LICENSE="* -@EULA"
CBUILD="armv7a-hardfloat-linux-gnueabi"
CFLAGS="-O2 -pipe -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=hard"
CHOST="armv7a-hardfloat-linux-gnueabi"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.6/ext-active/ /etc/php/cgi-php5.6/ext-active/ /etc/php/cli-php5.6/ext-active/ /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=hard"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe -march=armv7-a"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe -march=armv7-a"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="acl apache2 arm armv5te armv6 armv6t2 berkdb bzip2 cli cracklib crypt cxx dri fortran gdbm iconv ipv6 modules ncurses nls nptl openmp pam pcre php readline seccomp session sqlite ssl tcpd unicode xattr zlib" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby21" USERLAND="GNU" VIDEO_CARDS="exynos fbdev omap dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Michael Palimaka (kensington) gentoo-dev 2017-02-23 10:19:39 UTC
Could you please also attach /var/tmp/portage/net-libs/libnet-1.2_rc3-r1/temp/autoconf.out?
Comment 2 herminio.hernandezjr 2017-02-23 20:57:37 UTC
Here is what you requested.

gentoo-rpi3 rican-linux # cat /var/tmp/portage/net-libs/libnet-1.2_rc3-r1/temp/autoconf.out
***** autoconf *****
***** PWD: /var/tmp/portage/net-libs/libnet-1.2_rc3-r1/work/libnet-1.2-rc3
***** autoconf --force

configure:2580: error: possibly undefined macro: AC_MSW_RESULT
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.
Comment 3 Jeroen Roovers (RETIRED) gentoo-dev 2017-02-26 10:08:32 UTC
(In reply to herminio.hernandezjr from comment #2)
> Here is what you requested.
> 
> gentoo-rpi3 rican-linux # cat
> /var/tmp/portage/net-libs/libnet-1.2_rc3-r1/temp/autoconf.out
> ***** autoconf *****
> ***** PWD: /var/tmp/portage/net-libs/libnet-1.2_rc3-r1/work/libnet-1.2-rc3
> ***** autoconf --force
> 
> configure:2580: error: possibly undefined macro: AC_MSW_RESULT
>       If this token and others are legitimate, please use m4_pattern_allow.
>       See the Autoconf documentation.

That should be AC_MSG_RESULT and the libnet sources don't have that anywhere.

You appear to have run into the same issue with libtool about a month ago[1]:

"""
cat /var/tmp/portage/sys-devel/libtool-2.4.6-r2/temp/autoconf.out 
***** autoconf ***** 
***** PWD: /var/tmp/portage/sys-devel/libtool-2.4.6-r2/work/libtool- 
2.4.6/libltdl 
***** autoconf --force 

configure:2433: error: possibly undefined macro: AC_MSW_RESULT 
      If this token and others are legitimate, please use 
m4_pattern_allow. 
      See the Autoconf documentation. 

I am not finding much help on Google and am checking to see if anyone 
else has run into this before filing a bug. 

Thanks! 
Herminio
"""

That's the only reference to AC_MSW_RESULT Google Search comes up with, so you should assume that the issue is local.


[1] https://lists.gt.net/gentoo/embedded/321998