Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 610652 - dev-libs/weston-1.11.0 : /.../weston-launch.c:363: undefined reference to `major'
Summary: dev-libs/weston-1.11.0 : /.../weston-launch.c:363: undefined reference to `ma...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
: 628052 (view as bug list)
Depends on:
Blocks: glibc-sysmacros glibc-2.26-stable
  Show dependency tree
 
Reported: 2017-02-23 07:53 UTC by Toralf Förster
Modified: 2018-04-29 22:07 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,6.02 KB, text/plain)
2017-02-23 07:53 UTC, Toralf Förster
Details
config.log.tbz2 (config.log.tbz2,11.78 KB, application/x-bzip)
2017-02-23 07:53 UTC, Toralf Förster
Details
dev-libs:weston-1.11.0:20170223-012107.log (dev-libs:weston-1.11.0:20170223-012107.log,120.68 KB, text/plain)
2017-02-23 07:53 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,298.47 KB, text/plain)
2017-02-23 07:53 UTC, Toralf Förster
Details
environment (environment,108.85 KB, text/plain)
2017-02-23 07:53 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,25.34 KB, application/x-bzip)
2017-02-23 07:53 UTC, Toralf Förster
Details
weston-launch patch for major/minor (weston-launch-glibc.patch,324 bytes, patch)
2017-08-09 07:03 UTC, Jan Psota
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2017-02-23 07:53:23 UTC
libtool: link: x86_64-pc-linux-gnu-gcc -Wall -Wextra -Wno-unused-parameter -Wno-missing-field-initializers -g -fvisibility=hidden -Wstrict-prototypes -Wmissing-prototypes -Wsign-compare -I/usr/include/libdrm -O2 -pipe -march=native -Wall -Wl,-O1 -Wl,--as-needed -o weston-launch src/weston_launch-weston-launch.o  -lpam -ldrm
src/weston_launch-weston-launch.o: In function `handle_open':
/var/tmp/portage/dev-libs/weston-1.11.0/work/weston-1.11.0/src/weston-launch.c:363: undefined reference to `major'

  -----------------------------------------------------------------

  This is an unstable amd64 chroot image (named plasma-abi32+64_20170216-195507) at a hardened host acting as a tinderbox.

  -----------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-5.4.0 *
llvm-config:
3.9.1
Available Python interpreters, in order of preference:
  [1]   python3.4
  [2]   python3.5 (fallback)
  [3]   python2.7 (fallback)
  [4]   jython2.7 (fallback)
Available Ruby profiles:
  [1]   ruby21 (with Rubygems) *
java-config:
The following VMs are available for generation-2:
1)	IcedTea JDK 7.2.6.8 [icedtea-bin-7]
*)	IcedTea JDK 3.3.0 [icedtea-bin-8]
Available Java Virtual Machines:
  [1]   icedtea-bin-7 
  [2]   icedtea-bin-8  system-vm
Comment 1 Toralf Förster gentoo-dev 2017-02-23 07:53:27 UTC
Created attachment 464786 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2017-02-23 07:53:30 UTC
Created attachment 464788 [details]
config.log.tbz2
Comment 3 Toralf Förster gentoo-dev 2017-02-23 07:53:33 UTC
Created attachment 464790 [details]
dev-libs:weston-1.11.0:20170223-012107.log
Comment 4 Toralf Förster gentoo-dev 2017-02-23 07:53:36 UTC
Created attachment 464792 [details]
emerge-history.txt
Comment 5 Toralf Förster gentoo-dev 2017-02-23 07:53:39 UTC
Created attachment 464794 [details]
environment
Comment 6 Toralf Förster gentoo-dev 2017-02-23 07:53:42 UTC
Created attachment 464796 [details]
etc.portage.tbz2
Comment 7 Jan Psota 2017-08-09 07:03:15 UTC
Created attachment 488376 [details, diff]
weston-launch patch for major/minor

According to NEWS if glibc-2.25:
* The inclusion of <sys/sysmacros.h> by <sys/types.h> is deprecated.  This
  means that in a future release, the macros “major”, “minor”, and “makedev”
  will only be available from <sys/sysmacros.h>.

The same error occurred on 1.12.0 for me.

Attached patch should be applied by all weston ebuilds.
Resolved.
Comment 8 Andreas Sturmlechner gentoo-dev 2017-08-19 08:29:34 UTC
*** Bug 628052 has been marked as a duplicate of this bug. ***
Comment 9 James Le Cuirot gentoo-dev 2017-09-14 12:15:20 UTC
This is fixed in 3.0.0. It was addressed by upstream.
Comment 10 Andreas K. Hüttel gentoo-dev 2018-04-27 23:09:00 UTC
(In reply to James Le Cuirot from comment #9)
> This is fixed in 3.0.0. It was addressed by upstream.

Please either backport or stabilize 3.0.0, your decision.
Comment 11 Larry the Git Cow gentoo-dev 2018-04-29 22:07:06 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=0a594acda7bfbae3c55c54c9d0c521f362c2843d

commit 0a594acda7bfbae3c55c54c9d0c521f362c2843d
Author:     Andreas K. Hüttel <dilfridge@gentoo.org>
AuthorDate: 2018-04-29 22:06:51 +0000
Commit:     Andreas K. Hüttel <dilfridge@gentoo.org>
CommitDate: 2018-04-29 22:07:00 +0000

    dev-libs/weston: Add build fix for glibc-2.26, bug 610652
    
    Oh well, this one was really easy.
    
    Closes: https://bugs.gentoo.org/610652
    Package-Manager: Portage-2.3.31, Repoman-2.3.9

 dev-libs/weston/files/weston-1.11.0-sysmacros.patch | 11 +++++++++++
 dev-libs/weston/weston-1.11.0.ebuild                |  5 +++--
 2 files changed, 14 insertions(+), 2 deletions(-)