Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 60959 - K3B ebuild puts some files in the wrong place.
Summary: K3B ebuild puts some files in the wrong place.
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Heinrich Wendel (RETIRED)
URL: http://www.whitepost.pwp.blueyonder.c...
Depends on:
Reported: 2004-08-19 16:07 UTC by James Cort
Modified: 2004-08-26 03:31 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description James Cort 2004-08-19 16:07:32 UTC
There are two with k3b under KDE 3.2.3 related to files being in the wrong place.

1. Various images (most noticeably the splash screen) don't appear, making the program look very unprofessional.
2. k3bsetup doesn't work, "Library files for "" not found in paths".

Both of these errors are found in both the stable and the most recent unstable ebuilds.

Reproducible: Always
Steps to Reproduce:
1. emerge kde version 3.2.3r1
2. emerge qt version 3.3.3
3. emerge k3b (either the most recent or the unstable)

Actual Results:  
Run k3b - you should see something similar to the image referenced above.

Run k3bsetup - you should get the error described above.

Expected Results:  
A pretty splash screen should have appeared when running k3b.

k3bsetup should start a program which allows the user to configure various
aspects of k3b.

The problem seems to be that a number of files are placed in /usr/share/,
/usr/lib/ rather than /usr/kde/....

The splash screen & other graphics issues may be worked around by adding the
following symlink:

ln -s /usr/share/apps/k3b  /usr/kde/3.2/share/apps/

The k3bsetup issue may be worked around as follows:

cp /usr/lib/kde3/kcm_k3bsetup2.* /usr/kde/3.2/lib/kde3/

You must be logged in as root to do either of these.

I am logging this as major because the k3bsetup bug effectively prevents an
inexperienced user from configuring k3b without a lot of digging around.
Comment 1 Heinrich Wendel (RETIRED) gentoo-dev 2004-08-20 15:11:44 UTC
It works fine here. The files should not be in /usr/kde since they don't belong to the default installation.
Comment 2 Gregorio Guidi (RETIRED) gentoo-dev 2004-08-26 02:28:17 UTC
Right, all should work well as long as KDEDIRS is defined,
could you try running 'KDEDIRS="/usr" k3b' ?
Comment 3 Heinrich Wendel (RETIRED) gentoo-dev 2004-08-26 02:46:47 UTC
the locations of the files are correct, could you get it working?
Comment 4 James Cort 2004-08-26 03:31:26 UTC
I finally found the problem yesterday evening. For some reason, kde-env needed to be re-emerged.

Sorry for the trouble.