Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 609036 - dev-util/global[vim] - not satisfied by app-editors/neovim
Summary: dev-util/global[vim] - not satisfied by app-editors/neovim
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Naohiro Aota
URL:
Whiteboard:
Keywords:
Depends on: 586882
Blocks:
  Show dependency tree
 
Reported: 2017-02-12 05:21 UTC by Bearcat M. Sandor
Modified: 2019-10-28 15:10 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bearcat M. Sandor 2017-02-12 05:21:32 UTC
I run neovim, not vim, and i'm trying to emerge dev-util/global. dev-utils/global has the 'vim' flag: 

vim   : Integrate the GNU GLOBAL source code tag system with Vim

which of course i need. 

However, if i have the vim flag enabled it tries to install vim which i don't need since i run nvim: 

Calculating dependencies... done! 
[ebuild  N     ] app-editors/vim-core-8.0.0106::gentoo  USE="acl nls -minimal" 0 KiB 
[ebuild  N     ] app-editors/vim-8.0.0106::gentoo  USE="X acl gpm lua nls perl python ruby vim-pager -cscope -debug -luajit -minimal -racket (-selinux) -tcl" PYTHON_TARGETS="python3_5 -python2_7 -python3_4" 0 KiB 
[ebuild  N     ] dev-util/global-6.3.1::gentoo  USE="vim -doc -emacs" 1,338 KiB 


I have nvim enabled via eselect 

Available vi implementations: 
  [1]   vim 
  [2]   nvim * 
  [3]   busybox 

app-editors/neovim should provide vim for the vim useflag.
Comment 1 Arfrever Frehtes Taifersar Arahesis 2019-08-07 22:58:20 UTC
We should wait and see what solution will be applied for bug #586882.