Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 608484 - x11-drivers/xf86-video-virtualbox fails to build with >=kernel-4.9
Summary: x11-drivers/xf86-video-virtualbox fails to build with >=kernel-4.9
Status: RESOLVED DUPLICATE of bug 598800
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Lars Wendler (Polynomial-C)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-02-06 21:13 UTC by Valmor de Almeida
Modified: 2017-03-04 16:06 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info output (info.txt,5.30 KB, text/plain)
2017-02-06 21:13 UTC, Valmor de Almeida
Details
zipped build log file (build.log.zip,55.95 KB, application/zip)
2017-02-06 21:18 UTC, Valmor de Almeida
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Valmor de Almeida 2017-02-06 21:13:29 UTC
Created attachment 462710 [details]
emerge --info output

Unable to emerge virtualbox-5.0.32. The dependency xf86-video-virtualbox-5.0.32 does not compile.

 [31;01m*[0m ERROR: x11-drivers/xf86-video-virtualbox-5.0.32::gentoo failed (compile phase):
 [31;01m*[0m   emake failed
 [31;01m*[0m 
 [31;01m*[0m If you need support, post the output of `emerge --info '=x11-drivers/xf86-video-virtualbox-5.0.32::gentoo'`,
 [31;01m*[0m the complete build log and the output of `emerge -pqv '=x11-drivers/xf86-video-virtualbox-5.0.32::gentoo'`.
 [31;01m*[0m The complete build log is located at '/var/tmp/portage/x11-drivers/xf86-video-virtualbox-5.0.32/temp/build.log'.
 [31;01m*[0m The ebuild environment file is located at '/var/tmp/portage/x11-drivers/xf86-video-virtualbox-5.0.32/temp/environment'.
 [31;01m*[0m Working directory: '/var/tmp/portage/x11-drivers/xf86-video-virtualbox-5.0.32/work/VirtualBox-5.0.32/src/VBox/Runtime'
 [31;01m*[0m S: '/var/tmp/portage/x11-drivers/xf86-video-virtualbox-5.0.32/work/VirtualBox-5.0.32'
Comment 1 Valmor de Almeida 2017-02-06 21:18:26 UTC
Created attachment 462712 [details]
zipped build log file

Build file attached
Comment 2 Valmor de Almeida 2017-02-06 21:22:07 UTC
output of emerge -pqv '=x11-drivers/xf86-video-virtualbox-5.0.32::gentoo'


[ebuild  N    ] x11-drivers/xf86-video-virtualbox-5.0.32  USE="dri" PYTHON_TARGETS="python2_7" 
[ebuild  N    ] app-emulation/virtualbox-guest-additions-5.0.32  USE="X"
Comment 3 Valmor de Almeida 2017-02-07 03:35:28 UTC
I have also tried all other ebuild versions either lower versions than 5.0.32 and higher (unstable) versions. All of them have the same problem. I also removed xorg from the system and re emerged everything and the problem persists.
Therefore I am beginning to think there is some other problem since at least one ebuild should work.
Comment 4 Valmor de Almeida 2017-02-07 04:37:21 UTC
Not sure whether this additional information will help but the virtualbox package:  virtualbox-guest-additions-5.0.32 also does not compile and it has a similar compilation error as the video driver.
Comment 5 Lars Wendler (Polynomial-C) gentoo-dev 2017-02-09 19:28:20 UTC
This is unfortunately an issue with kernel-4.9

According to virtualbox upstream this will need some time to get fixed.
Comment 6 Lars Wendler (Polynomial-C) gentoo-dev 2017-03-04 16:06:57 UTC

*** This bug has been marked as a duplicate of bug 598800 ***