Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 608314 - media-libs/libsdl2-2.0.5 on PPC64 - .../work/SDL2-2.0.5/src/video/SDL_blit_N.c:127:5: error: ISO C90 forbids mixed declarations and code [-Werror=declaration-after-statement]
Summary: media-libs/libsdl2-2.0.5 on PPC64 - .../work/SDL2-2.0.5/src/video/SDL_blit_N....
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: PPC64 Linux
: Normal normal (vote)
Assignee: Gentoo Games
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-02-05 12:29 UTC by Jeroen Roovers
Modified: 2018-04-18 18:21 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
media-libs:libsdl2-2.0.5:20170205-122041.log (media-libs:libsdl2-2.0.5:20170205-122041.log,20.28 KB, text/x-log)
2017-02-05 12:29 UTC, Jeroen Roovers
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jeroen Roovers gentoo-dev 2017-02-05 12:29:31 UTC
Created attachment 462526 [details]
media-libs:libsdl2-2.0.5:20170205-122041.log

CC     build/SDL_blit_N.lo
/var/tmp/portage/media-libs/libsdl2-2.0.5/work/SDL2-2.0.5/src/video/SDL_blit_N.c: In function ‘calc_swizzle32’:
/var/tmp/portage/media-libs/libsdl2-2.0.5/work/SDL2-2.0.5/src/video/SDL_blit_N.c:127:5: error: ISO C90 forbids mixed declarations and code [-Werror=declaration-after-statement]
     const vector unsigned char plus = VECUINT8_LITERAL(0x00, 0x00, 0x00, 0x00,
     ^
Comment 1 James Le Cuirot gentoo-dev 2017-02-05 13:05:39 UTC
CC'ing Lars as he bumped it. I can't reproduce it with gcc 5.4.0 though. Something ppc64 specific perhaps? Unfortunately timberdoodle is dead and I'm waiting on others before I can rebuild it.
Comment 2 Jeroen Roovers gentoo-dev 2017-02-05 13:38:10 UTC
[ebuild  N    ~] media-libs/libsdl2-2.0.5::gentoo  USE="X alsa altivec fusionsound joystick opengl sound
threads video (-custom-cflags) -dbus -gles -haptic -nas -oss -pulseaudio -static-libs -tslib -udev -wayland -xinerama -xscreensaver" 0 KiB
Comment 3 James Le Cuirot gentoo-dev 2017-02-05 14:09:12 UTC
(In reply to Jeroen Roovers from comment #2)
> [ebuild  N    ~] media-libs/libsdl2-2.0.5::gentoo  USE="X alsa altivec
> fusionsound joystick opengl sound
> threads video (-custom-cflags) -dbus -gles -haptic -nas -oss -pulseaudio
> -static-libs -tslib -udev -wayland -xinerama -xscreensaver" 0 KiB

Just tried with those flags (except altivec) and still works here.
Comment 4 Lars Wendler (Polynomial-C) gentoo-dev 2017-02-05 17:35:45 UTC
I can't reproduce it either. So I suppose this is a ppc specific issue...
Somehow I doubt it's gcc-5 related.
Comment 5 Jeroen Roovers gentoo-dev 2017-02-05 21:25:54 UTC
(In reply to Lars Wendler (Polynomial-C) from comment #4)
> Somehow I doubt it's gcc-5 related.

Correct.
Comment 6 Pacho Ramos gentoo-dev 2018-02-28 15:10:04 UTC
is this still happening with 2.0.7?