Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 608048 - dev-java/jsr250-1.2 - eapply_user (or default) must be called in src_prepare()
Summary: dev-java/jsr250-1.2 - eapply_user (or default) must be called in src_prepare()
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Java team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-02-02 14:19 UTC by Martin Mokrejš
Modified: 2021-04-10 06:47 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Mokrejš 2017-02-02 14:19:12 UTC
>>> Emerging (1 of 5) dev-java/jsr250-1.2::gentoo
 * jsr250-1.2.jar SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                                                                                                                                                                                                                  [ ok ]
 * Using: oracle-jdk-bin-1.8
>>> Unpacking source...
>>> Unpacking jsr250-1.2.jar to /apps/gentoo/var/tmp/portage/dev-java/jsr250-1.2/work
>>> Source unpacked in /apps/gentoo/var/tmp/portage/dev-java/jsr250-1.2/work
>>> Preparing source in /apps/gentoo/var/tmp/portage/dev-java/jsr250-1.2/work ...
 * ERROR: dev-java/jsr250-1.2::gentoo failed (prepare phase):
 *   eapply_user (or default) must be called in src_prepare()!
 * 
 * Call stack:
 *            ebuild.sh, line  767:  Called __ebuild_main 'prepare'
 *   phase-functions.sh, line 1007:  Called __dyn_prepare
 *   phase-functions.sh, line  382:  Called die
 * The specific snippet of code:
 *              die "eapply_user (or default) must be called in src_prepare()!"
 * 
 * If you need support, post the output of `emerge --info '=dev-java/jsr250-1.2::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-java/jsr250-1.2::gentoo'`.
!!! When you file a bug report, please include the following information:
GENTOO_VM=oracle-jdk-bin-1.8  CLASSPATH="" JAVA_HOME="/apps/gentoo/opt/oracle-jdk-bin-1.8.0.121"
JAVACFLAGS="-source 1.7 -target 1.7" COMPILER=""
and of course, the output of emerge --info =jsr250-1.2
 * The complete build log is located at '/apps/gentoo/var/tmp/portage/dev-java/jsr250-1.2/temp/build.log'.
 * The ebuild environment file is located at '/apps/gentoo/var/tmp/portage/dev-java/jsr250-1.2/temp/environment'.
 * Working directory: '/apps/gentoo/var/tmp/portage/dev-java/jsr250-1.2/work'
 * S: '/apps/gentoo/var/tmp/portage/dev-java/jsr250-1.2/work'

>>> Failed to emerge dev-java/jsr250-1.2, Log file:
Comment 1 Andreas Sturmlechner gentoo-dev 2017-02-04 22:49:59 UTC
Works for me. Please provide emerge --info
Comment 2 James Le Cuirot gentoo-dev 2017-02-04 23:02:32 UTC
Are you running with outdated eclasses again?
Comment 3 Martin Mokrejš 2017-02-04 23:06:09 UTC
$ emerge --info
Portage 2.3.3 (python 2.7.12-final-0, prefix/linux-standalone/amd64, gcc-4.9.4, glibc-2.23-r3, 2.6.32-642.6.2.el6.Bull.104.x86_64 x86_64)
=================================================================
System uname: Linux-2.6.32-642.6.2.el6.Bull.104.x86_64-x86_64-Intel-R-_Xeon-R-_CPU_E5-2670_0_@_2.60GHz-with-redhat-6.4-Santiago
KiB Mem:   131942608 total,  31235072 free
KiB Swap:   65536128 total,  65515044 free
Timestamp of repository gentoo: Thu, 02 Feb 2017 09:00:01 +0000
sh bash 4.4_p11
ld GNU ld (Gentoo 2.27 p1.0) 2.27
app-shells/bash:          4.4_p11::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.1_rc4::gentoo
dev-lang/python:          2.7.12::gentoo, 3.4.5::gentoo
dev-util/cmake:           3.7.2::gentoo
dev-util/pkgconfig:       0.29.1::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/sandbox:         2.10-r3::gentoo
sys-devel/autoconf:       2.69-r2::gentoo
sys-devel/automake:       1.14.1-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.27::gentoo
sys-devel/gcc:            3.4.6-r2::gentoo, 4.1.2::gentoo, 4.2.4-r1::gentoo, 4.4.7::gentoo, 4.5.4::gentoo, 4.7.4::gentoo, 4.8.5::gentoo, 4.9.3::gentoo, 4.9.4::gentoo
sys-devel/gcc-config:     1.8_p20160608::rap
sys-devel/libtool:        2.4.6-r2::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.9::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r3::gentoo
Repositories:

gentoo
    location: /apps/gentoo/usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    eclass-overrides: rap

rap
    location: /apps/gentoo/usr/portage-stage
    sync-type: git
    sync-uri: https://anongit.gentoo.org/git/proj/android.git
    masters: gentoo
    eclass-overrides: rap

haskell
    location: /apps/gentoo/var/lib/layman/haskell
    masters: gentoo
    priority: 50
    eclass-overrides: rap

science
    location: /apps/gentoo/var/lib/layman/science
    masters: gentoo
    priority: 50
    eclass-overrides: rap

ACCEPT_KEYWORDS="amd64 ~amd64 ~amd64-linux"
ACCEPT_LICENSE="* -@EULA dlj-1.1 sun-bcla-java-vm Oracle-BCLA-JavaSE IBM-J1.6 skype-eula Nero-EULA-US AdobeFlash-10.3 skype-4.0.0.7-copyright AdobeFlash-11.x Intel-SDP OPERA-2014"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -O2 -pipe -march=native"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -O2 -pipe -march=native"
DISTDIR="/apps/gentoo/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles force-prefix merge-sync news nostrip parallel-fetch preserve-libs protect-owned sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans unprivileged"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j8"
PKGDIR="/apps/gentoo/usr/portage/packages"
PORTAGE_CONFIGROOT="/apps/gentoo/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/apps/gentoo/var/tmp"
USE="X alsa amd64 apache apache2 avx avx2 berkdb boost bzip2 cairo cgi cli coin cracklib crypt cryptlib cxx dbus device-mapper dhcp dri emboss encode fax fbcon ffmpeg fontconfig fortran gbm gd gdbm gimp glpk gnutls gtk hal hwdb iconv imaging innodb ithreads java javafx javascript jce jpeg jpg js jscript keymap ladspa lapack lcms libnotify lm_sensors mad mmx modules mpi mpich2 mysql ncurses nfs nls nptl nptlonly nscd objc openmp openssl pcre pdf perl php png policykit polkit ppds pppd prefix python qt3support readline resolvconf seccomp server session slideshow sndfile sqlite sse sse2 sse3 sse4_1 sse4_2 ssl ssse3 suexec svg syslog tcl tcpd threads tiff tk truetype unicode usb v4l v4l2 vim-syntax vnc wavpack wifi x11 xcb xml xorg xrandr xv xvid xvmc zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en_US en_GB en cs" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby21" USERLAND="GNU" VIDEO_CARDS="amdgpu fbdev intel nouveau radeon radeonsi vesa dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 4 Martin Mokrejš 2017-02-04 23:13:51 UTC
(In reply to James Le Cuirot from comment #2)
> Are you running with outdated eclasses again?

I think I still remember that in some still OPENed bug report by me found found some issue in Gentoo::RAP. I think there is too much load on Benda's shoulders.

But hold on, do you mean bug #595002?

Maybe fix the text I recently added to https://wiki.gentoo.org/wiki/Prefix/libc in section "Any pressing issue with Gentoo::RAP?". Is that I have likely because of two disparate trees, one handled by 'emerge --sync' and the other by 'emaint -r rap sync'? From the git-related output it seems 'emaint -r rap sync' has nothing to update if ran after 'emerge --sync' but as I mentioned in the case of patches vs. unpatched java-utils-2.eclass it seems there are differences in the trees. Then prevent sloppy users like me doing the wrong thing.
Comment 5 Sam James archtester gentoo-dev Security 2021-04-10 06:47:38 UTC
Can’t reproduce this?