Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 60761 - gnome-cups-manager-0.17 won't compile with gcc-3.4.1
Summary: gnome-cups-manager-0.17 won't compile with gcc-3.4.1
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Please assign to toolchain
Depends on:
Reported: 2004-08-18 05:01 UTC by Robin Smidsrød
Modified: 2004-08-20 09:32 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Robin Smidsrød 2004-08-18 05:01:18 UTC
Recently tried running an 'emerge -ve world' after upgrading to gcc-3.4.1, and gnome-cups-manager won't build using gcc-3.4.1.

Reproducible: Always
Steps to Reproduce:
1. upgrade to gcc-3.4.1
2. emerge -ve world

Actual Results:  
Stops on gnome-cups-manager, will get back with exact failure when my world
rebuild is finished (a day or two)

Expected Results:  
Successful emerge.

Gentoo Base System version 1.4.16
Portage 2.0.50-r9 (gcc34-x86-2004.2, gcc-3.4.1, glibc-, 2.6.7)
System uname: 2.6.7 i686 Intel(R) Pentium(R) M processor 1700MHz
Autoconf: sys-devel/autoconf-2.59-r4
Automake: sys-devel/automake-1.8.3
CFLAGS="-march=pentium-m -O2 -fomit-frame-pointer -pipe"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3.2/share/config /usr/kde/3/share/config /usr/lib/mozilla/defaults/pref
/usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=pentium-m -O2 -fomit-frame-pointer -pipe"
FEATURES="autoaddcvs ccache sandbox"
USE="X X509 aalib accessibility acl acpi alsa apm arts avi berkdb bluetooth cdr
crypt cups curl dga divx4linux doc dts dvd dvdr encode esd faac faad firebird
flac foomaticdb gdbm gif gimpprint gnome gphoto2 gpm gstreamer gtk gtkhtml icc
icc-pgo idea imlib innodb irda jack java jbig jpeg kde kerberos lcms ldap libg++
libwww mad mailwrapper matroska md5sum mikmod mmx mng motif mozilla mpeg mysql
ncurses nls nptl oav odbc oggvorbis opengl oss pam pda pdflib perl pic png pnp
postgres ppds pwdb python qt quicktime readline samba sasl scanner sdl skey
slang slp snmp socks5 speex spell sse ssl tcltk tcpd theora threads tiff
truetype trusted usb v4l v4l2 wifi wmf x86 xinerama xml2 xmms xosd xprint xv
xvid zlib"
Comment 1 foser (RETIRED) gentoo-dev 2004-08-18 14:13:43 UTC
trying a newer version might solve the problem, i know there are releases not yet added to portage (0.23)

please try bumping the ebuild yourself, see if that one works.
Comment 2 Bret Towe 2004-08-18 19:24:25 UTC
0.18 thats marked ~x86 compiles fine for me

Portage 2.0.51_pre20 (gcc34-x86-2004.2, gcc-3.4.1, glibc-, 2.6.7-co-0.6.2 i686 Mobile AMD Athlon(tm) XP 2400+)
System uname: 2.6.7-co-0.6.2 i686 Mobile AMD Athlon(tm) XP 2400+
Gentoo Base System version 1.4.16
distcc 2.13 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
Autoconf: sys-devel/autoconf-2.59-r4
Automake: sys-devel/automake-1.8.3
Binutils: sys-devel/binutils-
Headers:  sys-kernel/linux26-headers-2.6.7-r4
Libtools: sys-devel/libtool-1.4.3-r4
CFLAGS="-march=athlon-xp -O2 -fomit-frame-pointer -pipe"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.2/share/config /usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=athlon-xp -O2 -fomit-frame-pointer -pipe"
FEATURES="autoaddcvs ccache fixpackages sandbox"
USE="3dnow X acpi alsa avi berkdb cdr crypt cups dv dvb dvd dvdread encode esd fbcon foomaticdb gdbm gif gnome gtk gtk2 imlib input_devices_synaptics jpeg kde libg++ libwww mad matroska mikmod mmx motif mozilla mpeg ncurses network nptl oggvorbis opengl oss pam pdflib perl png python qt quicktime readline sdl slang spell sse ssl tcpd theora tiff truetype x86 xml2 xmms xv zlib"
Comment 3 Robin Smidsrød 2004-08-19 00:56:52 UTC
Here is the specific compile error:

rm -fr .libs/ .libs/libgnomecupsui-1.0.* .libs/libgnomecupsui-1.0.*
gcc -shared  gnome-cups-ui-init.lo gnome-cups-i18n.lo gnome-cups-ui-print.lo  -L/usr/lib /usr/lib/ /usr/lib/ /usr/lib/ /usr/lib/ -lm /usr/lib/ /usr/lib/ /usr/lib/ /usr/lib/ -ldl /usr/lib/ -lcups -lssl -lcrypto -lnsl /usr/lib/ /usr/lib/  -Wl,--export-dynamic -Wl,-soname -Wl, -o .libs/
(cd .libs && rm -f && ln -s
(cd .libs && rm -f && ln -s
ar cru .libs/libgnomecupsui-1.0.a  gnome-cups-ui-init.o gnome-cups-i18n.o gnome-cups-ui-print.o
ranlib .libs/libgnomecupsui-1.0.a
(cd .libs && rm -f && ln -s ../
make[2]: Leaving directory `/var/tmp/portage/gnome-cups-manager-0.17/work/gnome-cups-manager-0.17/libgnomecups'
Making all in gnome-cups-add
make[2]: Entering directory `/var/tmp/portage/gnome-cups-manager-0.17/work/gnome-cups-manager-0.17/gnome-cups-add'
Making all in snmpkit
make[3]: Entering directory `/var/tmp/portage/gnome-cups-manager-0.17/work/gnome-cups-manager-0.17/gnome-cups-add/snmpkit'
g++ -DHAVE_CONFIG_H -I. -I. -I../..     -march=pentium-m -O2 -fomit-frame-pointer -pipe -c ber.C
g++ -DHAVE_CONFIG_H -I. -I. -I../..     -march=pentium-m -O2 -fomit-frame-pointer -pipe -c beroid.C
g++ -DHAVE_CONFIG_H -I. -I. -I../..     -march=pentium-m -O2 -fomit-frame-pointer -pipe -c berseq.C
g++ -DHAVE_CONFIG_H -I. -I. -I../..     -march=pentium-m -O2 -fomit-frame-pointer -pipe -c oidseq.C
g++ -DHAVE_CONFIG_H -I. -I. -I../..     -march=pentium-m -O2 -fomit-frame-pointer -pipe -c snmpsock.C
g++ -DHAVE_CONFIG_H -I. -I. -I../..     -march=pentium-m -O2 -fomit-frame-pointer -pipe -c structfill.C
g++ -DHAVE_CONFIG_H -I. -I. -I../..     -march=pentium-m -O2 -fomit-frame-pointer -pipe -c session.C
g++ -DHAVE_CONFIG_H -I. -I. -I../..     -march=pentium-m -O2 -fomit-frame-pointer -pipe -c snmpkit_interface.C
snmpkit_interface.C: In function `void** sk_table_get(SNMPTABLE*)':
snmpkit_interface.C:511: error: array bound forbidden after parenthesized type-id
snmpkit_interface.C:511: note: try removing the parentheses around the type-id
make[3]: *** [snmpkit_interface.o] Error 1
make[3]: *** Waiting for unfinished jobs....
make[3]: Leaving directory `/var/tmp/portage/gnome-cups-manager-0.17/work/gnome-cups-manager-0.17/gnome-cups-add/snmpkit'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/gnome-cups-manager-0.17/work/gnome-cups-manager-0.17/gnome-cups-add'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/gnome-cups-manager-0.17/work/gnome-cups-manager-0.17'
make: *** [all-recursive-am] Error 2

!!! ERROR: net-print/gnome-cups-manager-0.17 failed.
!!! Function gnome2_src_compile, Line 38, Exitcode 2
!!! compile failure

Comment 4 Heinrich Wendel (RETIRED) gentoo-dev 2004-08-19 01:49:01 UTC
please try gnome-cups-manager-0.23 which i just added to portage
Comment 5 Robert Moss (RETIRED) gentoo-dev 2004-08-19 14:41:15 UTC
Closing. There's a ~arch version which works fine. Remember that gcc-3.4.1 is by no means stable yet, and you should certainly not expect stable packages to compile with it. Before filing a bug of this nature you should check the latest ~arch version is also broken.
Comment 6 Robin Smidsrød 2004-08-19 23:21:26 UTC
I've tested gnome-cups-manager-0.18, and it seems to work like it should. gnome-cups-manager-0.23 needed an updated libgnomecups (AFAIK) which was masked, so I skipped that one.

gcc-3.4.1 IS part of the stable branch at, but I know it's not up to speed in Gentoo yet. But I'm an owner of a Dell Precision M60 (Pentium M), and the only way to get -march=pentium-m is to use gcc-3.4.x. So here I am.

BTW: A world remerge (emerge -e world) with gcc-3.4.1 only had problems on these packages:

firebird (still doesn't work)
gnome-bluetooth (still doesn't work)
gnome-cups-manager (updated to 0.18, works)
apmd (removed, my machine doesn't use APM)
vlc (0.7.2-r1 doesn't compile, 0.7.2 does)
gnome-vfs-1 (still doesn't work)
control-center-1 (still doesn't work) 
xscreensaver (~arch version worked)
xfree (totally borked, moved to xorg, it borked to, changed arch to pentium3 and xorg worked)

That should meen that we should soon be able to see the light in the tunnel with regards to gcc-3.4, don't you think?
Comment 7 Disenchanted (RETIRED) gentoo-dev 2004-08-20 09:18:26 UTC
Check Gnome items for individual bugs, some might have fixes filed you can use.
firebird db needs A LOT of work as they decided to recreate the wheel instead of sticking to stl/boost

does -march=pentium3 -msse2 result in the same broken xorg as -march=pentium-m ?

'quickpkg xorg' before you try such a thing, for a quick 2 minute reinstallation should it install but be broken
(using emerge -K =xorg-x11-6.7.0-r2 (if that is your version))

Comment 8 Robin Smidsrød 2004-08-20 09:32:19 UTC
I haven't got the time to check, but it probably will, since gcc-changelog states that the difference between pentium3 and pentium-m is SSE2. Everything else is the same, so why shouldn't it bork there too?

I had a lot of SSE2 problems with gcc-3.3, but now (with gcc-3.4) the ONLY program which have strange segfaults is xfree/xorg. Nice improvement. Of course I've had some compiler errors, but overall, things are much more stable now.

Sidenote: Are there any distributions which ship with gcc-3.4 as standard?