Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 607480 - app-emulation/virtualbox-guest-additions-5.1.14 : /.../jump_label.h:295:65: error: ‘__builtin_types_compatible_p’ was not declared in this scope
Summary: app-emulation/virtualbox-guest-additions-5.1.14 : /.../jump_label.h:295:65: e...
Status: RESOLVED DUPLICATE of bug 603472
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 2 votes (vote)
Assignee: Lars Wendler (Polynomial-C)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-6
  Show dependency tree
 
Reported: 2017-01-28 14:21 UTC by Toralf Förster
Modified: 2017-02-21 08:01 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,5.62 KB, text/plain)
2017-01-28 14:21 UTC, Toralf Förster
Details
app-emulation:virtualbox-guest-additions-5.1.14:20170128-124418.log.bz2 (app-emulation:virtualbox-guest-additions-5.1.14:20170128-124418.log.bz2,40.64 KB, application/x-bzip)
2017-01-28 14:21 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,222.38 KB, text/plain)
2017-01-28 14:21 UTC, Toralf Förster
Details
environment (environment,142.58 KB, text/plain)
2017-01-28 14:21 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,24.33 KB, application/x-bzip)
2017-01-28 14:21 UTC, Toralf Förster
Details
Fix sloppy printk (vbox.printk.patch,534 bytes, patch)
2017-02-19 21:06 UTC, Joakim Tjernlund
Details | Diff
C++ version of __READ_ONCE (vbox.compiler.patch,807 bytes, patch)
2017-02-19 21:07 UTC, Joakim Tjernlund
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2017-01-28 14:21:43 UTC
  if (static_branch_unlikely(&mcsafe_key))
      ^~~~~~~~~~~~~~~~~~~~~~
/lib/modules/4.9.6-gentoo/build/include/linux/jump_label.h:295:65: error: ‘__builtin_types_compatible_p’ was not declared in this scope
  if (!__builtin_types_compatible_p(typeof(*x), struct static_key) && \
                                                                 ^
/lib/modules/4.9.6-gentoo/build/include/linux/compiler.h:168:42: note: in definition of macro ‘unlikely’

  -----------------------------------------------------------------

  This is an unstable amd64 chroot image (named hardened-unstable_20170120-150937) at a hardened host acting as a tinderbox.

  -----------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-6.3.0 *
llvm-config --version:
3.9.1

Available Python interpreters, in order of preference:
  [1]   python3.4
  [2]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby21 (with Rubygems) *
java-config:
The following VMs are available for generation-2:
  -----------------------------------------------------------------
Comment 1 Toralf Förster gentoo-dev 2017-01-28 14:21:46 UTC
Created attachment 461712 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2017-01-28 14:21:48 UTC
Created attachment 461714 [details]
app-emulation:virtualbox-guest-additions-5.1.14:20170128-124418.log.bz2
Comment 3 Toralf Förster gentoo-dev 2017-01-28 14:21:52 UTC
Created attachment 461716 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2017-01-28 14:21:56 UTC
Created attachment 461718 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2017-01-28 14:21:59 UTC
Created attachment 461720 [details]
etc.portage.tbz2
Comment 6 Michal Jakubowski 2017-01-30 09:43:19 UTC
The same.
Comment 7 HelLViS69 2017-02-07 11:13:40 UTC
Same here
Comment 8 Luis Lucas 2017-02-19 13:54:07 UTC
Same problem here.
Comment 9 Joakim Tjernlund 2017-02-19 21:06:37 UTC
Created attachment 464366 [details, diff]
Fix sloppy printk
Comment 10 Joakim Tjernlund 2017-02-19 21:07:40 UTC
Created attachment 464368 [details, diff]
C++ version of __READ_ONCE
Comment 11 Joakim Tjernlund 2017-02-19 21:11:37 UTC
With the two patches just uploaded( Fix sloppy printk, C++ version of __READ_ONCE)
and this diff to the ebuild:
--- a/virtualbox-guest-additions-5.1.14.ebuild	2017-02-19 19:38:41.490542701 +0100
+++ b/virtualbox-guest-additions-5.1.14.ebuild	2017-02-19 18:01:54.032052975 +0100
@@ -122,7 +122,8 @@
 	MAKE="kmk" \
 	emake TOOL_YASM_AS=yasm \
 	VBOX_ONLY_ADDITIONS=1 \
-	KBUILD_VERBOSE=2
+	KBUILD_VERBOSE=2 \
+	CXXFLAGS="-fpermissive -D__builtin_types_compatible_p\(x,y\)=1"


it builds. Don't know it it works, can anyone confirm?
Comment 12 Joakim Tjernlund 2017-02-19 21:20:38 UTC
Oops, wrong bug, should have been:
 https://bugs.gentoo.org/show_bug.cgi?id=603472
I do think this is close to your problem too.
Comment 13 Lars Wendler (Polynomial-C) gentoo-dev 2017-02-21 08:01:07 UTC

*** This bug has been marked as a duplicate of bug 603472 ***