Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 606900 - dev-libs/boost-1.63.0:0/1.63.0 causes slot conflicts with many packages
Summary: dev-libs/boost-1.63.0:0/1.63.0 causes slot conflicts with many packages
Status: RESOLVED DUPLICATE of bug 554838
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-01-23 11:24 UTC by Anton Gubarkov
Modified: 2017-01-25 12:02 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anton Gubarkov 2017-01-23 11:24:17 UTC
(dev-libs/boost-1.63.0:0/1.63.0::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/boost-1.62.0-r1:0/1.62.0::gentoo, installed) pulled in by
    >=dev-libs/boost-1.51.0:0/1.62.0= required by (dev-libs/liborcus-0.11.2:0/0.11::gentoo, installed)
                           ^^^^^^^^^^                                                                                                     
    dev-libs/boost:0/1.62.0= required by (media-sound/ardour-5.5:5/5::gentoo, installed)
                  ^^^^^^^^^^                                                                                                
    >=dev-libs/boost-1.55:0/1.62.0= required by (app-office/libreoffice-5.2.4.2:0/0::gentoo, installed)
                         ^^^^^^^^^^                                                                                                        
    dev-libs/boost:0/1.62.0= required by (net-misc/grive-0.5.1_pre20161004:0/0::gentoo, installed)
                  ^^^^^^^^^^                                                                                                          
    dev-libs/boost:0/1.62.0=[threads] required by (net-libs/rb_libtorrent-1.0.10:0/8::gentoo, installed)
                  ^^^^^^^^^^                                                                                                                
    >=dev-libs/boost-1.62:0/1.62.0= required by (app-office/scribus-1.5.2-r2:0/0::gentoo, installed)
                         ^^^^^^^^^^                                                                                                     
    dev-libs/boost:0/1.62.0=[threads] required by (app-backup/snapper-0.4.1:0/0::gentoo, installed)
                  ^^^^^^^^^^                                                                                                           
    dev-libs/boost:0/1.62.0= required by (dev-libs/librevenge-0.0.4:0/0::gentoo, installed)
                  ^^^^^^^^^^                                                                                                   
    dev-libs/boost:0/1.62.0= required by (net-p2p/qbittorrent-3.3.7:0/0::gentoo, installed)
                  ^^^^^^^^^^                                                                                                   
    dev-libs/boost:0/1.62.0=[python,python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (net-libs/rb_libtorrent-1.0.10:0/8::gentoo, installed)
                  ^^^^^^^^^^                                                                                                                                                                                                                                                                                
    dev-libs/boost:0/1.62.0=[threads] required by (dev-libs/libixion-0.11.1:0/0.11::gentoo, installed)
                  ^^^^^^^^^^                                                                                                              
    dev-libs/boost:0/1.62.0= required by (dev-util/mdds-1.2.2:1/1.2::gentoo, installed)
                  ^^^^^^^^^^                                                                                               
    dev-libs/boost:0/1.62.0= required by (dev-cpp/libcmis-0.5.2_pre20160820:0.5/0.5::gentoo, installed)
Comment 1 Anton Gubarkov 2017-01-23 11:24:50 UTC
r9-008cln ~ # emerge --info
Portage 2.3.3 (python 3.4.5-final-0, default/linux/amd64/13.0/desktop/gnome/systemd, gcc-5.4.0, glibc-2.23-r3, 4.8.14-rt-rt9 x86_64)
=================================================================
System uname: Linux-4.8.14-rt-rt9-x86_64-Intel-R-_Core-TM-_i7-4700MQ_CPU_@_2.40GHz-with-gentoo-2.3
KiB Mem:    15780524 total,    113948 free
KiB Swap:   20971516 total,  20024116 free
Timestamp of repository gentoo: Mon, 23 Jan 2017 09:00:01 +0000
sh bash 4.4_p5-r1
ld GNU ld (Gentoo 2.27 p1.0) 2.27
app-shells/bash:          4.4_p5-r1::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.1_rc4::gentoo
dev-lang/python:          2.7.12::gentoo, 3.4.5::gentoo, 3.5.2::gentoo
dev-util/cmake:           3.7.2::gentoo
dev-util/pkgconfig:       0.29.1::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/openrc:          0.23.1::gentoo
sys-apps/sandbox:         2.10-r3::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r2::gentoo
sys-devel/automake:       1.11.6-r2::gentoo, 1.12.6-r1::gentoo, 1.13.4-r1::gentoo, 1.14.1-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.27::gentoo
sys-devel/gcc:            5.4.0-r2::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r2::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.9::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r3::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000

rugubara
    location: /home/anton/devel/rugubara
    masters: gentoo
    priority: 0

anders-larsson
    location: /var/lib/layman/anders-larsson
    masters: gentoo
    priority: 50

betagarden
    location: /var/lib/layman/betagarden
    masters: gentoo
    priority: 50

bumblebee
    location: /var/lib/layman/bumblebee
    masters: gentoo
    priority: 50

fw-overlay
    location: /var/lib/layman/fw-overlay
    masters: gentoo
    priority: 50

ixit
    location: /var/lib/layman/ixit
    masters: gentoo
    priority: 50

jorgicio
    location: /var/lib/layman/jorgicio
    masters: gentoo
    priority: 50

kde
    location: /var/lib/layman/kde
    masters: gentoo
    priority: 50

proaudio
    location: /var/lib/layman/pro-audio
    masters: gentoo
    priority: 50

sabayon
    location: /var/lib/layman/sabayon
    masters: gentoo
    priority: 50

steam-overlay
    location: /var/lib/layman/steam
    masters: gentoo
    priority: 50

stuff
    location: /var/lib/layman/stuff
    masters: gentoo
    priority: 50

sunrise
    location: /var/lib/layman/sunrise
    masters: gentoo
    priority: 50

telred
    location: /var/lib/layman/telred
    masters: gentoo
    priority: 50

tlp
    location: /var/lib/layman/tlp
    masters: gentoo
    priority: 50

x11
    location: /var/lib/layman/x11
    masters: gentoo
    priority: 50

Installed sets: @kde-frameworks-live
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=haswell -mmmx -msse -msse2 -msse3 -mssse3 -mcx16 -msahf -mmovbe -maes -mpclmul -mpopcnt -mabm -mfma -mbmi -mbmi2 -mavx -mavx2 -msse4.2 -msse4.1 -mlzcnt -mrdrnd -mf16c -mfsgsbase -mfxsr -mxsave -mxsaveopt --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=6144 -mtune=haswell -fstack-protector-strong"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=haswell -mmmx -msse -msse2 -msse3 -mssse3 -mcx16 -msahf -mmovbe -maes -mpclmul -mpopcnt -mabm -mfma -mbmi -mbmi2 -mavx -mavx2 -msse4.2 -msse4.1 -mlzcnt -mrdrnd -mf16c -mfsgsbase -mfxsr -mxsave -mxsaveopt --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=6144 -mtune=haswell -fstack-protector-strong"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync metadata-transfer news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/etersoft"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi aes alsa amd64 archive avahi avx avx2 bash-completion berkdb bluetooth bluray branding bzip2 cacert cairo cdda cdr cli cloudprint colord cracklib crypt cups cxx cycles dbus dhcpcd djvu dri dri3 dts dvd dvdr eds egl emboss encode equalizer evdev evo exif extras faac fam ffmpeg fftw firefox flac fma3 fortran fprint frei0r g711 g722 g7221 gbm gdbm gif gimp gles2 gnome gnome-keyring gnome-online-accounts gpm gstreamer gtk gtk3 http iconv idn ieee1394 introspection ipv6 jack javafx jpeg jpeg2k kms lcms ldap libnotify libsecret lv2 lxc mad midi mmx mmxext mng modules mp3 mp4 mpeg mtp multilib native-headset nautilus ncurses networkmanager nls nptl nsplugin nvenc ogg opengl openimageio openmp pam pango pcre pdf png policykit popcnt postproc ppds pulseaudio qt3support qt4 rar raw readline realtime samba sdl seccomp sendto session smp speex spell sse sse2 sse3 sse4_1 sse4_2 ssl ssse3 startup-notification svg systemd tcpd theora threads tiff tracker truetype udev udisks unicode upower usb v4l vaapi vorbis vpx wavpack wayland winbind wxwidgets x264 x265 xa xattr xcb xinerama xml xv xvid xvmc zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="prefork" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 fma3 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" CURL_SSL="gnutls" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="multiboot efi-64 pc" INPUT_DEVICES="libinput" KERNEL="linux" L10N="en ru" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="nlpsolver" LINGUAS="en ru" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby24 ruby22 ruby23" USERLAND="GNU" VIDEO_CARDS="intel i965 nvidia" XFCE_PLUGINS="brightness clock trash battery power" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 2 Lars Wendler (Polynomial-C) gentoo-dev 2017-01-23 14:57:20 UTC
Run emerge with "--backtrack=100" option.
Comment 3 Anton Gubarkov 2017-01-23 16:14:31 UTC
This is what I get with --backtrack=100

!!! All ebuilds that could satisfy "=dev-util/boost-build-1.63*" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-util/boost-build-1.63.0::gentoo (masked by: )

(dependency required by "dev-libs/boost-1.63.0::gentoo" [ebuild])
(dependency required by "app-office/scribus-1.5.2-r2::gentoo[boost]" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
Comment 4 jospezial 2017-01-23 18:13:36 UTC
Did you only try to update boost or world?

Dup of bug 554838 ?
Comment 5 Anton Gubarkov 2017-01-23 20:25:07 UTC
(In reply to jospezial from comment #4)
> Did you only try to update boost or world?
> 
> Dup of bug 554838 ?

The problems I experienced are triggered by the @world update. 

I tried with --ignore-built-slot-operator-deps=y - the updates to boost and boost-build have found their place in the sequence. The build has started.
Comment 6 juneau_ 2017-01-24 03:22:55 UTC
I can confirm that boost and boost-build upgrade always accompanied with such headache, --ignore-built-slot-operator-deps=y helps though.
Comment 7 Michael Palimaka (kensington) gentoo-dev 2017-01-25 12:02:45 UTC

*** This bug has been marked as a duplicate of bug 554838 ***