Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 606624 - dev-libs/appstream-0.10.5 Error: cannot open mo file.../work/appstream-0.10.5_build/po/*.gmo
Summary: dev-libs/appstream-0.10.5 Error: cannot open mo file.../work/appstream-0.10.5...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-01-20 16:47 UTC by Petross404(Petros S)
Modified: 2017-02-18 04:04 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (dev-libs:appstream-0.10.5:20170120-163942.log,53.72 KB, text/x-log)
2017-01-20 16:47 UTC, Petross404(Petros S)
Details
build.log.-j1 (dev-libs:appstream-0.10.5:20170126-190438.log,66.97 KB, text/x-log)
2017-01-26 19:08 UTC, Petross404(Petros S)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petross404(Petros S) 2017-01-20 16:47:00 UTC
Created attachment 460756 [details]
build.log

Emerging dev-libs/appstream-0.10.5 failes with the following error:

Error: cannot open mo file /tmp/portage/dev-libs/appstream-0.10.5/work/appstream-0.10.5_build/po/*.gmo

USE Flags qt5 and apt are enabled.
[ebuild  N     ] dev-libs/appstream-0.10.5:0/4::gentoo  USE="apt qt5 -debug -doc {-test}" 0 KiB
Comment 1 Michael Palimaka (kensington) gentoo-dev 2017-01-26 18:25:59 UTC
Does it work with -j1?
Comment 2 Petross404(Petros S) 2017-01-26 19:08:29 UTC
Created attachment 461518 [details]
build.log.-j1

(In reply to Michael Palimaka (kensington) from comment #1)
> Does it work with -j1?

No, it doesn't compile.
Comment 3 James Ausmus 2017-02-16 00:43:34 UTC
Problem exists in version 0.10.6 as well
Comment 4 Jan Ziak (atomsymbol) 2017-02-17 16:05:37 UTC
AppStream-0.10.6.tar.xz contains .po files.

.po files are missing from the Portage build directory.

Where is Portage deleting or filtering out the *.po files?
Comment 5 Michael Palimaka (kensington) gentoo-dev 2017-02-18 04:04:29 UTC
Thanks, this should be fixed in git. Please reopen if the issue persists.

I believe this was caused by kde5.eclass removing all po files with LINGUAS="". I'm not sure why this package inherited kde5.eclass since there's nothing really KDE-related about it, so I've ported to cmake-utils instead.

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=14b829335ebccdb0b2ca546f4e1b1fb8f99e529e
https://gitweb.gentoo.org/proj/kde.git/commit/?id=15287e56093d5cfb85487a8b65113a07f1d7fea4