Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 606172 - x11-drivers/xf86-video-virtualbox-5.1.14 fails to compile
Summary: x11-drivers/xf86-video-virtualbox-5.1.14 fails to compile
Status: RESOLVED DUPLICATE of bug 598800
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Lars Wendler (Polynomial-C)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-01-18 10:00 UTC by Martin Wohlert
Modified: 2017-03-04 16:06 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log.xz (build.log.xz,33.79 KB, application/x-xz)
2017-01-18 10:00 UTC, Martin Wohlert
Details
patch for glibc-2.24 (virtualbox-5.1.14-glibc-2.24.patch,1.24 KB, patch)
2017-01-18 18:52 UTC, Helmut Jarausch
Details | Diff
ebuild for 5.1.14 using the patch (virtualbox-5.1.14.ebuild,13.22 KB, text/plain)
2017-01-19 10:07 UTC, Helmut Jarausch
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Wohlert 2017-01-18 10:00:13 UTC
Created attachment 460526 [details]
build.log.xz

Bug also happened with x11-drivers/xf86-video-virtualbox-5.1.12

short overview:

/lib/modules/4.9.2-gentoo/build/arch/x86/include/asm/string_64.h:103:6: note: in expansion of macro ‘static_branch_unlikely’
  if (static_branch_unlikely(&mcsafe_key))
      ^~~~~~~~~~~~~~~~~~~~~~
/lib/modules/4.9.2-gentoo/build/include/linux/jump_label.h:296:48: error: expected primary-expression before ‘struct’
      !__builtin_types_compatible_p(typeof(*x), struct static_key_true) &&\
                                                ^
/lib/modules/4.9.2-gentoo/build/include/linux/compiler.h:168:42: note: in definition of macro ‘unlikely’
 # define unlikely(x) __builtin_expect(!!(x), 0)
                                          ^
/lib/modules/4.9.2-gentoo/build/include/linux/jump_label.h:387:44: note: in expansion of macro ‘static_key_enabled’
 #define static_branch_unlikely(x) unlikely(static_key_enabled(&(x)->key))
                                            ^~~~~~~~~~~~~~~~~~
/lib/modules/4.9.2-gentoo/build/arch/x86/include/asm/string_64.h:103:6: note: in expansion of macro ‘static_branch_unlikely’
  if (static_branch_unlikely(&mcsafe_key))
      ^~~~~~~~~~~~~~~~~~~~~~
/lib/modules/4.9.2-gentoo/build/include/linux/jump_label.h:297:36: error: expected primary-expression before ‘typeof’
      !__builtin_types_compatible_p(typeof(*x), struct static_key_false)) \
                                    ^
/lib/modules/4.9.2-gentoo/build/include/linux/compiler.h:168:42: note: in definition of macro ‘unlikely’
 # define unlikely(x) __builtin_expect(!!(x), 0)
                                          ^
/lib/modules/4.9.2-gentoo/build/include/linux/jump_label.h:387:44: note: in expansion of macro ‘static_key_enabled’
 #define static_branch_unlikely(x) unlikely(static_key_enabled(&(x)->key))
                                            ^~~~~~~~~~~~~~~~~~
/lib/modules/4.9.2-gentoo/build/arch/x86/include/asm/string_64.h:103:6: note: in expansion of macro ‘static_branch_unlikely’
  if (static_branch_unlikely(&mcsafe_key))
      ^~~~~~~~~~~~~~~~~~~~~~
/lib/modules/4.9.2-gentoo/build/include/linux/jump_label.h:297:48: error: expected primary-expression before ‘struct’
      !__builtin_types_compatible_p(typeof(*x), struct static_key_false)) \
                                                ^
/lib/modules/4.9.2-gentoo/build/include/linux/compiler.h:168:42: note: in definition of macro ‘unlikely’
 # define unlikely(x) __builtin_expect(!!(x), 0)
                                          ^
/lib/modules/4.9.2-gentoo/build/include/linux/jump_label.h:387:44: note: in expansion of macro ‘static_key_enabled’
 #define static_branch_unlikely(x) unlikely(static_key_enabled(&(x)->key))
                                            ^~~~~~~~~~~~~~~~~~
/lib/modules/4.9.2-gentoo/build/arch/x86/include/asm/string_64.h:103:6: note: in expansion of macro ‘static_branch_unlikely’
  if (static_branch_unlikely(&mcsafe_key))
      ^~~~~~~~~~~~~~~~~~~~~~
kmk: *** [/var/tmp/portage/x11-drivers/xf86-video-virtualbox-5.1.14/work/VirtualBox-5.1.14/out/linux.amd64/release/obj/RuntimeGuestR0/common/alloc/heapsimple.o] Error 1
kmk: *** Exiting with status 2
Comment 1 Martin Wohlert 2017-01-18 10:01:49 UTC
# emerge --info

Portage 2.3.3 (python 3.4.5-final-0, hardened/linux/amd64, gcc-6.3.0, glibc-2.23-r3, 4.9.2-gentoo x86_64)
=================================================================
System uname: Linux-4.9.2-gentoo-x86_64-Intel-R-_Core-TM-_i7-4720HQ_CPU_@_2.60GHz-with-gentoo-2.3
KiB Mem:     4051328 total,    980116 free
KiB Swap:    2097148 total,   2090484 free
Timestamp of repository gentoo: Wed, 18 Jan 2017 06:00:01 +0000
sh bash 4.4_p5-r1
ld GNU ld (Gentoo 2.27 p1.0) 2.27
app-shells/bash:          4.4_p5-r1::gentoo
dev-lang/perl:            5.24.1_rc4::gentoo
dev-lang/python:          2.7.12::gentoo, 3.4.5::gentoo
dev-util/cmake:           3.7.2::gentoo
dev-util/pkgconfig:       0.29.1::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/openrc:          0.23.1::gentoo
sys-apps/sandbox:         2.10-r3::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r2::gentoo
sys-devel/automake:       1.13.4-r1::gentoo, 1.14.1-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.27::gentoo
sys-devel/gcc:            6.3.0::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r2::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.9::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r3::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://b-root-force.de/gentoo-portage/
    priority: -1000

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA Oracle-BCLA-JavaSE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-Os -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php7.1/ext-active/ /etc/php/cgi-php7.1/ext-active/ /etc/php/cli-php7.1/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-Os -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="https://gentoo.b-root-force.de"
LANG="de_DE.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl amd64 apng berkdb branding bzip2 cli cracklib crypt cryptsetup cxx dri gdbm gnome gnome-keyring hardened iconv ipv6 justify kvazaar lzma mmx mmxext modules mp3 mp4 mpeg multilib ncurses nls nptl ogg openmp opus pam pax_kernel pcre pie policykit pulseaudio readline schroedinger seccomp session sse sse2 ssl ssp systemd tcpd theora threads udisks unicode urandom vorbis vpx x264 x265 xattr xtpax xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="worker" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" L10N="de" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby21" USERLAND="GNU" VIDEO_CARDS="virtualbox" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 2 Martin Wohlert 2017-01-18 10:10:42 UTC
This bug is reproducible. What I've tried so far:

compiling with -std=gnu99, -std=gnu++98, -fpermissive. Compiling still fails.

I'm now emerging gcc-5.4.0 and gcc-4.9.4 to try compiling using them. Will give feedback then. Maybe it's related to gcc-6.3.0.

Any other ideas I can also try?
Comment 3 Helmut Jarausch 2017-01-18 18:52:20 UTC
Created attachment 460570 [details, diff]
patch for glibc-2.24
Comment 4 Martin Wohlert 2017-01-19 07:33:12 UTC
The patch from Helmut doesn't fix the problem, compilation still fails.

Despite the fact that I wasn't unable to build gcc-5.4.0 yesterday, I tried to compile the package with gcc-4.9.4 which failed with same errors like gcc-6.3.0.

Then I thought it might be because of "hardened" gcc. But even with vanilla gcc-4.9.4 the problem remains.
Comment 5 Helmut Jarausch 2017-01-19 10:07:00 UTC
(In reply to Martin Wohlert from comment #4)
> The patch from Helmut doesn't fix the problem, compilation still fails.
> 
> Despite the fact that I wasn't unable to build gcc-5.4.0 yesterday, I tried
> to compile the package with gcc-4.9.4 which failed with same errors like
> gcc-6.3.0.
> 
> Then I thought it might be because of "hardened" gcc. But even with vanilla
> gcc-4.9.4 the problem remains.

I've just compiled it once more - without any problems.
I'm using gcc-6.3.0 and glibc-2.24, though.
I've attached my ebuild, as well.
Comment 6 Helmut Jarausch 2017-01-19 10:07:42 UTC
Created attachment 460632 [details]
ebuild for 5.1.14 using the patch
Comment 7 Martin Wohlert 2017-01-19 12:45:58 UTC
Helmut, I think the ebuild you attached is for app-emulation/virtualbox, but this bug ticket is related to x11-drivers/xf86-video-virtualbox. I'm not trying to compile VirtualBox, I have problems to compile the xorg driver for my gentoo guest.

And that might also explain why your submitted patch didn't change anything.
Comment 8 Helmut Jarausch 2017-01-19 17:01:54 UTC
(In reply to Martin Wohlert from comment #7)
> Helmut, I think the ebuild you attached is for app-emulation/virtualbox, but
> this bug ticket is related to x11-drivers/xf86-video-virtualbox. I'm not
> trying to compile VirtualBox, I have problems to compile the xorg driver for
> my gentoo guest.
> 
> And that might also explain why your submitted patch didn't change anything.

Yes, sorry for that.

I can't install xf86-video-virtualbox-5.1.14 either since I even fail to install
virtualbox-guest-additions-5.1.14 (see my bug report https://bugs.gentoo.org/show_bug.cgi?id=603472 )
Comment 9 edes 2017-02-12 14:26:15 UTC
i have the same problem here:

- xf86-video-virtualbox-5.1.14
- gcc-5.4.0-r3
- gentoo-sources-4.9.9
Comment 10 Lars Wendler (Polynomial-C) gentoo-dev 2017-03-04 16:06:33 UTC

*** This bug has been marked as a duplicate of bug 598800 ***