Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 605122 - dev-python/twisted-16.6.0-r3 keyword request
Summary: dev-python/twisted-16.6.0-r3 keyword request
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Keywording (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Python Gentoo Team
URL:
Whiteboard:
Keywords: KEYWORDREQ
Depends on: 606990 619608 640424
Blocks: 605084 614386
  Show dependency tree
 
Reported: 2017-01-08 20:13 UTC by Brian Dolbec
Modified: 2018-07-16 14:51 UTC (History)
1 user (show)

See Also:
Package list:
=dev-python/hyper-h2-2.5.1 ia64 sparc x86-fbsd m68k s390 sh =dev-python/priority-1.3.0 ia64 sparc x86-fbsd m68k s390 sh =dev-python/gmpy-2.0.8 sparc x86-fbsd m68k s390 sh =dev-python/pytest-cov-2.3.1 x86-fbsd m68k s390 sh =dev-python/pytest-xdist-1.15.0 x86-fbsd m68k s390 sh =dev-python/sphinx-py3doc-enhanced-theme-2.3.2 x86-fbsd m68k s390 sh =dev-python/readme-0.6.0 x86-fbsd m68k s390 sh =sci-libs/mpir-2.6.0-r2 sparc x86-fbsd m68k s390 sh =dev-python/twisted-16.6.0-r3 ia64 sparc x86-fbsd m68k s390 sh =dev-python/bleach-1.5.0 x86-fbsd m68k s390 sh =dev-python/hpack-2.3.0-r1 ia64 sparc x86-fbsd m68k s390 sh =dev-python/hyperframe-4.0.1 ia64 sparc x86-fbsd m68k s390 sh =dev-python/constantly-15.1.0 ia64 sparc x86-fbsd m68k s390 sh =dev-python/incremental-16.10.1 ia64 sparc x86-fbsd m68k s390 sh
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Brian Dolbec gentoo-dev 2017-01-08 20:13:49 UTC
Many of the keywords had to be dropped due to new dependencies added to the tree.


Reproducible: Always
Comment 1 Brian Dolbec gentoo-dev 2017-01-08 20:32:15 UTC
Most pkgs should be able to qualify for ALLARCHES
Comment 2 Brian Dolbec gentoo-dev 2017-01-08 20:59:18 UTC
Sci-libs/mipr does not qualify for ALLARCHES
Comment 3 Stabilization helper bot gentoo-dev 2017-01-10 06:01:10 UTC
An automated check of this bug failed - repoman reported dependency errors (138 lines truncated): 

> dependency.bad dev-python/hyper-h2/hyper-h2-2.5.1.ebuild: DEPEND: ~alpha(default/linux/alpha/13.0) ['>=dev-python/hyperframe-4.0.1[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', '<dev-python/hyperframe-5.0.0[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', '>=dev-python/hpack-2.2.0[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', '<dev-python/hpack-3.0.0[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]']
> dependency.bad dev-python/hyper-h2/hyper-h2-2.5.1.ebuild: RDEPEND: ~alpha(default/linux/alpha/13.0) ['>=dev-python/hyperframe-4.0.1[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', '<dev-python/hyperframe-5.0.0[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', '>=dev-python/hpack-2.2.0[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', '<dev-python/hpack-3.0.0[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]']
> dependency.bad dev-python/hyper-h2/hyper-h2-2.5.1.ebuild: DEPEND: ~alpha(default/linux/alpha/13.0/desktop) ['>=dev-python/hyperframe-4.0.1[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', '<dev-python/hyperframe-5.0.0[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', '>=dev-python/hpack-2.2.0[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', '<dev-python/hpack-3.0.0[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]']
> dependency.bad dev-python/gmpy/gmpy-2.0.4.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['sci-libs/mpir']
> dependency.bad dev-python/gmpy/gmpy-2.0.4.ebuild: RDEPEND: ia64(default/linux/ia64/13.0) ['sci-libs/mpir']
> dependency.bad dev-python/gmpy/gmpy-2.0.4.ebuild: DEPEND: ia64(default/linux/ia64/13.0/desktop) ['sci-libs/mpir']
Comment 4 Jeroen Roovers (RETIRED) gentoo-dev 2017-01-12 19:22:09 UTC
Now then, these are *valid* atoms.
Comment 5 Brian Dolbec gentoo-dev 2017-01-12 22:50:01 UTC
OK, thanks, I'll remember that now.  So it needs to be a fully qualified portage atom.  The bot must feed the list directly as is then...
Comment 6 Stabilization helper bot gentoo-dev 2017-01-13 15:03:31 UTC
An automated check of this bug failed - repoman reported dependency errors (138 lines truncated): 

> dependency.bad dev-python/gmpy/gmpy-2.0.4.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['sci-libs/mpir']
> dependency.bad dev-python/gmpy/gmpy-2.0.4.ebuild: RDEPEND: ia64(default/linux/ia64/13.0) ['sci-libs/mpir']
> dependency.bad dev-python/gmpy/gmpy-2.0.4.ebuild: DEPEND: ia64(default/linux/ia64/13.0/desktop) ['sci-libs/mpir']
> dependency.bad dev-python/hyper-h2/hyper-h2-2.5.1.ebuild: DEPEND: ~alpha(default/linux/alpha/13.0) ['>=dev-python/hyperframe-4.0.1[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', '<dev-python/hyperframe-5.0.0[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', '>=dev-python/hpack-2.2.0[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', '<dev-python/hpack-3.0.0[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]']
> dependency.bad dev-python/hyper-h2/hyper-h2-2.5.1.ebuild: RDEPEND: ~alpha(default/linux/alpha/13.0) ['>=dev-python/hyperframe-4.0.1[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', '<dev-python/hyperframe-5.0.0[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', '>=dev-python/hpack-2.2.0[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', '<dev-python/hpack-3.0.0[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]']
> dependency.bad dev-python/hyper-h2/hyper-h2-2.5.1.ebuild: DEPEND: ~alpha(default/linux/alpha/13.0/desktop) ['>=dev-python/hyperframe-4.0.1[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', '<dev-python/hyperframe-5.0.0[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', '>=dev-python/hpack-2.2.0[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', '<dev-python/hpack-3.0.0[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]']
Comment 7 Stabilization helper bot gentoo-dev 2017-01-24 07:03:17 UTC
An automated check of this bug failed - repoman reported dependency errors (138 lines truncated): 

> dependency.bad dev-python/gmpy/gmpy-2.0.4.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['sci-libs/mpir']
> dependency.bad dev-python/gmpy/gmpy-2.0.4.ebuild: RDEPEND: ia64(default/linux/ia64/13.0) ['sci-libs/mpir']
> dependency.bad dev-python/gmpy/gmpy-2.0.4.ebuild: DEPEND: ia64(default/linux/ia64/13.0/desktop) ['sci-libs/mpir']
> dependency.bad dev-python/hyper-h2/hyper-h2-2.5.1.ebuild: DEPEND: ~alpha(default/linux/alpha/13.0) ['>=dev-python/hyperframe-4.0.1[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', '<dev-python/hyperframe-5.0.0[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]']
> dependency.bad dev-python/hyper-h2/hyper-h2-2.5.1.ebuild: RDEPEND: ~alpha(default/linux/alpha/13.0) ['>=dev-python/hyperframe-4.0.1[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', '<dev-python/hyperframe-5.0.0[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]']
> dependency.bad dev-python/hyper-h2/hyper-h2-2.5.1.ebuild: DEPEND: ~alpha(default/linux/alpha/13.0/desktop) ['>=dev-python/hyperframe-4.0.1[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', '<dev-python/hyperframe-5.0.0[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]']
Comment 8 Stabilization helper bot gentoo-dev 2017-01-24 10:03:20 UTC
An automated check of this bug failed - repoman reported dependency errors (138 lines truncated): 

> dependency.bad dev-python/hyper-h2/hyper-h2-2.5.1.ebuild: DEPEND: ~alpha(default/linux/alpha/13.0) ['>=dev-python/hyperframe-4.0.1[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', '<dev-python/hyperframe-5.0.0[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]']
> dependency.bad dev-python/hyper-h2/hyper-h2-2.5.1.ebuild: RDEPEND: ~alpha(default/linux/alpha/13.0) ['>=dev-python/hyperframe-4.0.1[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', '<dev-python/hyperframe-5.0.0[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]']
> dependency.bad dev-python/hyper-h2/hyper-h2-2.5.1.ebuild: DEPEND: ~alpha(default/linux/alpha/13.0/desktop) ['>=dev-python/hyperframe-4.0.1[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', '<dev-python/hyperframe-5.0.0[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]']
> dependency.bad dev-python/gmpy/gmpy-2.0.4.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['sci-libs/mpir']
> dependency.bad dev-python/gmpy/gmpy-2.0.4.ebuild: RDEPEND: ia64(default/linux/ia64/13.0) ['sci-libs/mpir']
> dependency.bad dev-python/gmpy/gmpy-2.0.4.ebuild: DEPEND: ia64(default/linux/ia64/13.0/desktop) ['sci-libs/mpir']
Comment 9 Stabilization helper bot gentoo-dev 2017-01-24 16:03:32 UTC
An automated check of this bug failed - repoman reported dependency errors (138 lines truncated): 

> dependency.bad dev-python/gmpy/gmpy-2.0.4.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['sci-libs/mpir']
> dependency.bad dev-python/gmpy/gmpy-2.0.4.ebuild: RDEPEND: ia64(default/linux/ia64/13.0) ['sci-libs/mpir']
> dependency.bad dev-python/gmpy/gmpy-2.0.4.ebuild: DEPEND: ia64(default/linux/ia64/13.0/desktop) ['sci-libs/mpir']
> dependency.bad dev-python/hyper-h2/hyper-h2-2.5.1.ebuild: DEPEND: ~alpha(default/linux/alpha/13.0) ['>=dev-python/hyperframe-4.0.1[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', '<dev-python/hyperframe-5.0.0[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]']
> dependency.bad dev-python/hyper-h2/hyper-h2-2.5.1.ebuild: RDEPEND: ~alpha(default/linux/alpha/13.0) ['>=dev-python/hyperframe-4.0.1[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', '<dev-python/hyperframe-5.0.0[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]']
> dependency.bad dev-python/hyper-h2/hyper-h2-2.5.1.ebuild: DEPEND: ~alpha(default/linux/alpha/13.0/desktop) ['>=dev-python/hyperframe-4.0.1[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', '<dev-python/hyperframe-5.0.0[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]']
Comment 10 Jeroen Roovers (RETIRED) gentoo-dev 2017-01-25 06:38:46 UTC
Marked ~hppa.
Comment 11 Stabilization helper bot gentoo-dev 2017-01-25 07:03:17 UTC
An automated check of this bug failed - repoman reported dependency errors (136 lines truncated): 

> dependency.bad dev-python/gmpy/gmpy-2.0.4.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['sci-libs/mpir']
> dependency.bad dev-python/gmpy/gmpy-2.0.4.ebuild: RDEPEND: ia64(default/linux/ia64/13.0) ['sci-libs/mpir']
> dependency.bad dev-python/gmpy/gmpy-2.0.4.ebuild: DEPEND: ia64(default/linux/ia64/13.0/desktop) ['sci-libs/mpir']
> dependency.bad dev-python/hyper-h2/hyper-h2-2.5.1.ebuild: DEPEND: ~alpha(default/linux/alpha/13.0) ['>=dev-python/hyperframe-4.0.1[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', '<dev-python/hyperframe-5.0.0[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]']
> dependency.bad dev-python/hyper-h2/hyper-h2-2.5.1.ebuild: RDEPEND: ~alpha(default/linux/alpha/13.0) ['>=dev-python/hyperframe-4.0.1[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', '<dev-python/hyperframe-5.0.0[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]']
> dependency.bad dev-python/hyper-h2/hyper-h2-2.5.1.ebuild: DEPEND: ~alpha(default/linux/alpha/13.0/desktop) ['>=dev-python/hyperframe-4.0.1[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', '<dev-python/hyperframe-5.0.0[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]']
Comment 12 Mart Raudsepp gentoo-dev 2017-02-06 04:23:40 UTC
Added optional arch specification to make bot happy about gmpy and mpir already carrying some stable keywords for some arches and it then moving it back to ~arch and failing on older versions of stuff needing it.
Comment 13 Stabilization helper bot gentoo-dev 2017-02-06 05:03:13 UTC
An automated check of this bug succeeded - the previous repoman errors are now resolved.
Comment 14 Mart Raudsepp gentoo-dev 2017-02-09 09:07:18 UTC
So I added mips CC as I'd like to keyword monolith twisted and the newer versions listed here that have older versions keyworded already, so as to not lose these completely over time as old versions get removed without consideration of mips (if I can't get some profiles of it stable sooner), but I've hit like a dozen test failures in the versions, and everything except 1 seem to be generic failures, not mips specific, too.

So I don't feel confident with the quality of the package versions needed here.

Some of the test failures encountered:
bug 575064
bug 597692
bug 597700
bug 601332
bug 608496 - "SystemError: Size of mp_limb_t and mpir_si not compatible", looks like a potential real issue for mips
bug 608570
Comment 15 Brian Dolbec gentoo-dev 2017-02-11 00:15:02 UTC
I should add a note here about the twisted test suite.  Due to the network sandbox and tests being run as root when using FEATURES=test.  There were several files which had to be removed, plus some additional tests disabled.

The twisted code was never meant to be run as root.  What I have done so far for a complete test suite run, was to not do the test suite mods/deletions for a -test flag emerge run.  Then as a normal user run the following command:

$ trial twisted.

repeat for all python versions.

I'll work on the ebuild to make backup copies of the changes and restore them after the test suite is run.  That way there shouldn't be any installed file changes when only the test flag is enabled/disabled.
Comment 16 Markus Meier gentoo-dev 2017-02-19 08:40:53 UTC
~arm added
Comment 17 Stabilization helper bot gentoo-dev 2017-02-19 09:03:10 UTC
An automated check of this bug failed - repoman reported dependency errors (11 lines truncated): 

> dependency.bad dev-python/pytest/pytest-3.0.3.ebuild: DEPEND: ppc(default/linux/powerpc/ppc32/13.0) ['>dev-python/pytest-xdist-1.13[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/pytest/pytest-3.0.3.ebuild: DEPEND: ppc(default/linux/powerpc/ppc32/13.0/desktop) ['>dev-python/pytest-xdist-1.13[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/pytest/pytest-3.0.3.ebuild: DEPEND: ppc(default/linux/powerpc/ppc32/13.0/desktop/gnome) ['>dev-python/pytest-xdist-1.13[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
Comment 18 Stabilization helper bot gentoo-dev 2017-02-19 19:05:45 UTC
An automated check of this bug failed - repoman reported dependency errors (11 lines truncated): 

> dependency.bad dev-python/pytest/pytest-3.0.3.ebuild: DEPEND: ppc(default/linux/powerpc/ppc32/13.0) ['>dev-python/pytest-xdist-1.13[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/pytest/pytest-3.0.3.ebuild: DEPEND: ppc(default/linux/powerpc/ppc32/13.0/desktop) ['>dev-python/pytest-xdist-1.13[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/pytest/pytest-3.0.3.ebuild: DEPEND: ppc(default/linux/powerpc/ppc32/13.0/desktop/gnome) ['>dev-python/pytest-xdist-1.13[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
Comment 19 Mike Gilbert gentoo-dev 2017-02-19 19:19:27 UTC
(In reply to Stabilization helper bot from comment #18)

The stable bot seems to be faulty; I am unable to reproduce this repoman error.
Comment 20 Stabilization helper bot gentoo-dev 2017-02-19 20:03:18 UTC
An automated check of this bug succeeded - the previous repoman errors are now resolved.
Comment 21 Anthony Basile gentoo-dev 2017-03-12 12:31:29 UTC
keyworded ~ppc ~ppc64
Comment 22 Stabilization helper bot gentoo-dev 2017-03-12 13:02:14 UTC
An automated check of this bug failed - repoman reported dependency errors (12 lines truncated): 

> dependency.bad dev-python/pytest/pytest-3.0.3.ebuild: DEPEND: alpha(default/linux/alpha/13.0) ['>dev-python/pytest-xdist-1.13[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/pytest/pytest-3.0.3.ebuild: DEPEND: alpha(default/linux/alpha/13.0/desktop) ['>dev-python/pytest-xdist-1.13[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/pytest/pytest-3.0.3.ebuild: DEPEND: alpha(default/linux/alpha/13.0/desktop/gnome) ['>dev-python/pytest-xdist-1.13[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
Comment 23 Brian Dolbec gentoo-dev 2017-03-22 03:00:55 UTC
Removing mips for teh time being until the gmpy test failure is resolved.

This should remove any blocks for the remaining arches.
Comment 24 Stabilization helper bot gentoo-dev 2017-03-22 03:02:33 UTC
An automated check of this bug failed - repoman reported dependency errors (12 lines truncated): 

> dependency.bad dev-python/pytest/pytest-3.0.3.ebuild: DEPEND: alpha(default/linux/alpha/13.0) ['>dev-python/pytest-xdist-1.13[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/pytest/pytest-3.0.3.ebuild: DEPEND: alpha(default/linux/alpha/13.0/desktop) ['>dev-python/pytest-xdist-1.13[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/pytest/pytest-3.0.3.ebuild: DEPEND: alpha(default/linux/alpha/13.0/desktop/gnome) ['>dev-python/pytest-xdist-1.13[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
Comment 25 Stabilization helper bot gentoo-dev 2017-03-22 04:01:36 UTC
An automated check of this bug failed - repoman reported dependency errors (12 lines truncated): 

> dependency.bad dev-python/pytest/pytest-3.0.3.ebuild: DEPEND: alpha(default/linux/alpha/13.0) ['>dev-python/pytest-xdist-1.13[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/pytest/pytest-3.0.3.ebuild: DEPEND: alpha(default/linux/alpha/13.0/desktop) ['>dev-python/pytest-xdist-1.13[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/pytest/pytest-3.0.3.ebuild: DEPEND: alpha(default/linux/alpha/13.0/desktop/gnome) ['>dev-python/pytest-xdist-1.13[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
Comment 26 Stabilization helper bot gentoo-dev 2017-03-22 09:00:29 UTC
An automated check of this bug failed - the following atoms are unknown:

>=dev-python/priority-1.2.2
>=dev-python/hyper-h2-2.5.1
>=dev-python/pytest-3.0.5
>=dev-python/twisted-16.4.1
>=dev-python/hyperframe-4.0.1
>=dev-python/sphinx-py3doc-enhanced-theme-2.3.2
>=dev-python/readme-0.6.0
>=dev-python/pytest-cov-2.3.1
>=dev-python/hpack-2.3.0-r1
>=dev-python/pytest-xdist-1.15.0
>=dev-python/gmpy-2.0.8
>=dev-python/bleach-1.5.0
>=sci-libs/mpir-2.6.0-r2

Please verify the atom list.
Comment 27 Stabilization helper bot gentoo-dev 2017-03-22 09:13:36 UTC
An automated check of this bug failed - repoman reported dependency errors (7 lines truncated): 

> dependency.bad dev-python/pytest/pytest-3.0.3.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>dev-python/pytest-xdist-1.13[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/pytest/pytest-3.0.3.ebuild: DEPEND: ia64(default/linux/ia64/13.0/desktop) ['>dev-python/pytest-xdist-1.13[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/pytest/pytest-3.0.3.ebuild: DEPEND: ia64(default/linux/ia64/13.0/desktop/gnome) ['>dev-python/pytest-xdist-1.13[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
Comment 28 Stabilization helper bot gentoo-dev 2017-03-22 09:16:23 UTC
An automated check of this bug succeeded - the previous repoman errors are now resolved.
Comment 29 Markus Meier gentoo-dev 2017-03-22 19:48:30 UTC
~arm64 added
Comment 30 Brian Dolbec gentoo-dev 2017-03-30 18:48:22 UTC
I am bumping this to the 16.6.0 version now.  It includes 2 new deps which come from code split out from the twisted code base.  I've keyworded them the same as the current 16.4.1 release since that code has already been tested for those arches, (less any new packaging related code).  Plus they are all pure python, so should not be a problem on any arch anyway.

twisted-16.6.0:  I have created a new patchset for the which modify the test suite to allow setting an EMERGE_TEST_OVERRIDE variable in the environment to skip tests that are not able to run correctly in the emerge test environment.  But they are out of the way when run as a normal user after installation.

twisted-16.6.0 TESTING NOTES: 
1) the most complete test is done as a normal user after installation.
2) In python 2.7, I had 3 failures. 2 of which are due to our (my) python returning b'\xe2\x80\xa2' instead of b'\\u2022'.  They are functionaly the same, but due to some twisted code involving truncation, I was unable to fix the test to work with the actual returned string.  These tests are skipped during the emerge test run.
3) twisted.test.test_policies.LoggingFactoryTests.test_loggingFactoryOpensLogfileAutomatically  for python-2.7 only, passes for 3.{4,5,6}



Word of warning:  

We are going to have to do this all over again for twisted-17.1.0 which I am working on.  It includes several new deps not currently in the tree (python at least, so testing shouldn't be difficult, 1 includes a test suite).

But I would like for this version to get as many keywords as possible as I intend to stabilize a 16 version very soon in order to aid the twisted dep migration from the old (now unsupported) split releases to the new single package.

Twisted-17 includes a lot more py3 changes and is a requirement for buildbot-0.9.5 which adds py3 capability finally.
Comment 31 Brian Dolbec gentoo-dev 2017-03-31 21:17:15 UTC
Fixed the tests a little more along with the ebuild.

For python2.7 there were several utf8 errors that appear to be because of
interaction with other tests ahead of it.  Python then returns a different form of the same charachters causing a test failure.  These same tests pass when run on their own which the ebuild now does.

Only 1 test fail remains for 2.7:

twisted.test.test_policies.LoggingFactoryTests.test_loggingFactoryOpensLogfileAutomatically

All tests pass in python3.{4,5,6}
Comment 32 Stabilization helper bot gentoo-dev 2017-03-31 22:02:22 UTC
An automated check of this bug succeeded - the previous repoman errors are now resolved.
Comment 33 Stabilization helper bot gentoo-dev 2017-05-24 21:00:46 UTC
An automated check of this bug failed - the following atom is unknown:

dev-python/priority-1.2.2

Please verify the atom list.
Comment 34 Stabilization helper bot gentoo-dev 2017-05-24 22:02:13 UTC
An automated check of this bug succeeded - the previous repoman errors are now resolved.
Comment 35 Tobias Klausmann (RETIRED) gentoo-dev 2017-05-26 10:51:03 UTC
Keyworded on ~alpha.
Comment 36 Brian Dolbec gentoo-dev 2017-05-26 16:57:56 UTC
Update pkglist for the current tree status of all pkgs
Comment 37 Brian Dolbec gentoo-dev 2017-06-24 21:07:01 UTC
Bumping to the -r2 version as it is the way the twisted ebuilds will be from now on.

Only difference to installed pkgs is a tiny script for updating the plugin cache.
Comment 38 Sergei Trofimovich (RETIRED) gentoo-dev 2017-07-02 15:02:49 UTC
~ia64 keyworded
Comment 39 Matt Turner gentoo-dev 2018-04-06 05:23:15 UTC
added ~mips
Comment 40 Larry the Git Cow gentoo-dev 2018-07-08 19:10:05 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=65c99cc090c8a772da1c9dd305d789e5ad07442b

commit 65c99cc090c8a772da1c9dd305d789e5ad07442b
Author:     Rolf Eike Beer <eike@sf-mail.de>
AuthorDate: 2018-07-08 18:41:50 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2018-07-08 19:09:43 +0000

    dev-python/gmpy: keyworded 2.0.8 for sparc
    
    Bug: https://bugs.gentoo.org/605122
    Package-Manager: Portage-2.3.40, Repoman-2.3.9
    RepoMan-Options: --include-arches="sparc"

 dev-python/gmpy/gmpy-2.0.8.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=566dbbed760db1a35e85acb1a103ed3c607e61c6

commit 566dbbed760db1a35e85acb1a103ed3c607e61c6
Author:     Rolf Eike Beer <eike@sf-mail.de>
AuthorDate: 2018-07-08 18:41:02 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2018-07-08 19:09:43 +0000

    dev-python/twisted: keyworded 16.6.0-r3 for sparc
    
    Bug: https://bugs.gentoo.org/605122
    Package-Manager: Portage-2.3.40, Repoman-2.3.9
    RepoMan-Options: --include-arches="sparc"

 dev-python/twisted/twisted-16.6.0-r3.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=b260d5c376bffb430cf79d8c3153b3b0ac50d803

commit b260d5c376bffb430cf79d8c3153b3b0ac50d803
Author:     Rolf Eike Beer <eike@sf-mail.de>
AuthorDate: 2018-07-08 18:39:30 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2018-07-08 19:09:42 +0000

    sci-libs/mpir: keyworded 2.6.0-r2 for sparc
    
    Bug: https://bugs.gentoo.org/605122
    Package-Manager: Portage-2.3.40, Repoman-2.3.9
    RepoMan-Options: --include-arches="sparc"

 sci-libs/mpir/mpir-2.6.0-r2.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 41 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2018-07-16 14:51:05 UTC
Obsoleting in favof of #661320.