Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 605088 - emerge: Don't stop due to failure in pkg_pretend phase when "--keep-going=y" is set
Summary: emerge: Don't stop due to failure in pkg_pretend phase when "--keep-going=y" ...
Status: RESOLVED DUPLICATE of bug 404157
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-01-08 18:27 UTC by Thomas Deutschmann
Modified: 2017-01-08 18:35 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Deutschmann gentoo-dev 2017-01-08 18:27:06 UTC
I am reporting this as a bug because I couldn't find any documentation
indicating that the current behavior is desired. But maybe documentation
just needs an update so I could understand if this is a feature request.


Situation:
==========
User wants to update its system but don't want that an error will stop the
whole process.

Command of choice:

  # emerge --ask --verbose --update --deep --tree \
        --with-bdeps=y --newrepo --keep-going=y --newuse world


Expectation:
============
Imagine that emerge has to update 10 package. If one of these packages is
failing emerge should "restart" and continue with the remaining packages
(if possible due to dependencies).


Problem:
========
A package failing in "pkg_pretend" phase causes the whole emerge process
to stop with an error. Emerge does not continue updating other,
non-affected packages. The "keep-going" option is basically ignored/not
honored at this stage.


This is no theoretical problem, please see

https://github.com/gentoo/gentoo/pull/3341


Proposed solution:
==================
Emerge should continue when "keep-going" option is set, even when
encountering an error in "pkg_pretend" phase.
Comment 1 Zac Medico gentoo-dev 2017-01-08 18:35:20 UTC

*** This bug has been marked as a duplicate of bug 404157 ***