Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 604500 - <www-client/seamonkey-bin-2.46 <www-client/seamonkey-2.46-r1: multiple vulnerabilities (CVE-2016-9079)
Summary: <www-client/seamonkey-bin-2.46 <www-client/seamonkey-2.46-r1: multiple vulner...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: Normal critical (vote)
Assignee: Gentoo Security
URL:
Whiteboard: A1 [glsa cve]
Keywords:
Depends on: 590178 593070
Blocks: 574968
  Show dependency tree
 
Reported: 2017-01-03 12:30 UTC by Lars Wendler (Polynomial-C)
Modified: 2017-01-13 15:03 UTC (History)
2 users (show)

See Also:
Package list:
=www-client/seamonkey-2.46-r1 =www-client/seamonkey-bin-2.46
Runtime testing required: ---
stable-bot: sanity-check+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lars Wendler (Polynomial-C) gentoo-dev 2017-01-03 12:30:19 UTC
Arches please test and mark stable the following two packages with thei mentioned target keywords:

=www-client/seamonkey-2.46:     ~alpha amd64 ~arm ~ppc ~ppc64 x86
=www-client/seamonkey-bin-2.46: amd64 x86
Comment 1 Stabilization helper bot gentoo-dev 2017-01-04 15:07:57 UTC
An automated check of this bug failed - repoman reported dependency errors (21 lines truncated): 

> dependency.bad www-client/seamonkey/seamonkey-2.46.ebuild: DEPEND: x86(default/linux/x86/13.0) ['>=dev-db/sqlite-3.13.0:3[secure-delete,debug=]']
> dependency.bad www-client/seamonkey/seamonkey-2.46.ebuild: RDEPEND: x86(default/linux/x86/13.0) ['>=dev-db/sqlite-3.13.0:3[secure-delete,debug=]']
> dependency.bad www-client/seamonkey/seamonkey-2.46.ebuild: DEPEND: x86(default/linux/x86/13.0/desktop) ['>=dev-db/sqlite-3.13.0:3[secure-delete,debug=]']
Comment 2 Thomas Deutschmann gentoo-dev Security 2017-01-04 15:41:50 UTC
Added to existing GLSA.
Comment 3 Aaron Bauman Gentoo Infrastructure gentoo-dev Security 2017-01-05 08:33:42 UTC
amd64 stable
Comment 4 Lars Wendler (Polynomial-C) gentoo-dev 2017-01-08 21:55:56 UTC
We revbumped seamonkey-2.46 so it works with >=dev-libs/nss-3.28 and committed that straight to stable where -r0 was already stable.

New stable targets are:

=www-client/seamonkey-2.46-r1:  ~alpha amd64 ~arm ~ppc ~ppc64 x86
=www-client/seamonkey-bin-2.46: amd64 x86
Comment 5 Myckel Habets 2017-01-12 18:16:43 UTC
Both packages build and run fine on x86. Please mark stable for x86.
Comment 6 Lars Wendler (Polynomial-C) gentoo-dev 2017-01-13 14:22:00 UTC
commit 97e3b969f2145a2f8d1167eb33c10a6b534d2723
Author: Lars Wendler <polynomial-c@gentoo.org>
Date:   Fri Jan 13 15:06:19 2017

    www-client/seamonkey: Security cleanup for bug #604500

    Package-Manager: Portage-2.3.3, Repoman-2.3.1

commit e6b5887df7a737c56598be2443fcf935dab50777
Author: Lars Wendler <polynomial-c@gentoo.org>
Date:   Fri Jan 13 15:00:52 2017

    www-client/seamonkey-bin: Security cleanup for bug #604500

    Package-Manager: Portage-2.3.3, Repoman-2.3.1

commit 7eee60d5308357c76615848a9bd580ae76999afc
Author: Lars Wendler <polynomial-c@gentoo.org>
Date:   Fri Jan 13 15:00:12 2017

    www-client/seamonkey-bin: Stable for x86 (bug #604500)

    as reported by Myckel Habets in the bug.

    Package-Manager: Portage-2.3.3, Repoman-2.3.1
    RepoMan-Options: --include-arches="x86"

commit fbd9086a8fc457b41a6809cda758c0d6396bd4c2
Author: Lars Wendler <polynomial-c@gentoo.org>
Date:   Fri Jan 13 14:59:02 2017

    www-client/seamonkey: Stable for x86 (bug #604500)

    as reported by Myckel Habets in the bug.

    Package-Manager: Portage-2.3.3, Repoman-2.3.1
    RepoMan-Options: --include-arches="x86"
Comment 7 GLSAMaker/CVETool Bot gentoo-dev 2017-01-13 15:03:15 UTC
This issue was resolved and addressed in
 GLSA 201701-35 at https://security.gentoo.org/glsa/201701-35
by GLSA coordinator Aaron Bauman (b-man).