Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 604228 - sys-fs/multipath-tools-0.6.2-r2 : ../.../libmultipath.so: undefined reference to `minor'
Summary: sys-fs/multipath-tools-0.6.2-r2 : ../.../libmultipath.so: undefined reference...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
: 633500 (view as bug list)
Depends on:
Blocks: glibc-sysmacros
  Show dependency tree
 
Reported: 2016-12-31 09:26 UTC by Toralf Förster
Modified: 2017-10-28 15:09 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-history.txt (emerge-history.txt,47.83 KB, text/plain)
2016-12-31 09:27 UTC, Toralf Förster
Details
environment (environment,84.72 KB, text/plain)
2016-12-31 09:27 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,11.10 KB, application/x-bzip)
2016-12-31 09:27 UTC, Toralf Förster
Details
sys-fs:multipath-tools-0.6.2-r2:20161231-075047.log (sys-fs:multipath-tools-0.6.2-r2:20161231-075047.log,27.65 KB, text/plain)
2016-12-31 09:27 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2016-12-31 09:26:55 UTC
x86_64-pc-linux-gnu-gcc -Wunused -Wstrict-prototypes -O2 -g -pipe -Wformat-security -Wall -Wp,-U_FORTIFY_SOURCE -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -fPIC -DLIB_STRING=\"lib64\" -DRUN_DIR=\"run\" -I../libmultipath -I../libmpathcmd -c -o main.o main.c
x86_64-pc-linux-gnu-gcc -Wunused -Wstrict-prototypes -O2 -g -pipe -Wformat-security -Wall -Wp,-U_FORTIFY_SOURCE -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -fPIC -DLIB_STRING=\"lib64\" -DRUN_DIR=\"run\" -I../libmultipath -I../libmpathcmd -Wl,-O1 -Wl,--as-needed main.o -o multipath -lpthread -ldevmapper -ldl -L../libmultipath -lmultipath -ludev -L../libmpathcmd -lmpathcmd
../libmultipath/libmultipath.so: undefined reference to `minor'

  -----------------------------------------------------------------

  This is an unstable amd64 chroot image (named 13.0-no-multilib-libressl-unstable_20161230-143925) at a hardened host acting as a tinderbox.

  -----------------------------------------------------------------
  from make.conf:
USE="  -openssl -gnutls libressl pax_kernel xtpax -cdinstall -oci8 -bindist ssp aqua -avformat cdb contrib corefonts dbus dot eglfs freetds gif -go gstreamer gtk hdf5 help ipv6 kerberos mbox -policykit printsupport pulseaudio qt5 rendering smartcard sql system-harfbuzz udev v4l2 wayland webgl X xkb xml xvfb zenmap"

gcc-config -l:
 [1] x86_64-pc-linux-gnu-5.4.0 *
llvm-config --version:
3.9.1

Available Python interpreters, in order of preference:
  [1]   python3.4
  [2]   python2.7 (fallback)

java-config:

  -----------------------------------------------------------------



$ cat emerge-info.txt
Portage 2.3.3 (python 3.4.5-final-0, default/linux/amd64/13.0/no-multilib, gcc-5.4.0, glibc-2.24, 4.8.15-hardened x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.8.15-hardened-x86_64-Intel-R-_Core-TM-_i7-3930K_CPU_@_3.20GHz-with-gentoo-2.3
KiB Mem:    65285560 total,   3415484 free
KiB Swap:   67108860 total,  67091444 free
Timestamp of repository gentoo: Sat, 31 Dec 2016 04:22:39 +0000
sh bash 4.4_p5-r1
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.4_p5-r1::gentoo
dev-lang/perl:            5.24.1_rc4::gentoo
dev-lang/python:          2.7.12::gentoo, 3.4.5::gentoo
dev-util/cmake:           3.7.1::gentoo
dev-util/pkgconfig:       0.29.1::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/openrc:          0.23::gentoo
sys-apps/sandbox:         2.10-r2::gentoo
sys-devel/autoconf:       2.69-r2::gentoo
sys-devel/automake:       1.13.4-r1::gentoo, 1.14.1-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo, 2.27::gentoo
sys-devel/gcc:            5.4.0-r2::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r2::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.9::gentoo (virtual/os-headers)
sys-libs/glibc:           2.24::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: 1

tinderbox
    location: /tmp/tb/data/portage
    masters: gentoo
    priority: 2

local
    location: /usr/local/portage
    masters: gentoo
    priority: 99

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=native -Wall"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php7.1/ext-active/ /etc/php/cgi-php7.1/ext-active/ /etc/php/cli-php7.1/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=native"
DISTDIR="/var/tmp/distfiles"
EMERGE_DEFAULT_OPTS="--verbose --verbose-conflicts --color=n --nospinner --tree --quiet-build"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync network-sandbox parallel-fetch preserve-libs protect-owned sandbox sfperms strict test-fail-continue unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.uni-erlangen.de/pub/mirrors/gentoo rsync://mirror.netcologne.de/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gor.bytemark.co.uk/gentoo/ rsync://ftp.snt.utwente.nl/gentoo"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X acl amd64 berkdb bzip2 cdb cli contrib corefonts cracklib crypt cxx dbus dot dri eglfs fortran freetds gdbm gif gstreamer gtk hdf5 help iconv ipv6 kerberos libressl mbox mmx mmxext modules ncurses nls nptl openmp pam pax_kernel pcre printsupport pulseaudio qt5 readline rendering seccomp session smartcard sql sse sse2 ssl ssp system-harfbuzz tcpd udev unicode v4l2 wayland webgl xattr xkb xml xtpax xvfb zenmap zlib" ABI_X86="64" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" CURL_SSL="libressl" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" L10N="ast bo gd nr" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby21" USERLAND="GNU" VIDEO_CARDS="intel i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Toralf Förster gentoo-dev 2016-12-31 09:27:01 UTC
Created attachment 458092 [details]
emerge-history.txt
Comment 2 Toralf Förster gentoo-dev 2016-12-31 09:27:05 UTC
Created attachment 458094 [details]
environment
Comment 3 Toralf Förster gentoo-dev 2016-12-31 09:27:08 UTC
Created attachment 458096 [details]
etc.portage.tbz2
Comment 4 Toralf Förster gentoo-dev 2016-12-31 09:27:11 UTC
Created attachment 458098 [details]
sys-fs:multipath-tools-0.6.2-r2:20161231-075047.log
Comment 5 Anthony Ryan 2017-01-04 05:20:28 UTC
I've got a patch sent upstream, as soon as it's been accepted I'll get this issue resolved together with a version bump to 0.6.4.
Comment 6 Lars Wendler (Polynomial-C) gentoo-dev 2017-08-02 06:31:08 UTC
This has been patched in multipath-tools-0.6.4 and fixed in multipath-tools-0.7.1 by upstream.
Comment 7 Mike Gilbert gentoo-dev 2017-10-28 15:09:00 UTC
*** Bug 633500 has been marked as a duplicate of this bug. ***