Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 604086 - games-strategy/freeorion-0.4.5-r1 : /.../construct_10.hpp:23:25: error: invalid conversion from ‘const char*’ to ‘param_type {aka char*}’ [-fpermissive]
Summary: games-strategy/freeorion-0.4.5-r1 : /.../construct_10.hpp:23:25: error: inval...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Adam Feldman
URL: https://github.com/freeorion/freeorio...
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-6
  Show dependency tree
 
Reported: 2016-12-29 21:47 UTC by Toralf Förster
Modified: 2017-04-26 18:45 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-history.txt (emerge-history.txt,329.98 KB, text/plain)
2016-12-29 21:47 UTC, Toralf Förster
Details
environment (environment,168.59 KB, text/plain)
2016-12-29 21:47 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,18.22 KB, application/x-bzip)
2016-12-29 21:47 UTC, Toralf Förster
Details
games-strategy:freeorion-0.4.5-r1:20161229-190242.log (games-strategy:freeorion-0.4.5-r1:20161229-190242.log,119.43 KB, text/plain)
2016-12-29 21:48 UTC, Toralf Förster
Details
emerge-info.txt (emerge-info.txt,5.50 KB, text/plain)
2017-03-26 19:53 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,43.79 KB, text/plain)
2017-03-26 19:53 UTC, Toralf Förster
Details
environment (environment,163.72 KB, text/plain)
2017-03-26 19:53 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,21.75 KB, application/x-bzip)
2017-03-26 19:53 UTC, Toralf Förster
Details
games-strategy:freeorion-0.4.6:20170326-192031.log (games-strategy:freeorion-0.4.6:20170326-192031.log,117.99 KB, text/plain)
2017-03-26 19:53 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,42.10 KB, application/x-bzip)
2017-03-26 19:53 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2016-12-29 21:47:44 UTC
/usr/include/boost/phoenix/object/detail/cpp03/preprocessed/construct_10.hpp: In instantiation of ‘const typename boost::phoenix::expression::construct<boost::phoenix::detail::target<T>, A0>::type boost::phoenix::construct(const A0&) [with T = std::__cxx11::basic_string<char>; A0 = char [21]; typename boost::phoenix::expression::construct<boost::phoenix::detail::target<T>, A0>::type = boost::phoenix::actor<boost::proto::exprns_::basic_expr<boost::phoenix::tag::construct, boost::proto::argsns_::list2<boost::proto::exprns_::basic_expr<boost::proto::tagns_::tag::terminal, boost::proto::argsns_::term<boost::phoenix::detail::target<std::__cxx11::basic_string<char> > >, 0l>, boost::proto::exprns_::basic_expr<boost::proto::tagns_::tag::terminal, boost::proto::argsns_::term<char*>, 0l> >, 2l> >]’:
/var/tmp/portage/games-strategy/freeorion-0.4.5-r1/work/freeorion-0.4.5/parse/DoubleComplexValueRefParser.cpp:49:96:   required from here
/usr/include/boost/phoenix/object/detail/cpp03/preprocessed/construct_10.hpp:23:25: error: invalid conversion from ‘const char*’ to ‘param_type {aka char*}’ [-fpermissive]
             expression::
             ~~~~~~~~~~~~ 
                 construct<detail::target<T>, A0>::

  -----------------------------------------------------------------

  This is an unstable amd64 chroot image (named gnome-systemd-unstable_20161221-233014) at a hardened host acting as a tinderbox.

  -----------------------------------------------------------------
  from make.conf:
USE="  pax_kernel xtpax -cdinstall -oci8 -bindist ssp aqua -btrfs cgroups clang dec_av2 drmkms dvb -eglfs extra fluidsynth -fortran haptic llvm modplug odbc -ogg python semantic-desktop server smime sockets system-libvpx -system-llvm system-sqlite szip -timidity xcb"

gcc-config -l:
 [1] x86_64-pc-linux-gnu-6.2.0
 [2] x86_64-pc-linux-gnu-6.3.0 *
llvm-config --version:
3.9.1
Available Java Virtual Machines:
  [1]   icedtea-bin-7 
  [2]   icedtea-bin-8  system-vm
Available Python interpreters, in order of preference:
  [1]   python2.7
  [2]   python3.4
  [3]   python3.5 (fallback)
  [4]   jython2.7 (fallback)

java-config:
The following VMs are available for generation-2:
1)	IcedTea JDK 7.2.6.8 [icedtea-bin-7]
*)	IcedTea JDK 3.2.0 [icedtea-bin-8]
  -----------------------------------------------------------------



$ cat emerge-info.txt
Portage 2.3.3 (python 2.7.12-final-0, default/linux/amd64/13.0/desktop/gnome/systemd, gcc-6.3.0, glibc-2.23-r3, 4.8.15-hardened x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.8.15-hardened-x86_64-Intel-R-_Core-TM-_i7-3930K_CPU_@_3.20GHz-with-gentoo-2.3
KiB Mem:    65285560 total,   9170528 free
KiB Swap:   67108860 total,  67092124 free
Timestamp of repository gentoo: Thu, 29 Dec 2016 17:02:40 +0000
sh bash 4.4_p5-r1
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.4_p5-r1::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.1_rc4::gentoo
dev-lang/python:          2.7.12::gentoo, 3.4.5::gentoo, 3.5.2::gentoo
dev-util/cmake:           3.7.1::gentoo
dev-util/pkgconfig:       0.29.1::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/openrc:          0.23::gentoo
sys-apps/sandbox:         2.10-r2::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r2::gentoo
sys-devel/automake:       1.9.6-r4::gentoo, 1.11.6-r2::gentoo, 1.12.6-r1::gentoo, 1.13.4-r1::gentoo, 1.14.1-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo, 2.27::gentoo
sys-devel/gcc:            6.2.0-r1::gentoo, 6.3.0::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r2::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.9::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r3::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: 1

tinderbox
    location: /tmp/tb/data/portage
    masters: gentoo
    priority: 2

local
    location: /usr/local/portage
    masters: gentoo
    priority: 99

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=native -Wall"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /etc/stunnel/stunnel.conf /opt/openfire/resources/security/ /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-Werror=terminate -O2 -pipe -march=native"
DISTDIR="/var/tmp/distfiles"
EMERGE_DEFAULT_OPTS="--verbose --verbose-conflicts --color=n --nospinner --tree --quiet-build"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync network-sandbox parallel-fetch preserve-libs protect-owned sandbox sfperms strict test-fail-continue unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.uni-erlangen.de/pub/mirrors/gentoo rsync://mirror.netcologne.de/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gor.bytemark.co.uk/gentoo/ rsync://ftp.snt.utwente.nl/gentoo"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cgroups clang cli colord cracklib crypt cups cxx dbus dec_av2 dri drmkms dts dvb dvd dvdr eds emboss encode evo exif extra fam firefox flac fluidsynth gdbm gif glamor gnome gnome-keyring gnome-online-accounts gpm gstreamer gtk haptic iconv introspection ipv6 jpeg lcms ldap libnotify libsecret llvm mad mmx mmxext mng modplug modules mp3 mp4 mpeg multilib nautilus ncurses nls nptl odbc opengl openmp pam pango pax_kernel pcre pdf png policykit ppds pulseaudio python qt3support qt4 readline sdl seccomp semantic-desktop server session smime sockets spell sse sse2 ssl ssp startup-notification svg system-libvpx system-sqlite systemd szip tcpd tiff tracker truetype udev udisks unicode upower usb vorbis wxwidgets x264 xattr xcb xml xtpax xv xvid zlib" ABI_X86="64" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" L10N="cak et fi la my pa pl tg" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby21" USERLAND="GNU" VIDEO_CARDS="intel i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Toralf Förster gentoo-dev 2016-12-29 21:47:51 UTC
Created attachment 457862 [details]
emerge-history.txt
Comment 2 Toralf Förster gentoo-dev 2016-12-29 21:47:54 UTC
Created attachment 457864 [details]
environment
Comment 3 Toralf Förster gentoo-dev 2016-12-29 21:47:57 UTC
Created attachment 457866 [details]
etc.portage.tbz2
Comment 4 Toralf Förster gentoo-dev 2016-12-29 21:48:00 UTC
Created attachment 457868 [details]
games-strategy:freeorion-0.4.5-r1:20161229-190242.log
Comment 5 Adam Feldman gentoo-dev 2017-03-16 04:24:46 UTC
Hey Toralf, can you try this again with 0.4.6?
Comment 6 Adam Feldman gentoo-dev 2017-03-16 04:25:40 UTC
Hey Toralf, can you try this again with 0.4.6?
Comment 7 Toralf Förster gentoo-dev 2017-03-16 19:33:39 UTC
(In reply to NP-Hardass from comment #6)
that version failed at this image with the same error - whereas it emerges fine at another image : desktop-abi32+64_20170228-084815

ofc I might upgrade @world this image and then look again ....
Comment 8 Adam Feldman gentoo-dev 2017-03-17 01:27:26 UTC
(In reply to Toralf Förster from comment #7)
> (In reply to NP-Hardass from comment #6)
> that version failed at this image with the same error - whereas it emerges
> fine at another image : desktop-abi32+64_20170228-084815
> 
> ofc I might upgrade @world this image and then look again ....

Let me know what you find out.  I just added -fpermissive to CFLAGS and 0.4.6 compiled without issue on my system.
Comment 9 Toralf Förster gentoo-dev 2017-03-26 19:53:05 UTC
same issue at an unstable amd64 chroot image (named plasma-abi32+64_20170325-144619)
Comment 10 Toralf Förster gentoo-dev 2017-03-26 19:53:07 UTC
Created attachment 468376 [details]
emerge-info.txt
Comment 11 Toralf Förster gentoo-dev 2017-03-26 19:53:10 UTC
Created attachment 468378 [details]
emerge-history.txt
Comment 12 Toralf Förster gentoo-dev 2017-03-26 19:53:13 UTC
Created attachment 468380 [details]
environment
Comment 13 Toralf Förster gentoo-dev 2017-03-26 19:53:16 UTC
Created attachment 468382 [details]
etc.portage.tbz2
Comment 14 Toralf Förster gentoo-dev 2017-03-26 19:53:19 UTC
Created attachment 468384 [details]
games-strategy:freeorion-0.4.6:20170326-192031.log
Comment 15 Toralf Förster gentoo-dev 2017-03-26 19:53:22 UTC
Created attachment 468386 [details]
temp.tbz2
Comment 16 Adam Feldman gentoo-dev 2017-04-25 19:02:25 UTC
Toralf, should be fixed in 0.4.7_rc2, can you test that with boost-1.63?
Comment 17 Toralf Förster gentoo-dev 2017-04-26 18:39:13 UTC
(In reply to NP-Hardass from comment #16)
indeed - fixed there
Comment 18 Adam Feldman gentoo-dev 2017-04-26 18:45:15 UTC
Affected version removed in 438e3912063d437bf8aa036f8812fdf4dd3cccde


Thanks, as always, Toralf.