Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 604042 - media-gfx/darktable-2.2.0 with =dev-python/jsonschema-2.5.1-r2 - jsonschema: error: argument -i/--instance: invalid _json_file value
Summary: media-gfx/darktable-2.2.0 with =dev-python/jsonschema-2.5.1-r2 - jsonschema: ...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Gentoo Graphics Project
URL: https://github.com/Julian/jsonschema/...
Whiteboard:
Keywords:
: 640518 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-12-29 15:41 UTC by Jura
Modified: 2017-12-25 00:58 UTC (History)
8 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,119.15 KB, text/plain)
2016-12-29 15:41 UTC, Jura
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jura 2016-12-29 15:41:22 UTC
Created attachment 457822 [details]
build.log

installed =dev-python/jsonschema-2.5.1-r2

can't build darktable-2.2.0(and 2.3.0 too)

# cd /var/tmp/portage/media-gfx/darktable-2.2.0/work/darktable-2.2.0_build
# make
...
...
[ 90%] Built target darktable-chart
[ 90%] Built target darktable.appdata_file
[ 90%] Checking validity of noiseprofiles.json
usage: jsonschema [-h] [-i INSTANCES] [-F ERROR_FORMAT] [-V VALIDATOR] schema
jsonschema: error: argument -i/--instance: invalid _json_file value: '/var/tmp/portage/media-gfx/darktable-2.2.0/work/darktable-2.2.0/data/noiseprofiles.json'
make[2]: *** [data/CMakeFiles/validate_noiseprofiles_json.dir/build.make:59: data/CMakeFiles/validate_noiseprofiles_json] Error 2
make[1]: *** [CMakeFiles/Makefile2:6472: data/CMakeFiles/validate_noiseprofiles_json.dir/all] Error 2
make: *** [Makefile:150: all] Error 2
Comment 1 Elfenbein, Karsten 2016-12-30 10:54:43 UTC
I get this as well when the default Python interpreter is set to Python version 3.4.

After switching the default Python to version 2.7 the build worked. ("eselect python list" "eselect python set X")
Comment 2 Zoltan Puskas 2017-01-09 02:53:25 UTC
Same happens when building =media-gfx/darktable-2.2.1

...
[ 14%] Built target darktable.appdata_file
usage: jsonschema [-h] [-i INSTANCES] [-F ERROR_FORMAT] [-V VALIDATOR] schema
jsonschema: error: argument -i/--instance: invalid _json_file value: '/tmp/portage/media-gfx/darktable-2.2.1/work/darktable-2.2.1/data/noiseprofiles.json'
make[2]: *** [data/CMakeFiles/validate_noiseprofiles_json.dir/build.make:59: data/CMakeFiles/validate_noiseprofiles_json] Error 2
make[2]: Leaving directory '/tmp/portage/media-gfx/darktable-2.2.1/work/darktable-2.2.1_build'
make[1]: *** [CMakeFiles/Makefile2:6632: data/CMakeFiles/validate_noiseprofiles_json.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
make[2]: Leaving directory '/tmp/portage/media-gfx/darktable-2.2.1/work/darktable-2.2.1_build'
make -f src/external/rawspeed/CMakeFiles/rawspeed.dir/build.make src/external/rawspeed/CMakeFiles/rawspeed.dir/build
make[2]: Entering directory '/tmp/portage/media-gfx/darktable-2.2.1/work/darktable-2.2.1_build'
...
Comment 3 Alexander Pitzer 2017-01-11 22:38:13 UTC
I had this problem with media-gfx/darktable-2.2.1, too. The switch to python2.7, like suggested by 'Elfenbein, Karsten', via eselect solved the problem.
Comment 4 Tom Gillespie 2017-01-18 21:31:21 UTC
Confirming that switching the python interpreter to 2.7 fixes this for media-gfx/darktable-2.2.1
Comment 6 Markus Meier gentoo-dev 2017-01-19 20:55:04 UTC
(In reply to Lebedev Roman from comment #5)
> It's https://github.com/Julian/jsonschema/issues/299#issuecomment-250469699

Thanks for the link. Let's see what will happen in that issue...
Comment 7 Markus Meier gentoo-dev 2017-02-16 21:25:15 UTC
(In reply to Jura from comment #0)
(In reply to Alexander Pitzer from comment #3)
(In reply to Tom Gillespie from comment #4)

What LANG and LC_ALL are you using? Looking at the linked jsonschema report, things should be fine with a "sane" LANG/LC_ALL setting.
Comment 8 Hendrik v. Raven 2017-07-23 10:53:26 UTC
I get the same bug. I am using paludis which enforces a locale of C unless specified otherwise, apparently a UTF-8 locle is required.
The issue can be fixed by calling python_export_utf8_locale from the python-utils-r1.eclass in the compile phase.
Comment 9 Ben Kohler gentoo-dev 2017-12-10 14:23:55 UTC
*** Bug 640518 has been marked as a duplicate of this bug. ***
Comment 10 Denis Descheneaux 2017-12-25 00:58:08 UTC
Comment 8 works also for v.2.4.0

This could be changed as to not pull in :4 if you have :5 already installed

in the CDEPEND= section for v.2.4.0

	opencl? (
		>=sys-devel/llvm-4:=
		>=sys-devel/clang-4:=
		virtual/opencl
		)