Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 603326 - app-emulation/libdsk-1.4.2 : ../.../libdsk.so: undefined reference to `major'
Summary: app-emulation/libdsk-1.4.2 : ../.../libdsk.so: undefined reference to `major'
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Chema Alonso Josa (RETIRED)
URL:
Whiteboard: ~arch only
Keywords:
Depends on:
Blocks: glibc-sysmacros
  Show dependency tree
 
Reported: 2016-12-21 12:06 UTC by Toralf Förster
Modified: 2018-04-27 22:58 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
app-emulation:libdsk-1.4.2:20161221-115923.log (app-emulation:libdsk-1.4.2:20161221-115923.log,55.21 KB, text/plain)
2016-12-21 12:06 UTC, Toralf Förster
Details
config.log (config.log,71.17 KB, text/plain)
2016-12-21 12:06 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,150.17 KB, text/plain)
2016-12-21 12:06 UTC, Toralf Förster
Details
environment (environment,15.23 KB, text/plain)
2016-12-21 12:06 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,10.46 KB, application/x-bzip2)
2016-12-21 12:06 UTC, Toralf Förster
Details
emerge-info.txt (emerge-info.txt,17.24 KB, text/plain)
2017-07-14 17:51 UTC, Toralf Förster
Details
app-emulation:libdsk-1.5.4:20170714-000846.log (app-emulation:libdsk-1.5.4:20170714-000846.log,56.69 KB, text/plain)
2017-07-14 17:51 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,296.43 KB, text/plain)
2017-07-14 17:52 UTC, Toralf Förster
Details
environment (environment,17.01 KB, text/plain)
2017-07-14 17:52 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,57.25 KB, application/x-bzip)
2017-07-14 17:52 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,9.99 KB, application/x-bzip)
2017-07-14 17:52 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,11.31 KB, application/x-bzip)
2017-07-14 17:52 UTC, Toralf Förster
Details
emerge-info.txt (emerge-info.txt,15.42 KB, text/plain)
2017-11-23 19:08 UTC, Toralf Förster
Details
app-emulation:libdsk-1.5.4:20171123-104443.log (app-emulation:libdsk-1.5.4:20171123-104443.log,56.69 KB, text/plain)
2017-11-23 19:08 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,175.69 KB, text/plain)
2017-11-23 19:08 UTC, Toralf Förster
Details
environment (environment,15.15 KB, text/plain)
2017-11-23 19:08 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,12.60 KB, application/x-bzip)
2017-11-23 19:08 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,9.96 KB, application/x-bzip)
2017-11-23 19:08 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,10.79 KB, application/x-bzip)
2017-11-23 19:08 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2016-12-21 12:06:23 UTC
/bin/sh ../libtool  --tag=CC   --mode=link x86_64-pc-linux-gnu-gcc  -Wall -DNOTWINDLL -O2 -pipe -march=native -Wall  -Wl,-O1 -Wl,--as-needed -o dsktrans dsktrans.o utilopts.o formname.o bootsec.o ../lib/libdsk.la -lbz2 -lz 
libtool: link: x86_64-pc-linux-gnu-gcc -Wall -DNOTWINDLL -O2 -pipe -march=native -Wall -Wl,-O1 -Wl,--as-needed -o .libs/dsktrans dsktrans.o utilopts.o formname.o bootsec.o  ../lib/.libs/libdsk.so -lbz2 -lz
../lib/.libs/libdsk.so: undefined reference to `major'
collect2: error: ld returned 1 exit status
make[2]: *** [Makefile:544: dsktrans] Error 1
make[2]: Leaving directory '/var/tmp/portage/app-emulation/libdsk-1.4.2/work/libdsk-1.4.2/tools'


$ cat emerge-info.txt
  -----------------------------------------------------------------

  This is an unstable amd64 chroot image (named plasma-systemd-unstable_20161218-165256) at a hardened host acting as a tinderbox.

  -----------------------------------------------------------------
  USE flags in make.conf:
USE="  pax_kernel xtpax -cdinstall -oci8 -bindist ssp aqua contrib -extraengine fax ffmpeg fontconfig gzip haptic ldap llvm mbox midi minizip mp4 mpeg2 mta nscd opencv png python qml scrypt swscale v4l xkb"
  -----------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-5.4.0 *
llvm-config --version:
3.9.0
Available Java Virtual Machines:
  [1]   icedtea-bin-8  system-vm
Available Python interpreters, in order of preference:
  [1]   python3.4
  [2]   python3.5 (fallback)
  [3]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby21 (with Rubygems) *
java-config:
The following VMs are available for generation-2:
*)	IcedTea JDK 3.2.0 [icedtea-bin-8]
  -----------------------------------------------------------------

Portage 2.3.3 (python 3.4.5-final-0, default/linux/amd64/13.0/desktop/plasma/systemd, gcc-5.4.0, glibc-2.24, 4.8.15-hardened x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.8.15-hardened-x86_64-Intel-R-_Core-TM-_i7-3930K_CPU_@_3.20GHz-with-gentoo-2.3
KiB Mem:    65285560 total,   3031180 free
KiB Swap:   67108860 total,  67097560 free
Timestamp of repository gentoo: Wed, 21 Dec 2016 11:22:23 +0000
sh bash 4.4_p5-r1
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.4_p5-r1::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.1_rc4::gentoo
dev-lang/python:          2.7.12::gentoo, 3.4.5::gentoo, 3.5.2::gentoo
dev-util/cmake:           3.7.1::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/openrc:          0.23::gentoo
sys-apps/sandbox:         2.10-r2::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r2::gentoo
sys-devel/automake:       1.9.6-r4::gentoo, 1.11.6-r2::gentoo, 1.13.4-r1::gentoo, 1.14.1-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo, 2.27::gentoo
sys-devel/gcc:            5.4.0::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r2::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.9::gentoo (virtual/os-headers)
sys-libs/glibc:           2.24::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: 1

tinderbox
    location: /tmp/tb/data/portage
    masters: gentoo
    priority: 2

local
    location: /usr/local/portage
    masters: gentoo
    priority: 99

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=native -Wall"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/easy-rsa /usr/share/gnupg/qualified.txt /var/lib/i2pd/certificates"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -march=native"
DISTDIR="/var/tmp/distfiles"
EMERGE_DEFAULT_OPTS="--verbose --verbose-conflicts --color=n --nospinner --tree --quiet-build"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync network-sandbox parallel-fetch preserve-libs protect-owned sandbox sfperms strict test-fail-continue unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.uni-erlangen.de/pub/mirrors/gentoo rsync://mirror.netcologne.de/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gor.bytemark.co.uk/gentoo/ rsync://ftp.snt.utwente.nl/gentoo"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cli contrib cracklib crypt cups cxx dbus declarative dri dts dvd dvdr emboss encode exif fam fax ffmpeg firefox flac fontconfig fortran gdbm gif glamor gpm gtk gzip haptic iconv ipv6 jpeg kde kipi lcms ldap libnotify llvm mad mbox midi minizip mmx mmxext mng modules mp3 mp4 mpeg mpeg2 mta multilib ncurses nls nptl nscd ogg opencv opengl openmp pam pango pax_kernel pcre pdf phonon plasma png policykit ppds python qml qt3support qt4 qt5 readline scrypt sdl seccomp semantic-desktop session spell sse sse2 ssl ssp startup-notification svg swscale systemd tcpd tiff truetype udev udisks unicode upower usb v4l vorbis widgets wxwidgets x264 xattr xcb xcomposite xinerama xkb xml xscreensaver xtpax xv xvid zlib" ABI_X86="64" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" L10N="ach bn-IN cy el eo ml ne sa sid" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby21" USERLAND="GNU" VIDEO_CARDS="intel i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Toralf Förster gentoo-dev 2016-12-21 12:06:30 UTC
Created attachment 456976 [details]
app-emulation:libdsk-1.4.2:20161221-115923.log
Comment 2 Toralf Förster gentoo-dev 2016-12-21 12:06:33 UTC
Created attachment 456978 [details]
config.log
Comment 3 Toralf Förster gentoo-dev 2016-12-21 12:06:35 UTC
Created attachment 456980 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2016-12-21 12:06:39 UTC
Created attachment 456982 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2016-12-21 12:06:41 UTC
Created attachment 456984 [details]
etc.portage.tbz2
Comment 6 Chema Alonso Josa (RETIRED) gentoo-dev 2017-04-06 07:24:44 UTC
Version bumped, libdsk-1.4.2 no longer in the tree. Closing.

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=47d7e8d90095dea484a232b5f52413dd8bd26f6c
Comment 7 Toralf Förster gentoo-dev 2017-05-18 16:27:21 UTC
(In reply to Chema Alonso Josa from comment #6)
1.5.4:
libtool: link: x86_64-pc-linux-gnu-gcc -Wall -DNOTWINDLL -O2 -pipe -march=native -Wall -Wl,-O1 -Wl,--as-needed -o .libs/dsktrans dsktrans.o utilopts.o formname.o bootsec.o  ../lib/.libs/libdsk.so -lbz2 -lz
../lib/.libs/libdsk.so: undefined reference to `major'
collect2: error: ld returned 1 exit status
make[2]: *** [Makefile:554: dsktrans] Error 1
make[2]: Leaving directory '/var/tmp/portage/app-emulation/libdsk-1.5.4/work/libdsk-1.5.4/tools'

--
Comment 8 Toralf Förster gentoo-dev 2017-07-14 17:51:52 UTC
got at the unstable amd64 chroot image 13.0_20170706-210712 this : app-emulation/libdsk-1.5.4 : ../.../libdsk.so: undefined reference to  major
Comment 9 Toralf Förster gentoo-dev 2017-07-14 17:51:55 UTC
Created attachment 484446 [details]
emerge-info.txt
Comment 10 Toralf Förster gentoo-dev 2017-07-14 17:51:58 UTC
Created attachment 484448 [details]
app-emulation:libdsk-1.5.4:20170714-000846.log
Comment 11 Toralf Förster gentoo-dev 2017-07-14 17:52:01 UTC
Created attachment 484450 [details]
emerge-history.txt
Comment 12 Toralf Förster gentoo-dev 2017-07-14 17:52:04 UTC
Created attachment 484452 [details]
environment
Comment 13 Toralf Förster gentoo-dev 2017-07-14 17:52:07 UTC
Created attachment 484454 [details]
etc.portage.tbz2
Comment 14 Toralf Förster gentoo-dev 2017-07-14 17:52:11 UTC
Created attachment 484456 [details]
logs.tbz2
Comment 15 Toralf Förster gentoo-dev 2017-07-14 17:52:14 UTC
Created attachment 484458 [details]
temp.tbz2
Comment 16 Andreas K. Hüttel gentoo-dev 2017-10-20 20:24:28 UTC
Ping - this is now blocking glibc-2.25 stabilization.
Comment 17 Chema Alonso Josa (RETIRED) gentoo-dev 2017-10-22 15:14:36 UTC
Sorry, but I can't reproduce this with =sys-libs/glibc-2.24-r4. I don't have access to a hardened system at this moment.
Comment 18 Toralf Förster gentoo-dev 2017-10-22 15:32:49 UTC
(In reply to Chema Alonso Josa from comment #17)
But the chroot image itself is not a hardened system
Comment 19 Toralf Förster gentoo-dev 2017-11-23 19:08:15 UTC
got at the unstable amd64 chroot image 13.0-no-multilib_libressl_20171120-180602 this : ../.../libdsk.so: undefined reference to major
Comment 20 Toralf Förster gentoo-dev 2017-11-23 19:08:18 UTC
Created attachment 506196 [details]
emerge-info.txt
Comment 21 Toralf Förster gentoo-dev 2017-11-23 19:08:21 UTC
Created attachment 506198 [details]
app-emulation:libdsk-1.5.4:20171123-104443.log
Comment 22 Toralf Förster gentoo-dev 2017-11-23 19:08:24 UTC
Created attachment 506200 [details]
emerge-history.txt
Comment 23 Toralf Förster gentoo-dev 2017-11-23 19:08:27 UTC
Created attachment 506202 [details]
environment
Comment 24 Toralf Förster gentoo-dev 2017-11-23 19:08:30 UTC
Created attachment 506204 [details]
etc.portage.tbz2
Comment 25 Toralf Förster gentoo-dev 2017-11-23 19:08:33 UTC
Created attachment 506206 [details]
logs.tbz2
Comment 26 Toralf Förster gentoo-dev 2017-11-23 19:08:36 UTC
Created attachment 506208 [details]
temp.tbz2
Comment 27 Larry the Git Cow gentoo-dev 2018-01-28 15:21:55 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=e626214cc3ff526e5ee87e2567d5fda930949726

commit e626214cc3ff526e5ee87e2567d5fda930949726
Author:     Chema Alonso Josa <nimiux@gentoo.org>
AuthorDate: 2018-01-28 15:21:20 +0000
Commit:     Chema Alonso Josa <nimiux@gentoo.org>
CommitDate: 2018-01-28 15:21:46 +0000

    app-emulation/libdsk: Adds sysmacros includes.
    
    Closes: https://bugs.gentoo.org/603326
    Package-Manager: Portage-2.3.19, Repoman-2.3.6

 .../files/libdsk-1.5.6-include-sysmacros.patch     | 22 ++++++++++++++++++++++
 app-emulation/libdsk/libdsk-1.5.6.ebuild           |  5 +++++
 2 files changed, 27 insertions(+)