Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 603138 - kde-plasma/kwin-5.8.4 : /.../logind.cpp:315:65: error: ‘major’ was not declared in this scope
Summary: kde-plasma/kwin-5.8.4 : /.../logind.cpp:315:65: error: ‘major’ was not declar...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo KDE team
URL: https://git.reviewboard.kde.org/r/127...
Whiteboard:
Keywords:
Depends on:
Blocks: glibc-sysmacros
  Show dependency tree
 
Reported: 2016-12-19 19:55 UTC by Toralf Förster
Modified: 2017-06-10 16:13 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-history.txt (emerge-history.txt,40.22 KB, text/plain)
2016-12-19 19:55 UTC, Toralf Förster
Details
environment (environment,156.56 KB, text/plain)
2016-12-19 19:55 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,10.08 KB, application/x-bzip2)
2016-12-19 19:55 UTC, Toralf Förster
Details
kde-plasma:kwin-5.8.4:20161219-194043.log (kde-plasma:kwin-5.8.4:20161219-194043.log,677.02 KB, text/plain)
2016-12-19 19:55 UTC, Toralf Förster
Details
Quick&Dirty Patch to compile kwin-5.8.4 (kwin-sysmacros.patch,246 bytes, patch)
2016-12-25 15:22 UTC, Oliver Hildebrandt
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2016-12-19 19:55:18 UTC
/var/tmp/portage/kde-plasma/kwin-5.8.4/work/kwin-5.8.4/logind.cpp: In member function ‘int KWin::LogindIntegration::takeDevice(const char*)’:
/var/tmp/portage/kde-plasma/kwin-5.8.4/work/kwin-5.8.4/logind.cpp:315:65: error: ‘major’ was not declared in this scope
     message.setArguments(QVariantList({QVariant(major(st.st_rdev)), QVariant(mi
                                                                 ^


$ cat emerge-info.txt
  -----------------------------------------------------------------

  This is an unstable amd64 chroot image (named plasma-systemd-unstable_20161218-165256) at a hardened host acting as a tinderbox.

  -----------------------------------------------------------------
  USE flags in make.conf:
USE="  pax_kernel xtpax -cdinstall -oci8 -bindist ssp aqua contrib -extraengine fax ffmpeg fontconfig gzip haptic ldap llvm mbox midi minizip mp4 mpeg2 mta nscd opencv png python qml scrypt swscale v4l xkb"
  -----------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-5.4.0 *
llvm-config --version:
3.9.0
Available Java Virtual Machines:
  [1]   icedtea-bin-8  system-vm
Available Python interpreters, in order of preference:
  [1]   python3.4
  [2]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby21 (with Rubygems) *
java-config:
The following VMs are available for generation-2:
*)	IcedTea JDK 3.2.0 [icedtea-bin-8]
  -----------------------------------------------------------------

Portage 2.3.3 (python 3.4.5-final-0, default/linux/amd64/13.0/desktop/plasma/systemd, gcc-5.4.0, glibc-2.24, 4.8.15-hardened x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.8.15-hardened-x86_64-Intel-R-_Core-TM-_i7-3930K_CPU_@_3.20GHz-with-gentoo-2.3
KiB Mem:    65285560 total,   1247528 free
KiB Swap:   67108860 total,  67101500 free
Timestamp of repository gentoo: Mon, 19 Dec 2016 17:22:20 +0000
sh bash 4.4_p5-r1
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.4_p5-r1::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.1_rc4::gentoo
dev-lang/python:          2.7.12::gentoo, 3.4.5::gentoo
dev-util/cmake:           3.7.1::gentoo
dev-util/pkgconfig:       0.29.1::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/openrc:          0.22.4::gentoo
sys-apps/sandbox:         2.10-r2::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r2::gentoo
sys-devel/automake:       1.13.4-r1::gentoo, 1.14.1-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo, 2.27::gentoo
sys-devel/gcc:            5.4.0::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r2::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.8::gentoo (virtual/os-headers)
sys-libs/glibc:           2.24::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: 1

tinderbox
    location: /tmp/tb/data/portage
    masters: gentoo
    priority: 2

local
    location: /usr/local/portage
    masters: gentoo
    priority: 99

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=native -Wall"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=native"
DISTDIR="/var/tmp/distfiles"
EMERGE_DEFAULT_OPTS="--verbose --verbose-conflicts --color=n --nospinner --tree --quiet-build"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync network-sandbox parallel-fetch preserve-libs protect-owned sandbox sfperms strict test-fail-continue unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.uni-erlangen.de/pub/mirrors/gentoo rsync://mirror.netcologne.de/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gor.bytemark.co.uk/gentoo/ rsync://ftp.snt.utwente.nl/gentoo"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cli contrib cracklib crypt cups cxx dbus declarative dri dts dvd dvdr emboss encode exif fam fax ffmpeg firefox flac fontconfig fortran gdbm gif glamor gpm gtk gzip haptic iconv ipv6 jpeg kde kipi lcms ldap libnotify llvm mad mbox midi minizip mmx mmxext mng modules mp3 mp4 mpeg mpeg2 mta multilib ncurses nls nptl nscd ogg opencv opengl openmp pam pango pax_kernel pcre pdf phonon plasma png policykit ppds python qml qt3support qt4 qt5 readline scrypt sdl seccomp semantic-desktop session spell sse sse2 ssl ssp startup-notification svg swscale systemd tcpd tiff truetype udev udisks unicode upower usb v4l vorbis widgets wxwidgets x264 xattr xcb xcomposite xinerama xkb xml xscreensaver xtpax xv xvid zlib" ABI_X86="64" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" L10N="ach bn-IN cy el eo ml ne sa sid" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby21" USERLAND="GNU" VIDEO_CARDS="intel i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Toralf Förster gentoo-dev 2016-12-19 19:55:24 UTC
Created attachment 456776 [details]
emerge-history.txt
Comment 2 Toralf Förster gentoo-dev 2016-12-19 19:55:27 UTC
Created attachment 456778 [details]
environment
Comment 3 Toralf Förster gentoo-dev 2016-12-19 19:55:31 UTC
Created attachment 456780 [details]
etc.portage.tbz2
Comment 4 Toralf Förster gentoo-dev 2016-12-19 19:55:34 UTC
Created attachment 456782 [details]
kde-plasma:kwin-5.8.4:20161219-194043.log
Comment 5 Oliver Hildebrandt 2016-12-24 09:33:18 UTC
Same PRoblem here, since emerge world update even kwin-5.8.3 (Which i have installed) won't build with the same error. Think the Problem is in one of the Updated Packages.
Comment 6 Oliver Hildebrandt 2016-12-24 09:41:53 UTC
(In reply to Oliver Hildebrandt from comment #5)
> Same PRoblem here, since emerge world update even kwin-5.8.3 (Which i have
> installed) won't build with the same error. Think the Problem is in one of
> the Updated Packages.

Even if i downgrade the qt5 libs to 5.6.X Versions this error occur, so it looks like it's not qt related.
Comment 7 Johannes Huber gentoo-dev 2016-12-24 09:43:22 UTC
It is glibc related, see blocked bug.
Comment 8 Oliver Hildebrandt 2016-12-25 15:22:02 UTC
Created attachment 457376 [details, diff]
Quick&Dirty Patch to compile kwin-5.8.4

I have added the "#include <sys/sysmacros.h>" statement to logind.cpp. It compiled successful, when i finish my emerge world in the next few hours i will post a comment if kwin is running without Problems (In first sight).
Comment 9 Oliver Hildebrandt 2016-12-27 10:12:11 UTC
(In reply to Oliver Hildebrandt from comment #8)
> Created attachment 457376 [details, diff] [details, diff]
> Quick&Dirty Patch to compile kwin-5.8.4
> 
> I have added the "#include <sys/sysmacros.h>" statement to logind.cpp. It
> compiled successful, when i finish my emerge world in the next few hours i
> will post a comment if kwin is running without Problems (In first sight).

Patch works, kwin is running.
Comment 10 Michael Palimaka (kensington) gentoo-dev 2017-01-18 10:34:05 UTC
Andreas previously landed a patch like this upstream, but it was since backed out because it broke build on FreeBSD.
Comment 11 Lars Wendler (Polynomial-C) gentoo-dev 2017-06-08 21:43:22 UTC
Can we please add this portage? It's quite annoying to put each and every new kwin ebuild into a separate overlay just to get kwin compiled.
Comment 12 Michael Palimaka (kensington) gentoo-dev 2017-06-10 14:59:50 UTC
(In reply to Lars Wendler (Polynomial-C) from comment #11)
> Can we please add this portage? It's quite annoying to put each and every
> new kwin ebuild into a separate overlay just to get kwin compiled.

Also note that all KDE ebuilds support epatch_user.
Comment 13 Andreas Sturmlechner gentoo-dev 2017-06-10 16:13:14 UTC
Gave upstream another push and added proposed fix to Portage, git commit 35c1419142a37a2be44c1a66d91f57b9b84382b8