Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 602964 - Improve output when visibility prevents subslot-triggered rebuilds
Summary: Improve output when visibility prevents subslot-triggered rebuilds
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords: InVCS
: 607244 (view as bug list)
Depends on:
Blocks: 155723 611328
  Show dependency tree
 
Reported: 2016-12-17 21:37 UTC by Andreas K. Hüttel
Modified: 2017-05-20 18:09 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas K. Hüttel gentoo-dev 2016-12-17 21:37:04 UTC
I've recently had lots of trouble getting my system to update cleanly. With --ignore-built-slot-operator-deps=yes everything worked fine, without both boost and parts of Qt got tangled into a mess of conflicting up- and downgrade suggestions. 

After a lot of try-and-error I found the reason. I had a package installed where
* the installed version had been removed from the tree
* all other (newer) versions were locally package.masked
* and a rebuild was due

It would be nice if such a situation were expressed more clearly in the output. 

Now I only found it because this was one of the packages trying to trigger a Qt downgrade, and I checked them all in turn...

[Interestingly in both cases with and without --ignore-built-slot-operator-deps=yes autounmask did not suggest anything about the package. Only when I tried to rebuild it manually by listing it on the command line...]
Comment 1 Zac Medico gentoo-dev 2016-12-18 10:35:19 UTC
It shouldn't be too difficult to identify and highlight these packages in the slot conflict output. That will be a vast improvement over the current situation.
Comment 4 Zac Medico gentoo-dev 2017-01-04 22:21:22 UTC
We could extend this to include information about other issues found in the depgraph _slot_operator_trigger_reinstalls and _slot_operator_update_probe methods. For example:

* _slot_operator_trigger_reinstalls will not call _slot_operator_update_probe if the package depth is greater than the current --deep setting

* _slot_operator_update_probe will not trigger a rebuild if it can't find an available package that satisfies the check_reverse_dependencies function
Comment 5 Zac Medico gentoo-dev 2017-02-13 17:28:40 UTC
*** Bug 607244 has been marked as a duplicate of this bug. ***
Comment 6 Zac Medico gentoo-dev 2017-05-20 18:09:03 UTC
Fixed in portage-2.3.5.