Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 602854 - sys-apps/portage: "update has been skipped" message is confusing
Summary: sys-apps/portage: "update has been skipped" message is confusing
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords: InVCS
Depends on:
Blocks: 611328
  Show dependency tree
 
Reported: 2016-12-16 18:27 UTC by Sergey S. Starikoff
Modified: 2017-05-20 18:08 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sergey S. Starikoff 2016-12-16 18:27:04 UTC
Today, trying to install app-text/sigil on my amd64 system I was woundered, when portage suggested me to continue installing dependencies, when target package was skipped due to unsatisfied deps:

# emerge app-text/sigil

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] sys-libs/libunwind-1.1-r1:7::gentoo  USE="-debug -debug-frame -libatomic -lzma -static-libs" 1073 KiB
[ebuild  N     ] dev-util/google-perftools-2.0-r2:0/4::gentoo  USE="debug -largepages -minimal -static-libs {-test}" 1232 KiB
[ebuild  N     ] dev-libs/xerces-c-3.1.4-r1::gentoo  USE="iconv icu -curl -doc -examples -static-libs {-test} -threads" CPU_FLAGS_X86="sse2" 6829 KiB
[ebuild  N     ] app-arch/snappy-1.1.3-r1::gentoo  USE="-static-libs" ABI_X86="(64) -32 (-x32)" 1474 KiB
[ebuild  N     ] dev-libs/leveldb-1.18-r1::gentoo  USE="snappy tcmalloc -static-libs" 205 KiB
[ebuild  N     ] dev-qt/linguist-tools-5.6.2:5/5.6::gentoo  USE="-debug -qml {-test}" 0 KiB
[ebuild  NS    ] dev-qt/qtxmlpatterns-5.6.2:5/5.6::gentoo [4.8.6-r1:4::gentoo] USE="-debug {-test}" 1293 KiB
[ebuild  NS    ] dev-qt/qtsql-5.6.2:5/5.6::gentoo [4.8.6-r1:4::gentoo] USE="sqlite -debug -freetds -mysql -oci8 -odbc -postgres {-test}" 0 KiB
[ebuild  NS    ] dev-qt/qtwebkit-5.6.2:5/5.6::gentoo [4.8.6-r1:4::gentoo] USE="jit -debug -geolocation -gstreamer -gstreamer010 -multimedia -opengl -orientation -printsupport -qml {-test} -webchannel -webp" 34479 KiB
[ebuild  N    ~] app-text/sigil-0.8.7-r1::gentoo  18940 KiB

Total: 10 packages (7 new, 3 in new slots), Size of downloads: 65523 KiB

!!! The following update has been skipped due to unsatisfied dependencies:

app-text/sigil:0

!!! All ebuilds that could satisfy "dev-python/regex[python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),python_single_target_python3_4(+)?,python_single_target_python3_5(+)?]" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-python/regex-2016.01.10::gentoo (masked by: ~amd64 keyword)
- dev-python/regex-2015.07.19::gentoo (masked by: ~amd64 keyword)
- dev-python/regex-2015.07.12::gentoo (masked by: ~amd64 keyword)

(dependency required by "app-text/sigil-0.9.6::gentoo" [ebuild])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

Would you like to merge these packages? [Yes/No] 

$ einfo 
Portage 2.3.0 (python 3.4.5-final-0, default/linux/amd64/13.0, gcc-4.9.3, glibc-2.22-r4, 4.4.26-gentoo x86_64)
=================================================================
System uname: Linux-4.4.26-gentoo-x86_64-Intel-R-_Core-TM-_i5_CPU_661_@_3.33GHz-with-gentoo-2.2
KiB Mem:     7976180 total,   3407280 free
KiB Swap:    4024240 total,   4024240 free
Timestamp of repository gentoo: Fri, 16 Dec 2016 15:45:01 +0000
sh bash 4.3_p48-r1
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.3_p48-r1::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.22.2::gentoo
dev-lang/python:          2.7.12::gentoo, 3.4.5::gentoo
dev-util/cmake:           3.5.2-r1::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.22.4::gentoo
sys-apps/sandbox:         2.10-r1::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.11.6-r1::gentoo, 1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.9.3::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6-r2::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.3::gentoo (virtual/os-headers)
sys-libs/glibc:           2.22-r4::gentoo
Repositories:

gentoo
    location: /usr/portage/gentoo
    sync-type: rsync
    sync-uri: rsync://mirror.yandex.ru/gentoo-portage/
    priority: -1000

local
    location: /usr/portage/local
    masters: gentoo

rion
    location: /usr/portage/layman/rion
    masters: gentoo
    priority: 0

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA GPL*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /etc/conf.d/clock /etc/rc.conf /usr/lib64/libreoffice/program/sofficerc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.6/ext-active/ /etc/php/cgi-php5.6/ext-active/ /etc/php/cli-php5.6/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles/"
EMERGE_DEFAULT_OPTS="--ask=y --verbose --autounmask=n"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs buildsyspkg config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://xeon.gentoo.ru/mirrors/gentoo/distfiles/ 		ftp://mirror2.corbina.ru/gentoo-distfiles/ 	http://mirror2.corbina.ru/gentoo-distfiles/ 		http://mirror.yandex.ru/gentoo-distfiles/ 		ftp://mirror.yandex.ru/gentoo-distfiles/ 		http://gentoo.bloodhost.ru/ 		ftp://gentoo.bloodhost.ru/ 	distfiles.gentoo.org"
LANG="ru_RU.UTF8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages/"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 acl alsa amd64 berkdb bzip2 cairo cdr cli consolekit cracklib crypt cups cxx dbus djvu dri dv dvd ffmpeg flac fortran gdbm gif gtk iconv icu jpeg jpeg2k kpathsea mac mmx mmxext modules mp3 mpeg multilib ncurses nls nptl ogg openmp pam pcre pdf png policykit qt3support readline seccomp session sse sse2 ssl tcpd tiff truetype unicode utf8 v4l v4l2 vorbis x264 xattr zlib" ABI_X86="64" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev" KERNEL="linux" L10N="ru" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="ru" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" QEMU_SOFTMMU_TARGETS="i386" QEMU_USER_TARGETS="i386" RUBY_TARGETS="ruby21" SANE_BACKENDS="genesys" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Brian Dolbec gentoo-dev 2016-12-22 16:09:11 UTC
Can you please install portage-2.3.3 and try this same package emerge?

There have been a number of bugfixes, of which this might have been one of them.
Comment 2 Zac Medico gentoo-dev 2016-12-22 16:45:16 UTC
In this case emerge is behaving as designed. Since you have --autounmask=n in EMERGE_DEFAULT_OPTS, it couldn't choose the masked dev-python/regex package, so it chose an older version of app-text/sigil which does not required dev-python/regex.
Comment 3 Sergey S. Starikoff 2016-12-23 12:06:13 UTC
(In reply to Zac Medico from comment #2)
> In this case emerge is behaving as designed. Since you have --autounmask=n
> in EMERGE_DEFAULT_OPTS, it couldn't choose the masked dev-python/regex
> package, so it chose an older version of app-text/sigil which does not
> required dev-python/regex.

???
When I ask to install _sigil_ suggestion to do anything after skipping it (user-requested (!) package _sigil_) is something strange and wrong.
Is it REALLY designed?!?
Comment 4 Zac Medico gentoo-dev 2016-12-23 21:12:01 UTC
It did _not_ skip sigil. The warning message gives the reason why it did not choose the latest version. It chose sigil-0.8.7-r1 instead of the latest version:

[ebuild  N    ~] app-text/sigil-0.8.7-r1::gentoo  18940 KiB
Comment 5 Zac Medico gentoo-dev 2016-12-24 06:49:41 UTC
(In reply to Sergey S. Starikoff from comment #3)
> Is it REALLY designed?!?

Yes. If you disagree with my explanation, then please explain you you think emerge should behave differently in this case.
Comment 6 Sergey S. Starikoff 2016-12-26 06:27:51 UTC
(In reply to Zac Medico from comment #4)
> It did _not_ skip sigil. The warning message gives the reason why it did not
> choose the latest version. It chose sigil-0.8.7-r1 instead of the latest
> version:
> 
> [ebuild  N    ~] app-text/sigil-0.8.7-r1::gentoo  18940 KiB

Ops.
Excuse me.

Skipping package's version in error message confused me:

> !!! The following update has been skipped due to unsatisfied dependencies:
>
> app-text/sigil:0

app-text/sigil has the only slot.
So both versions (skipped =app-text/sigil-0.9.6 and suggested for installation =app-text/sigil-0.8.7-r1) matches app-text/sigil:0. This is the collision, that confused me.
Comment 7 Zac Medico gentoo-dev 2016-12-27 00:47:46 UTC
Yeah, these messages can be confusing a first glance. They're not so bad after you've grown accustomed to them. Maybe something like this would help to clarify:

!!! The following update has been skipped due to unsatisfied dependencies:

app-text/sigil:0

    selected: app-text/sigil-0.8.7-r1::gentoo
    skipped: app-text/sigil-0.9.6::gentoo (see unsatisfied dependency below)
Comment 8 Brian Dolbec gentoo-dev 2016-12-27 03:06:50 UTC
Yeah, that looks good Zac.
It's a lot better than the existing message.
Comment 10 Sergey S. Starikoff 2016-12-29 08:32:16 UTC
(In reply to Zac Medico from comment #7)
> Yeah, these messages can be confusing a first glance. They're not so bad
> after you've grown accustomed to them. Maybe something like this would help
> to clarify:
> 
> !!! The following update has been skipped due to unsatisfied dependencies:
> 
> app-text/sigil:0
> 
>     selected: app-text/sigil-0.8.7-r1::gentoo
>     skipped: app-text/sigil-0.9.6::gentoo (see unsatisfied dependency below)

Yes.
Reqular experience provedies skills of interpreting this message.

When skipping single atom suggested message looks well.

But when skipping several atoms it still can confuse.
May be it will enough to add some kind of counter add echo additional warning (something like: «latest skipped»), when skipping more than one atom?
Comment 11 Zac Medico gentoo-dev 2016-12-29 09:20:31 UTC
(In reply to Sergey S. Starikoff from comment #10)
> When skipping single atom suggested message looks well.
> 
> But when skipping several atoms it still can confuse.
> May be it will enough to add some kind of counter add echo additional
> warning (something like: «latest skipped»), when skipping more than one atom?

It shows a separate message for each skipped update, so there shouldn't be anything confusing about it, just more similar messages to read.

This is in the master branch:

https://gitweb.gentoo.org/proj/portage.git/commit/?id=7dc23bc66b410b5a2f9640dc93ca65f5b2678670
Comment 12 Zac Medico gentoo-dev 2017-05-20 18:08:05 UTC
Fixed in portage-2.3.5.