Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 60193 - dev-ml/lablgtk-2 doesn't compile (cannot handle TLS data)
Summary: dev-ml/lablgtk-2 doesn't compile (cannot handle TLS data)
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Team for the ML programming language family
: 60661 (view as bug list)
Depends on:
Blocks: 91611
  Show dependency tree
Reported: 2004-08-12 17:59 UTC by Ian Truelsen
Modified: 2008-01-27 15:20 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Ian Truelsen 2004-08-12 17:59:08 UTC
ocamlmklib -verbose -o lablglade ml_glade.o -L/usr/lib -lglade-gnome -lglade -L/usr/lib -lxml -lz -rdynamic -L/usr/lib -L/usr/X11R6/lib -rdynamic -lgnomeui -lart_lgpl -lgdk_imlib -lSM -lICE -lgtk -lgdk -lgmodule -ldl -lXi -lXext -lX11 -lgnome -lgnomesupport -lesd -lasound -laudiofile -lm -ldb1 -lglib
Unknown option -rdynamic
Unknown option -rdynamic
+ gcc -shared -o ./ ml_glade.o -L/usr/lib -L/usr/lib -L/usr/lib -L/usr/X11R6/lib  -Wl,-rpath,/usr/lib:/usr/X11R6/lib -lglade-gnome -lglade -lxml -lz -lgnomeui -lart_lgpl -lgdk_imlib -lSM -lICE -lgtk -lgdk -lgmodule -ldl -lXi -lXext -lX11 -lgnome -lgnomesupport -lesd -lasound -laudiofile -lm -ldb1 -lglib
+ ar rc ./liblablglade.a ml_glade.o
+ ranlib ./liblablglade.a
ocamlc.opt -I /usr/lib/ocaml/lablGL -w s -c glade.mli
ocamlc.opt -I /usr/lib/ocaml/lablGL -w s -c
ocamlmklib -verbose -o lablglade glade.cmo -L/usr/lib -lglade-gnome -lglade -L/usr/lib -lxml -lz -rdynamic -L/usr/lib -L/usr/X11R6/lib -rdynamic -lgnomeui -lart_lgpl -lgdk_imlib -lSM -lICE -lgtk -lgdk -lgmodule -ldl -lXi -lXext -lX11 -lgnome -lgnomesupport -lesd -lasound -laudiofile -lm -ldb1 -lglib
Unknown option -rdynamic
Unknown option -rdynamic
+ /usr/bin/ocamlc -a  -o lablglade.cma  glade.cmo -dllib -llablglade -cclib -llablglade -ccopt -L/usr/lib -ccopt -L/usr/lib -ccopt -L/usr/lib -ccopt -L/usr/X11R6/lib -ccopt -Wl,-rpath,/usr/lib:/usr/X11R6/lib -cclib -lglade-gnome -cclib -lglade -cclib -lxml -cclib -lz -cclib -lgnomeui -cclib -lart_lgpl -cclib -lgdk_imlib -cclib -lSM -cclib -lICE -cclib -lgtk -cclib -lgdk -cclib -lgmodule -cclib -ldl -cclib -lXi -cclib -lXext -cclib -lX11 -cclib -lgnome -cclib -lgnomesupport -cclib -lesd -cclib -lasound -cclib -laudiofile -cclib -lm -cclib -ldb1 -cclib -lglib 
ocamlc.opt -I /usr/lib/ocaml/lablGL -w s -c
ocamlmktop -I /usr/lib/ocaml/lablGL -o lablgtktop unix.cma str.cma lablgl.cma -I . lablgtk.cma lablgtkgl.cma lablgnome.cma lablglade.cma gtkInit.cmo
Error on dynamically loaded library: cannot handle TLS data
make[1]: *** [lablgtktop] Error 2
make[1]: Leaving directory `/var/tmp/portage/lablgtk-1.2.6/work/lablgtk-1.2.6/src'
make: *** [all] Error 2

!!! ERROR: dev-ml/lablgtk-1.2.6 failed.
!!! Function src_compile, Line 36, Exitcode 2
!!! (no error message)

Reproducible: Always
Steps to Reproduce:
1. emerge dev-ml/lablgtk

Portage 2.0.50-r9 (default-x86-2004.0, gcc-3.3.4, glibc-,
System uname: 2.6.7-gentoo-r13 i686 AMD Athlon(tm) XP 1700+
Gentoo Base System version 1.5.2
distcc 2.16 i486-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.3 [enabled]
Autoconf: sys-devel/autoconf-2.59-r4
Automake: sys-devel/automake-1.8.5-r1
CFLAGS="-mcpu=athlon-xp -O3 -pipe -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3.2/share/config /usr/kde/3.3/share/config /usr/kde/3/share/config
/usr/share/config /usr/share/texmf/dvipdfm/config/
/usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/
/usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-mcpu=athlon-xp -O3 -pipe -fomit-frame-pointer"
FEATURES="autoaddcvs ccache sandbox"
USE="3dnow X aalib acpi aim alsa apm arts avi berkdb cdr crypt cups dillo
directfb dvd encode esd fbcon flash foomaticdb gdbm gif gnome gpm gtk gtk2 icq
imap imlib jabber java jpeg kde ldap libg++ libwww mad maildir mikmod motif
moznocompose moznoirc moznomail mpeg msn mysql ncurses nls oggvorbis opengl
oscar oss pam pdflib perl png python qt quicktime readline sdl slang slp spell
ssl svga tcltk tcpd tetex tiff truetype usb video_cards_nvidia x86 xface xml2
xmms xv yahoo zlib"
Comment 1 Matthieu Sozeau (RETIRED) gentoo-dev 2004-08-13 15:14:52 UTC
Seems interesting :) Where do come from ? (qpkg -f /usr/lib/ probably)
Comment 2 Ian Truelsen 2004-08-13 17:25:41 UTC
ian@minion ~ $ qpkg -f /usr/lib/
ian@minion ~ $ locate libnvidia-tls
ian@minion ~ $ qpkg -f /usr/lib/tls/
ian@minion ~ $ qpkg -f /usr/lib/tls/  
ian@minion ~ $ qpkg -f /usr/lib/opengl/nvidia/lib/
media-video/nvidia-glx *
Comment 3 Matthieu Sozeau (RETIRED) gentoo-dev 2004-08-17 11:19:31 UTC
*** Bug 60661 has been marked as a duplicate of this bug. ***
Comment 4 Matthieu Sozeau (RETIRED) gentoo-dev 2004-08-17 11:25:33 UTC
I have the same libs on my athlon box, but no lablgtk error. I suppose if you `USE=-opengl emerge lablgtk` it works ? Tell me, i'll ask the upstream developpers for a solution.
Comment 5 Ian Truelsen 2004-08-17 18:44:15 UTC
Yes, USE="-opengl" gets past the problem.
Comment 6 Matthieu Sozeau (RETIRED) gentoo-dev 2004-08-18 04:33:00 UTC
I was thinking it may be due to a bug in old nvidia drivers, have you tried with the latest version of nvidia-glx ?
Comment 7 Christian Fernandez 2004-08-18 05:31:35 UTC
ok I try USE=-opengl emerge lablgtk  the problem...
the version is a newer one check the one I download:

root@rek2 ~ # USE=-opengl emerge  lablgtk
Calculating dependencies ...done!
>>> emerge (1 of 1) dev-ml/lablgtk-2.4.0 to /
>>> md5 src_uri ;-) lablgtk-2.4.0.tar.gz

and now when I do a emerge --update  world it shows another version(the one giving the problem)

root@rek2 ~ # emerge --update -p world

These are the packages that I would merge, in order:

Calculating world dependencies ...done!
[ebuild     U ] dev-ml/lablgtk-1.2.7 [1.2.6]
[ebuild     U ] net-misc/unison-2.9.1-r1 [2.9.1]
[ebuild     U ] x11-libs/qt-3.3.3 [3.3.2]
[ebuild     U ] media-sound/esound-0.2.35 [0.2.34]

so how come if I do and --upgrade it needs one version and if I just download it individually gets the newer one? and BTW I am still having the problem 
Comment 8 Matthieu Sozeau (RETIRED) gentoo-dev 2004-08-18 06:11:23 UTC
Unison wants a lablgtk-1.2.* (GTK1) version, not a lablgtk-2.* (GTK2) version hence the portage behavior. You can do "USE=-opengl emerge =dev-ml/lablgtk-1.2.7" to get the one you want. I have two questions:
- does lablgtk-2.4.0 with opengl set works
- what's the compile trace of lablgtk-1.2.7 with USE=-opengl when it fails.
Comment 9 Ian Truelsen 2004-08-18 06:48:06 UTC
I am using the 6111 version which is the latest version available.
Comment 10 Christian Fernandez 2004-08-18 07:21:04 UTC
ok now it works  I did the install so unison can also install and when ahead...
I am still wondering why opengl is giving problems... it shoulnt

Comment 11 Matthieu Sozeau (RETIRED) gentoo-dev 2004-08-18 13:30:50 UTC
It's some nasty bug related to nptl i think... i'm still trying to contact upstream but their mailing list is slow.
Comment 12 Ian Truelsen 2004-08-18 14:56:25 UTC
I am not using nptl on my system.
Comment 13 Sascha Silbe 2004-11-15 09:09:49 UTC
Exactly the same problem here:  === Begin === ocamlc.opt -I /usr/lib/ocaml/lablGL -w s -c ocamlmktop -I /usr/lib/ocaml/lablGL -o lablgtktop unix.cma str.cma lablgl.cma -I . lablgtk.cma lablgtkgl.cma gtkInit.cmo Error on dynamically loaded library: cannot handle TLS data make[1]: *** [lablgtktop] Error 2 rm make[1]: Leaving directory `/tmp/portage/portage/lablgtk-1.2.5/work/lablgtk-1.2.5/src' make: *** [all] Error 2  !!! ERROR: dev-ml/lablgtk-1.2.5 failed. !!! Function src_compile, Line 35, Exitcode 2 !!! (no error message) !!! If you need support, post the topmost build error, NOT this status message.  root@cube:~# equery list nvidia [ Searching for package 'nvidia' in all categories among: ]  * installed packages [I--] [  ] media-video/nvidia-kernel-1.0.6111-r3 (2.6.7-cube-3) [I--] [  ] media-video/nvidia-glx-1.0.6111 (0) root@cube:~# emerge info Portage 2.0.51-r3 (default-linux/x86/2004.0, gcc-3.3.4, glibc-, 2.6.7-cube-3 i686) ================================================================= System uname: 2.6.7-cube-3 i686 AMD Athlon(tm) XP 1700+ Gentoo Base System version 1.4.16 distcc 2.16 i586-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled] ccache version 2.3 [enabled] Autoconf: sys-devel/autoconf-2.59-r5 Automake: sys-devel/automake-1.8.5-r1 Binutils: sys-devel/binutils- Headers:  sys-kernel/linux-headers-2.4.21-r1 Libtools: sys-devel/libtool-1.5.2-r5 ACCEPT_KEYWORDS="x86" AUTOCLEAN="yes" CFLAGS="-march=pentium -mcpu=athlon-tbird -O3 -pipe" CHOST="i586-pc-linux-gnu" COMPILER="" CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /usr/vice/etc /var/qmail/alias /var/qmail/control" CONFIG_PROTECT_MASK="/etc/afs/C /etc/afs/afsws /etc/afs/modload /etc/gconf /etc/make.globals /etc/terminfo /etc/env.d" CXXFLAGS="-march=pentium -mcpu=athlon-tbird -O3 -pipe" DISTDIR="/usr/portage/distfiles" FEATURES="autoaddcvs ccache distlocks maketest sandbox sfperms strict userpriv usersandbox" GENTOO_MIRRORS="" MAKEOPTS="-j2" PKGDIR="/usr/portage/packages" PORTAGE_TMPDIR="/var/tmp/portage" PORTDIR="/usr/portage" PORTDIR_OVERLAY="/usr/local/portage" SYNC="rsync://" USE="3dnow X acl afs apm avi berkdb bitmap-fonts cdr crypt doc dvd dvdr encode f77 fam flac foomaticdb gdbm gif gimpprint gtk gtk2 gtkhtml guile hbci imagemagick imap imlib ipv6 j-noaim j-nomsn j-noyahoo jabber jpeg krb4 lcms libg++ libwww lvm1 mad maildir mbox mikmod mmx monitor mpeg mysql nas ncurses nls oggvorbis opengl oss pam pdflib plotutils png postgres python qt qtmt quicktime readline samba sdl skey spell sqlite sse ssl tetex tiff truetype unicode x86 xml xml2 xv xvid zlib linguas_en,de"   === End ===  
Comment 14 Jochen Trumpf 2005-01-17 18:34:49 UTC
works for me with 
[I--] [  ] media-video/nvidia-glx-1.0.6629-r1 (0)
[I--] [  ] media-video/nvidia-kernel-1.0.6629-r1 (0)
[I--] [  ] dev-ml/lablgtk-1.2.5 (1)
now (used to have the problem with older nvidia versions).
To try don't forget to remove -opengl from package.use and maybe you have to re-emerge lablgl first (see bug #59933).
Comment 15 Matthieu Sozeau (RETIRED) gentoo-dev 2005-02-06 06:09:42 UTC
Ian, Sacha and Christian, do you still have problems with the latest versions of nvidia drivers ?
Comment 16 Sascha Silbe 2005-02-06 06:23:32 UTC
Works fine now (except for some warnings about installing files with group portage). Thanks! 
Comment 17 Arudil 2005-05-13 12:53:44 UTC
nvidia-kernel 1.0.7174
nvidia-glx 1.0.7174-r4
non-ntpl system
lablgl re-emerged after emerging nvidia

USE="opengl" emerge =lablgtk-1.2.5 ; USE="opengl" emerge =lablgtk-2.4.0
-> both does not compile:


ocamlc.opt -I /usr/lib/ocaml/lablGL -w s -c
ocamlmktop -I /usr/lib/ocaml/lablGL -o lablgtktop unix.cma str.cma lablgl.cma -I . lablgtk.cma lablgtkgl.cma gtkInit.cmo
Error on dynamically loaded library: cannot handle TLS data


ocamlmktop -I +lablGL -thread  -o lablgtktop unix.cma threads.cma lablgl.cma \
   -I . lablgtk.cma lablgtkgl.cma lablglade.cma lablgnomecanvas.cma lablgnomeui.cma lablpanel.cma lablrsvg.cma gtkThread.cmo gtkInit.cmo
Error on dynamically loaded library: cannot handle TLS data
Comment 18 Sascha Silbe 2005-08-06 05:27:52 UTC
Happens on my laptop (with ATI graphics card) now:

checking for GTK_LIBS... -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lm -lpangoxft-1.0 -lpangox-1.0 -lpango-1.0 -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0  
checking lablGL directory... configure: error: gtkgl enforced but lablGL not found

!!! Please attach the config.log to your bug report:
!!! /var/tmp/portage/lablgtk-2.4.0/work/lablgtk-2.4.0/config.log

!!! ERROR: dev-ml/lablgtk-2.4.0 failed.
!!! Function econf, Line 485, Exitcode 0
!!! econf failed
!!! If you need support, post the topmost build error, NOT this status message.

Comment 19 Matthieu Sozeau (RETIRED) gentoo-dev 2005-09-21 10:06:58 UTC
Sacha: it's a problem with your pkgconfig/gtkglarea installation, try with the  
latest versions (you should get a /usr/lib/pkgconfig/gtkgl-2.0.pc file).  
Comment 20 Sascha Silbe 2005-09-21 10:57:31 UTC
Cannot try it currently since the HD in my laptop has died. Might take several weeks until I get a replacement.
Comment 21 spiralvoice 2006-08-09 03:12:20 UTC
Does this bug still happen with current Gentoo?
Comment 22 Jakub Moc (RETIRED) gentoo-dev 2006-12-03 03:53:49 UTC
<dev-ml/lablgtk-2 package.masked for gnome-1 removal -> WONTFIX
Comment 23 Alexandre Buisse (RETIRED) gentoo-dev 2006-12-03 08:00:27 UTC
Comment #17 says it also happens with 2.4.0.
Comment 24 Wendall Cada 2007-01-08 01:18:10 UTC
USE='-opengl' emerge lablgtk
This is the only thing that works for me. Otherwise, I get the following error:
+ /usr/bin/ocamlopt -a -o lablgtk.cmxa  gaux.cmx gpointer.cmx glib.cmx gobject.c
mx gdkEnums.cmx pangoEnums.cmx gtkEnums.cmx pango.cmx gdk.cmx gdkEvent.cmx gdkKe
ysyms.cmx gdkPixbuf.cmx gtk.cmx gtkSignal.cmx gtkStock.cmx gtkObject.cmx gtkBase
Props.cmx gtkBinProps.cmx gtkButtonProps.cmx gtkEditProps.cmx gtkListProps.cmx g
tkMenuProps.cmx gtkMiscProps.cmx gtkPackProps.cmx gtkRangeProps.cmx gtkTextProps
.cmx gtkTreeProps.cmx gtkFileProps.cmx gtkActionProps.cmx gtkBrokenProps.cmx gtk
Data.cmx gtkBase.cmx gtkPack.cmx gtkButton.cmx gtkMenu.cmx gtkMisc.cmx gtkWindow
.cmx gtkList.cmx gtkBin.cmx gtkEdit.cmx gtkRange.cmx gtkText.cmx gtkTree.cmx gtk
File.cmx gtkMain.cmx gtkBroken.cmx gPango.cmx gDraw.cmx gObj.cmx gData.cmx gMain
.cmx ogtkBaseProps.cmx ogtkBinProps.cmx ogtkButtonProps.cmx ogtkEditProps.cmx og
tkListProps.cmx ogtkMenuProps.cmx ogtkMiscProps.cmx ogtkPackProps.cmx ogtkRangeP
rops.cmx ogtkTextProps.cmx ogtkTreeProps.cmx ogtkFileProps.cmx ogtkActionProps.c
mx ogtkBrokenProps.cmx gContainer.cmx gPack.cmx gButton.cmx gText.cmx gMenu.cmx 
gMisc.cmx gTree.cmx gList.cmx gFile.cmx gWindow.cmx gBin.cmx gEdit.cmx
x gAction.cmx gBroken.cmx gUtil.cmx gToolbox.cmx -cclib -llablgtk2   -cclib -lgt
k-x11-2.0 -cclib -lgdk-x11-2.0 -cclib -latk-1.0 -cclib -lgdk_pixbuf-2.0 -cclib -
lm -cclib -lpangocairo-1.0 -cclib -lpango-1.0 -cclib -lcairo -cclib -lgobject-2.
0 -cclib -lgmodule-2.0 -cclib -ldl -cclib -lglib-2.0 
ocamlopt.opt -I +lablGL -w s -c
/usr/lib/ocaml/lablGL/gl.cmx is not a compilation unit description.
make[1]: *** [glGtk.cmx] Error 2
make[1]: Leaving directory `/var/tmp/portage/lablgtk-2.6.0/work/lablgtk-2.6.0/sr
make: *** [opt] Error 2

Comment 25 Alexandre Buisse (RETIRED) gentoo-dev 2007-01-08 12:04:31 UTC
@Wendall: this has nothing to do with the TLS data thing, it's most probably because you emerged a new version of ocaml and it's not binary compatible from one version to another, so you need to reemerge everything that is built with ocaml. Check the ewarn at the end of the ocaml emerge to know how to proceed.
Comment 26 Alexis Ballier gentoo-dev 2008-01-27 15:20:59 UTC
old bug, cant reproduce it (and I'm using nvidia-drivers)

please reopen if it still happens