Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 601704 - app-office/libreoffice-bin looks ugly under Xfce
Summary: app-office/libreoffice-bin looks ugly under Xfce
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Andreas K. Hüttel
Depends on:
Reported: 2016-12-05 18:49 UTC by Gleb
Modified: 2020-12-12 07:01 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---

emerge --info (emerge-info.txt,5.66 KB, text/plain)
2016-12-08 14:25 UTC, Gleb

Note You need to log in before you can comment on or make changes to this bug.
Description Gleb 2016-12-05 18:49:34 UTC
After many attempts including waiting for the next release (5.2) it still has the same issue. I don't use Gnome and gnome useflag is not enabled for this package but it doesn't seem to be required as GTK support should work fine even without the Gnome.

Unfortunately I couldn't install it with gnome useflag to check as it requires too many rebuilds (changing eudev to udev and systemd) and new Gnome packages which will break everything.
Comment 1 Jonas Stein gentoo-dev 2016-12-08 07:57:36 UTC
A precise description of the bug is necessary, we can not provide support via bug tracker.
I suggest to collect more details with the help of the gentoo support channels [1] first.

Please provide the emerge --info, log files and a screenshot.

Comment 2 Gleb 2016-12-08 14:25:16 UTC
Created attachment 455512 [details]
emerge --info

Sorry for the delay, compiling libreoffice takes a lot of time, and here's some info after I checked source-based version. I'm not sure what log files I can provide in such case because libreoffice doesn't provide it.

1. emerge --info: see attachement.
Almost stable system, Xfce with GTK2/GTK3 (enabled in make.conf), no systemd, d-bus, eudev, polkit, consolekit and all the stuff (typical home desktop system similar to Xubuntu 14.04).

2a. app-office/libreoffice-bin: current version from portage (5.2.x, the same problem was with 5.1.x and I can't remember if it was the case with 4.x and 5.0.x -- I think that there wasn't any problems with these versions). Screenshot [1].
Enabled USE-flags for this pacakge: java

2b. app-office/libreoffice: also current version from portage (I never had previous versions installed). No problems here, GTK2/3-styles are in use, see screenshot [2].
Enabled USE-flags for that package: bluetooth branding cups dbus gtk gtk3 java

3. What I tried to solve thit issue: almost everything I found on Internet relevant to my problem, arch wiki has those advices collected in one place [3].
A little bit outdated, but the same info (environment variables especiallly) was everywhere.

I had libreoffice-bin with ugly look without GTK-style applied and even after update to 5.2.x the problem was still there, so I compiled libreoffice. The only additional dependencies was: ucpp and Archive-Zip and that version looked as expected with GTK-applied applied.

I tried two packages on the same system with the same libraries (GTK and co.) and one package doesn't have problems (libreoffice) and another (libreoffice-bin) has it.

[1] (libreoffice-bin Win95/98 style)
[2] (libreoffice GTK style)
Comment 3 Andreas K. Hüttel archtester gentoo-dev 2016-12-13 20:54:16 UTC
Well, the reason for this is that people were complaining about the "superfluous" gtk dependency...

(I'll probably revert that sometime though.)
Comment 4 Andreas K. Hüttel archtester gentoo-dev 2016-12-20 21:09:29 UTC

commit 934065cd6a01cc8b58b81097fdfa4921bf65a25c (HEAD -> master, origin/master, origin/HEAD)
Author: Andreas K. Hüttel <>
Date:   Tue Dec 20 22:08:06 2016 +0100

    Unconditionally build gtk-2 backend, build gtk-3 backend additionally for gnome

 generate | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)
Comment 5 Andreas Sturmlechner gentoo-dev 2017-12-05 19:12:54 UTC
Recent libreoffice-bin ebuilds all have gtk+:2 hard-dep.