Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 599954 - x11-drivers/xf86-input-keyboard-1.8.1 : /.../kbd.c:386:2: error: implicit declaration of function 'AddEnabledDevice' [-Werror=implicit-function-declaration]
Summary: x11-drivers/xf86-input-keyboard-1.8.1 : /.../kbd.c:386:2: error: implicit dec...
Status: RESOLVED DUPLICATE of bug 599938
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-6
  Show dependency tree
 
Reported: 2016-11-16 09:03 UTC by Toralf Förster
Modified: 2016-11-16 10:55 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
config.log (config.log,49.96 KB, text/plain)
2016-11-16 09:03 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,214.27 KB, text/plain)
2016-11-16 09:03 UTC, Toralf Förster
Details
environment (environment,122.75 KB, text/plain)
2016-11-16 09:03 UTC, Toralf Förster
Details
x11-drivers:xf86-input-keyboard-1.8.1:20161116-002138.log (x11-drivers:xf86-input-keyboard-1.8.1:20161116-002138.log,13.78 KB, text/plain)
2016-11-16 09:03 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2016-11-16 09:03:38 UTC
libtool: compile:  x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I/var/tmp/portage/x11-drivers/xf86-input-keyboard-1.8.1/work/xf86-input-keyboard-1.8.1/src -I.. -fvisibility=hidden -I/usr/include/xorg -I/usr/include/pixman-1 -I/usr/include/X11/dri -I/usr/include/libdrm -Wall -Wpointer-arith -Wmissing-declarations -Wformat=2 -Wstrict-prototypes -Wmissing-prototypes -Wnested-externs -Wbad-function-cast -Wold-style-definition -Wdeclaration-after-statement -Wunused -Wuninitialized -Wshadow -Wmissing-noreturn -Wmissing-format-attribute -Wredundant-decls -Wlogical-op -Werror=implicit -Werror=nonnull -Werror=init-self -Werror=main -Werror=missing-braces -Werror=sequence-point -Werror=return-type -Werror=trigraphs -Werror=array-bounds -Werror=write-strings -Werror=address -Werror=int-to-pointer-cast -Werror=pointer-to-int-cast -fno-strict-aliasing -march=native -O2 -pipe -c /var/tmp/portage/x11-drivers/xf86-input-keyboard-1.8.1/work/xf86-input-keyboard-1.8.1/src/kbd.c  -fPIC -DPIC -o .libs/kbd.o
/var/tmp/portage/x11-drivers/xf86-input-keyboard-1.8.1/work/xf86-input-keyboard-1.8.1/src/kbd.c: In function 'KbdProc':
/var/tmp/portage/x11-drivers/xf86-input-keyboard-1.8.1/work/xf86-input-keyboard-1.8.1/src/kbd.c:386:2: error: implicit declaration of function 'AddEnabledDevice' [-Werror=implicit-function-declaration]
  AddEnabledDevice(pInfo->fd);
  ^
/var/tmp/portage/x11-drivers/xf86-input-keyboard-1.8.1/work/xf86-input-keyboard-1.8.1/src/kbd.c:386:2: warning: nested extern declaration of 'AddEnabledDevice' [-Wnested-externs]


$ cat emerge-info.txt
  -----------------------------------------------------------------

  This is an unstable amd64 chroot image (named amd64-13.0-no-multilib-unstable_20161112-113908) at a hardened host acting as a tinderbox.

  -----------------------------------------------------------------
  USE flags ...

  ... in make.conf:
USE="  pax_kernel xtpax -cdinstall -oci8 -bindist ssp avformat cgroups compat dbus extra ftp gd -gnomecanvas -gstreamer gtk lua -lzma -mad midi mikmod minimal modplug mpi ncurses odbc pyqt4 scripts smpeg sqlite system-jpeg -traceroute webstart x264 xcb -xmlreader xvmc zenmap ziffy"

  ... in /etc/portage/package.use/*:
  mail-mta/ssmtp      mta ssl
  net-misc/wget       ssl
  app-editors/xemacs  -nopie
  dev-db/sqlite           secure-delete
  dev-lang/python         sqlite
  dev-qt/qtsql            sqlite
  mail-client/thunderbird -pulseaudio system-icu
  media-libs/libvpx       postproc
  media-libs/libpng       apng
  media-sound/pulseaudio  alsa
  media-video/ffmpeg      sdl
  sys-libs/ntdb           python
  sys-libs/tdb            python
  sys-libs/tevent         python
  x11-libs/cairo          X
  x11-libs/libxcb         xkb
  www-client/firefox      -pulseaudio system-icu
  app-crypt/mit-krb5      -pkinit
  media-video/ffmpeg      -sdl
  sys-libs/zlib           minizip
  x11-base/xorg-server    glamor -minimal
  app-crypt/pinentry  -qt4
  app-editors/emacs   -dbus -gtk -gtk3 -ssl -svg
  app-text/docbook-xsl-stylesheets  -ruby
  app-text/xmlto      -latex
  dev-libs/boehm-gc   threads
  dev-libs/libpcre    pcre16
  dev-lang/python     threads
  dev-qt/qtgui        egl eglfs
  dev-util/cmake      -qt4 -qt5
  dev-vcs/git         -gtk -perl
  gnome-base/librsvg  -tools
  media-libs/mesa     -vaapi -video_cards_radeonsi -video_cards_radeon
  net-nds/openldap    -sasl
  sys-apps/kmod       tools
  sys-libs/ncurses    -gpm
  x11-libs/gtk+       -cups
  sys-auth/polkit     -kde
  app-text/xmlto      -text
  net-misc/openssh    ssl
  sys-apps/busybox    -pam
  net-misc/iputils -caps -filecaps

  entries in /etc/portage/package.unmask/*:
  ~sys-apps/sandbox-2.11
  ~dev-libs/botan-1.11.32
  ~sys-devel/flex-2.6.2
  -----------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-5.4.0 *
llvm-config --version:
3.9.0

Available Python interpreters, in order of preference:
  [1]   python3.4
  [2]   python3.5 (fallback)
  [3]   python2.7 (fallback)
  [4]   pypy3 (fallback)
Available Ruby profiles:
  [1]   ruby20 (with Rubygems)
  [2]   ruby21 (with Rubygems) *
java-config:

  -----------------------------------------------------------------

Portage 2.3.2 (python 3.4.5-final-0, default/linux/amd64/13.0/no-multilib, gcc-5.4.0, glibc-2.23-r3, 4.8.7-hardened x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.8.7-hardened-x86_64-Intel-R-_Core-TM-_i7-3930K_CPU_@_3.20GHz-with-gentoo-2.3
KiB Mem:    65285560 total,   2754092 free
KiB Swap:   67108860 total,  67103368 free
Timestamp of repository gentoo: Tue, 15 Nov 2016 23:22:37 +0000
sh bash 4.4_p5
ld GNU ld (Gentoo 2.26.1 p1.0) 2.26.1
ccache version 3.3.3 [disabled]
app-shells/bash:          4.4_p5::gentoo
dev-lang/perl:            5.24.0-r2::gentoo
dev-lang/python:          2.7.12::gentoo, 3.4.5::gentoo, 3.5.2::gentoo
dev-util/ccache:          3.3.3::gentoo
dev-util/cmake:           3.7.0::gentoo
dev-util/pkgconfig:       0.29.1::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/openrc:          0.22.3-r1::gentoo
sys-apps/sandbox:         2.11-r2::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r2::gentoo
sys-devel/automake:       1.10.3-r2::gentoo, 1.11.6-r2::gentoo, 1.12.6-r1::gentoo, 1.13.4-r1::gentoo, 1.14.1-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.26.1::gentoo, 2.27::gentoo
sys-devel/gcc:            5.4.0::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r2::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.8::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r3::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: 1

tinderbox
    location: /tmp/tb/data/portage
    masters: gentoo
    priority: 2

local
    location: /usr/local/portage
    masters: gentoo
    priority: 3

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /etc/omega.conf /etc/stunnel/stunnel.conf /var/yp/Makefile"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.6/ext-active/ /etc/php/apache2-php7.0/ext-active/ /etc/php/cgi-php5.6/ext-active/ /etc/php/cgi-php7.0/ext-active/ /etc/php/cli-php5.6/ext-active/ /etc/php/cli-php7.0/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/var/tmp/distfiles"
EMERGE_DEFAULT_OPTS="--verbose --verbose-conflicts --color=n --nospinner --tree --quiet-build"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync network-sandbox parallel-fetch preserve-libs protect-owned sandbox sfperms strict test-fail-continue unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.uni-erlangen.de/pub/mirrors/gentoo rsync://mirror.netcologne.de/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gor.bytemark.co.uk/gentoo/ rsync://ftp.snt.utwente.nl/gentoo"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="acl amd64 avformat berkdb bzip2 cgroups cli compat cracklib crypt cxx dbus dri extra fortran ftp gd gdbm gtk iconv ipv6 lua midi mikmod minimal mmx mmxext modplug modules mpi ncurses nls nptl odbc openmp pam pax_kernel pcre pyqt4 readline scripts seccomp session smpeg sqlite sse sse2 ssl ssp system-jpeg tcpd unicode webstart x264 xattr xcb xtpax xvmc zenmap ziffy zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" L10N="ar cs eu kn pa ro sa sr sr-Latn" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="amdgpu fbdev intel nouveau radeon radeonsi vesa dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

x11-drivers/xf86-input-keyboard-1.8.1::gentoo was built with the following:
USE=""
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,-z,lazy"
Comment 1 Toralf Förster gentoo-dev 2016-11-16 09:03:45 UTC
Created attachment 453450 [details]
config.log
Comment 2 Toralf Förster gentoo-dev 2016-11-16 09:03:48 UTC
Created attachment 453452 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2016-11-16 09:03:51 UTC
Created attachment 453454 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2016-11-16 09:03:54 UTC
Created attachment 453456 [details]
x11-drivers:xf86-input-keyboard-1.8.1:20161116-002138.log
Comment 5 Lars Wendler (Polynomial-C) gentoo-dev 2016-11-16 10:55:29 UTC

*** This bug has been marked as a duplicate of bug 599938 ***