Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 599622 - gnome-base/gnome-control-center-3.22.1[gnome-online-accounts,-colord] does not build
Summary: gnome-base/gnome-control-center-3.22.1[gnome-online-accounts,-colord] does no...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords: InVCS
Depends on:
Blocks: gnome-3.22
  Show dependency tree
 
Reported: 2016-11-13 04:29 UTC by Marien Zwart
Modified: 2016-11-13 09:58 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
config.log (config.log,78.44 KB, text/plain)
2016-11-13 04:29 UTC, Marien Zwart
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marien Zwart 2016-11-13 04:29:39 UTC
Created attachment 453178 [details]
config.log

gnome-control-center-3.22.1 does not build without colord (USE flag off and packages not present) if gnome-online-accounts is enabled. See attached config.log.

This is caused by two typos in the gnome-control-center-3.22.0-optional.patch.

The first one is here:

+AC_ARG_ENABLE([color],
+              AS_HELP_STRING([--disable-color],
+                             [disable color management panel]),
+              []
+              [enable_color=auto])

There is a missing comma after the "[]" (second-to-last argument). This means only three arguments are passed: enable_color=auto is executed when --{enable,disable}-color is given, overriding the explicit choice.

That should only turn colord into an automagic dependency, but there is another typo a few lines further down:

+                           AS_IF([test "$enable_goa" = "yes"],
+                                 [AC_MSG_ERROR([colord support requested but not found])])
+                         ])

This should be checking $enable_color, not $enable_goa. This makes the missing colord dependency fatal if goa (gnome-online-accounts) is enabled.
Comment 1 Gilles Dartiguelongue gentoo-dev 2016-11-13 09:58:13 UTC
Should be fixed in https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=2641ed0e8724f2ac50698355ae72da39f9904a13

Thanks for reporting.