Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 598424 - sys-block/thin-provisioning-tools: version bump to 0.6.3 and GCC 6 build fix
Summary: sys-block/thin-provisioning-tools: version bump to 0.6.3 and GCC 6 build fix
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 3 votes (vote)
Assignee: Robin Johnson
URL:
Whiteboard:
Keywords:
: 582686 (view as bug list)
Depends on:
Blocks: gcc-6
  Show dependency tree
 
Reported: 2016-10-29 11:00 UTC by Jonathan Scruggs (RETIRED)
Modified: 2017-03-06 22:37 UTC (History)
8 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
thin-provisioning-tools-0.6.3.ebuild (thin-provisioning-tools-0.6.3.ebuild,1.50 KB, text/plain)
2016-10-29 11:00 UTC, Jonathan Scruggs (RETIRED)
Details
thin-provisioning-tools-0.6.3-build-fixes.patch (thin-provisioning-tools-0.6.3-build-fixes.patch,2.15 KB, patch)
2016-10-29 11:01 UTC, Jonathan Scruggs (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Scruggs (RETIRED) gentoo-dev 2016-10-29 11:00:48 UTC
Created attachment 451822 [details]
thin-provisioning-tools-0.6.3.ebuild

Upstream decided to hard code -std=gnu++98 compile flag instead of fixing the underlying issues. I made a patch that removes that hard coding and fixes the issues that caused the compile failures. I'll submit the the patch upstream later. It's now set to use compiler default -- probably could make it use -std=c++14 for consistency. That line of the patch can be changed if you want.

I removed the sed lines to put them in the build fixes patch.

Updated to EAPI 6.

I can create a Pull Request if you want.
Comment 1 Jonathan Scruggs (RETIRED) gentoo-dev 2016-10-29 11:01:54 UTC
Created attachment 451824 [details, diff]
thin-provisioning-tools-0.6.3-build-fixes.patch

The patch that removes gnu++98 hard coding and fixes the build issues properly.
Comment 2 Justin Lecher gentoo-dev 2016-12-28 10:47:53 UTC
commit a121971a2a828064776d338ed771bdfc5b852052
Author: Justin Lecher <jlec@gentoo.org>
Date:   Wed Dec 28 10:45:36 2016 +0000

    sys-block/thin-provisioning-tools: Version Bump and Fixes for gcc-6

    Thanks Jon for the ebuild and patch

    Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=598424

    Package-Manager: Portage-2.3.3, Repoman-2.3.1
    Signed-off-by: Justin Lecher <jlec@gentoo.org>

    https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=a121971a2a828064776d338ed771bdfc5b852052
Comment 3 SpanKY gentoo-dev 2017-03-06 22:37:16 UTC
*** Bug 582686 has been marked as a duplicate of this bug. ***