Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 598070 - dev-python/pycparser-2.16-r1 IOError: [Errno 13] Permission denied: '/usr/lib64/python2.7/site-packages/pycparser-2.16-py2.7.egg-info/PKG-INFO'
Summary: dev-python/pycparser-2.16-r1 IOError: [Errno 13] Permission denied: '/usr/lib...
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Python Gentoo Team
URL:
Whiteboard:
Keywords:
: 598068 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-10-25 11:33 UTC by Anton Kochkov
Modified: 2016-10-26 13:59 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anton Kochkov 2016-10-25 11:33:18 UTC
>>> Compiling source in /var/tmp/portage/dev-python/pycparser-2.16-r1/work/pycparser-2.16 ...
 * python2_7: running distutils-r1_run_phase python_compile
/usr/bin/python2.7 setup.py build
Traceback (most recent call last):
  File "setup.py", line 3, in <module>
    from setuptools import setup
  File "/usr/lib64/python2.7/site-packages/setuptools/__init__.py", line 10, in <module>
    from setuptools.extern.six.moves import filterfalse, map
  File "/usr/lib64/python2.7/site-packages/setuptools/extern/__init__.py", line 1, in <module>
    from pkg_resources.extern import VendorImporter
  File "/usr/lib64/python2.7/site-packages/pkg_resources/__init__.py", line 2985, in <module>
    @_call_aside
  File "/usr/lib64/python2.7/site-packages/pkg_resources/__init__.py", line 2971, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib64/python2.7/site-packages/pkg_resources/__init__.py", line 2998, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib64/python2.7/site-packages/pkg_resources/__init__.py", line 651, in _build_master
    ws = cls()
  File "/usr/lib64/python2.7/site-packages/pkg_resources/__init__.py", line 644, in __init__
    self.add_entry(entry)
  File "/usr/lib64/python2.7/site-packages/pkg_resources/__init__.py", line 700, in add_entry
    for dist in find_distributions(entry, True):
  File "/usr/lib64/python2.7/site-packages/pkg_resources/__init__.py", line 1990, in find_on_path
    path_item, entry, metadata, precedence=DEVELOP_DIST
  File "/usr/lib64/python2.7/site-packages/pkg_resources/__init__.py", line 2399, in from_location
    py_version=py_version, platform=platform, **kw
  File "/usr/lib64/python2.7/site-packages/pkg_resources/__init__.py", line 2740, in _reload_version
    md_version = _version_from_file(self._get_metadata(self.PKG_INFO))
  File "/usr/lib64/python2.7/site-packages/pkg_resources/__init__.py", line 2364, in _version_from_file
    line = next(iter(version_lines), '')
  File "/usr/lib64/python2.7/site-packages/pkg_resources/__init__.py", line 2532, in _get_metadata
    for line in self.get_metadata_lines(name):
  File "/usr/lib64/python2.7/site-packages/pkg_resources/__init__.py", line 1472, in get_metadata_lines
    return yield_lines(self.get_metadata(name))
  File "/usr/lib64/python2.7/site-packages/pkg_resources/__init__.py", line 1468, in get_metadata
    value = self._get(self._fn(self.egg_info, name))
  File "/usr/lib64/python2.7/site-packages/pkg_resources/__init__.py", line 1577, in _get
    with open(path, 'rb') as stream:
IOError: [Errno 13] Permission denied: '/usr/lib64/python2.7/site-packages/pycparser-2.16-py2.7.egg-info/PKG-INFO'
 * ERROR: dev-python/pycparser-2.16-r1::gentoo failed (compile phase):
 *   (no error message)
 *
 * Call stack:
 *     ebuild.sh, line  115:  Called src_compile
 *   environment, line 2600:  Called distutils-r1_src_compile
 *   environment, line  747:  Called _distutils-r1_run_foreach_impl 'python_compile'
 *   environment, line  308:  Called python_foreach_impl 'distutils-r1_run_phase' 'python_compile'
 *   environment, line 2130:  Called multibuild_foreach_variant '_python_multibuild_wrapper' 'distutils-r1_run_phase'
'python_compile'
 *   environment, line 1431:  Called _multibuild_run '_python_multibuild_wrapper' 'distutils-r1_run_phase' 'python_com
pile'
 *   environment, line 1429:  Called _python_multibuild_wrapper 'distutils-r1_run_phase' 'python_compile'
 *   environment, line  499:  Called distutils-r1_run_phase 'python_compile'
 *   environment, line  740:  Called python_compile
 *   environment, line 1715:  Called distutils-r1_python_compile
 *   environment, line  615:  Called esetup.py 'build'
 *   environment, line  994:  Called die
 * The specific snippet of code:
 *       "${@}" || die "${die_args[@]}";
 *
 * If you need support, post the output of `emerge --info '=dev-python/pycparser-2.16-r1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-python/pycparser-2.16-r1::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/dev-python/pycparser-2.16-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-python/pycparser-2.16-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-python/pycparser-2.16-r1/work/pycparser-2.16'
Comment 1 Anton Kochkov 2016-10-25 11:33:52 UTC
Related to https://bugs.gentoo.org/show_bug.cgi?id=598066 ?
Comment 2 Lars Wendler (Polynomial-C) gentoo-dev 2016-10-25 11:36:15 UTC

*** This bug has been marked as a duplicate of bug 598066 ***
Comment 3 Mike Gilbert gentoo-dev 2016-10-25 14:21:04 UTC
Sorry about this; I added a pkg_pretend check advising the user to unmerge the broken pycparser first.

commit eebba2385e89f4390d45299d9b3aa48e87c13f53
Author: Mike Gilbert <floppym@gentoo.org>
Date:   Tue Oct 25 10:18:24 2016 -0400

    dev-python/pycparser: add pkg_pretend check for broken version

    Having the broken pycparser-2.16 installed breaks installation of
    all setuptools packages, including the 2.16-r1 revbump.

    Package-Manager: portage-2.3.2

 dev-python/pycparser/pycparser-2.16-r1.ebuild | 9 +++++++++
 1 file changed, 9 insertions(+)
Comment 4 Lars Wendler (Polynomial-C) gentoo-dev 2016-10-26 12:47:06 UTC
*** Bug 598068 has been marked as a duplicate of this bug. ***