Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 597842 - gnome-base/gnome-shell-3.22.1 - .libs/ShellMenu-0.1: error while loading shared libraries: libmutter-clutter-1.0.so: cannot open shared object file: No such file or directory
Summary: gnome-base/gnome-shell-3.22.1 - .libs/ShellMenu-0.1: error while loading shar...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords: InVCS
: 598816 598846 (view as bug list)
Depends on:
Blocks: gnome-3.22
  Show dependency tree
 
Reported: 2016-10-23 04:43 UTC by iGentoo
Modified: 2016-11-12 10:47 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
gnome-shell-3.22.1-build.log (gnome-shell-3.22.1-build.log,480.09 KB, text/plain)
2016-10-23 04:43 UTC, iGentoo
Details
workaround patch (mutter-rpath.patch,452 bytes, patch)
2016-10-23 04:46 UTC, iGentoo
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description iGentoo 2016-10-23 04:43:20 UTC
Created attachment 451084 [details]
gnome-shell-3.22.1-build.log

g-ir-scanner: link: /bin/bash ../libtool --mode=link --tag=CC x86_64-pc-linux-gnu-gcc -o /var/tmp/portage/gnome-base/gnome-shell-3.22.1/work/gnome-shell-3.22.1/src/tmp-introspect2MXerZ/ShellMenu-0.1 -export-dynamic -Wall -march=native -O2 -pipe -frecord-gcc-switches -Wl,-O1 -Wl,--as-needed tmp-introspect2MXerZ/var/tmp/portage/gnome-base/gnome-shell-3.22.1/work/gnome-shell-3.22.1/src/tmp-introspect2MXerZ/ShellMenu-0.1.o -L. libgnome-shell-menu.la -L/usr/lib64/mutter -rpath /usr/lib64/mutter -lgio-2.0 -lgobject-2.0 -Wl,--export-dynamic -lgmodule-2.0 -pthread -lglib-2.0
libtool: link: x86_64-pc-linux-gnu-gcc -o /var/tmp/portage/gnome-base/gnome-shell-3.22.1/work/gnome-shell-3.22.1/src/tmp-introspect2MXerZ/.libs/ShellMenu-0.1 -Wall -march=native -O2 -pipe -frecord-gcc-switches -Wl,-O1 tmp-introspect2MXerZ/var/tmp/portage/gnome-base/gnome-shell-3.22.1/work/gnome-shell-3.22.1/src/tmp-introspect2MXerZ/ShellMenu-0.1.o -Wl,--export-dynamic -pthread -Wl,--export-dynamic  -Wl,--as-needed -L. ./.libs/libgnome-shell-menu.so -L/usr/lib64/mutter -lxml2 -latk-bridge-2.0 -lgjs -lmozjs-24 -lgstbase-1.0 -lgstreamer-1.0 -lsoup-2.4 -lmutter-clutter-1.0 -ljson-glib-1.0 -lwayland-egl -lwayland-client -lXi -lmutter-cogl-pango -lmutter-cogl -lgbm -ldrm -lwayland-server -lEGL -lXext -lXdamage -lXfixes -lXcomposite -lXrandr -lstartup-notification-1 -lgirepository-1.0 -lcanberra-gtk3 -lX11 -lcanberra -ltelepathy-glib -lpolkit-agent-1 -lpolkit-gobject-1 -lgcr-base-3 -lgck-1 -lp11-kit -lsystemd -lnm-gtk -lnm-glib -lnm-util -ldbus-glib-1 -ldbus-1 -lgtk-3 -lgdk-3 -lpangocairo-1.0 -lpango-1.0 -latk-1.0 -lcairo-gobject -lcairo -lgdk_pixbuf-2.0 -lsecret-1 -lgio-2.0 -lgobject-2.0 -lgmodule-2.0 -lglib-2.0 -pthread -Wl,-rpath -Wl,/usr/lib64/gnome-shell -Wl,-rpath -Wl,/usr/lib64/mutter
/var/tmp/portage/gnome-base/gnome-shell-3.22.1/work/gnome-shell-3.22.1/src/tmp-introspect2MXerZ/.libs/ShellMenu-0.1: error while loading shared libraries: libmutter-clutter-1.0.so: cannot open shared object file: No such file or directory
Command '[u'/var/tmp/portage/gnome-base/gnome-shell-3.22.1/work/gnome-shell-3.22.1/src/tmp-introspect2MXerZ/ShellMenu-0.1', u'--introspect-dump=/var/tmp/portage/gnome-base/gnome-shell-3.22.1/work/gnome-shell-3.22.1/src/tmp-introspect2MXerZ/functions.txt,/var/tmp/portage/gnome-base/gnome-shell-3.22.1/work/gnome-shell-3.22.1/src/tmp-introspect2MXerZ/dump.xml']' returned non-zero exit status 127
make[4]: *** [/usr/share/gobject-introspection-1.0/Makefile.introspection:156: ShellMenu-0.1.gir] Error 1
make[4]: Leaving directory '/var/tmp/portage/gnome-base/gnome-shell-3.22.1/work/gnome-shell-3.22.1/src'
make[3]: *** [Makefile:2279: all-recursive] Error 1




Portage 2.3.2 (python 3.5.2-final-0, default/linux/amd64/13.0, gcc-6.2.0, glibc-2.24, 4.7.9-hardened.x86_64 x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.7.9-hardened.x86_64-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q9300_@_2.50GHz-with-gentoo-2.3
KiB Mem:     6114308 total,    131256 free
KiB Swap:    6291452 total,   5705584 free
sh dash 0.5.9.1
ld GNU gold (Gentoo 2.26.1 p1.0 2.26.1) 1.11
ccache version 3.3.2 [disabled]
app-shells/bash:          4.4-r1::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.0-r2::gentoo
dev-lang/python:          2.7.12::gentoo, 3.5.2::gentoo
dev-util/ccache:          3.3.2::local-repo
dev-util/cmake:           3.7.0_rc2::gentoo
dev-util/pkgconfig:       0.29.1::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/sandbox:         2.11-r2::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r2::gentoo
sys-devel/automake:       1.15-r2::gentoo
sys-devel/binutils:       2.26.1::gentoo
sys-devel/gcc:            6.2.0-r1::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r2::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.7::gentoo (virtual/os-headers)
sys-libs/glibc:           2.24::local-repo
Repositories:

gentoo
    location: /usr/portage
    sync-type: git
    sync-uri: git://anongit.gentoo.org/repo/gentoo.git
    sync-user: portage
    priority: -1000
    eclass-overrides: local-repo
    sync-git-pull-extra-opts: -v

gnome-next
    location: /var/lib/layman/gnome-next
    sync-type: git
    sync-uri: https://github.com/Heather/gentoo-gnome.git
    masters: gentoo
    sync-git-pull-extra-opts: -v

local-repo
    location: /usr/local/portage
    masters: gentoo

Installed sets: @local
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-Wall -march=native -O2 -pipe -frecord-gcc-switches"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-Wall -march=native -O2 -pipe -frecord-gcc-switches"
DISTDIR="/var/portage/distfiles"
EMERGE_DEFAULT_OPTS="--color=n --oneshot"
FCFLAGS="-Wall -march=native -O2 -pipe -frecord-gcc-switches"
FEATURES="assume-digests binpkg-logs buildpkg collision-protect config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync metadata-transfer multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms split-log strict test-fail-continue unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-Wall -march=native -O2 -pipe -frecord-gcc-switches"
GENTOO_MIRRORS="http://mirrors.163.com/gentoo http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="V=1 -j6"
PKGDIR="/var/portage/packages"
PORTAGE_BZIP2_COMMAND="lbzip2"
PORTAGE_COMPRESS="xz"
PORTAGE_COMPRESS_FLAGS="-9T0"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X acl amd64 audit berkdb bzip2 cli cracklib crypt cxx dbus dri egl fortran gdbm gles2 iconv icu ipv6 jpeg mmx mmxext modules multilib ncurses nls nptl opengl openmp pam pax_kernel pcre pic png policykit pulseaudio readline seccomp session sse sse2 ssl systemd tcpd unicode vdpau vim-syntax wayland xattr zlib" ABI_X86="64 32 x32" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2 sse3 sse4_1 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev" KERNEL="linux" L10N="zh-CN" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="zh_CN" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python3_5" PYTHON_TARGETS="python2_7 python3_5" RUBY_TARGETS="ruby23" USERLAND="GNU" VIDEO_CARDS="nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

dev-libs/gobject-introspection-1.49.2::gnome-next was built with the following:
USE="-cairo -debug -doctool -test" ABI_X86="64" PYTHON_TARGETS="python2_7"


gnome-base/gnome-shell-3.22.1::local-repo was built with the following:
USE="networkmanager nls -bluetooth (-openrc-force)" ABI_X86="64" PYTHON_TARGETS="python3_5 -python3_3 -python3_4"


x11-wm/mutter-3.22.1::gnome-next was built with the following:
USE="introspection kms wayland -test" ABI_X86="64"
Comment 1 iGentoo 2016-10-23 04:46:43 UTC
Created attachment 451086 [details, diff]
workaround patch
Comment 2 Geoff Leach 2016-10-25 12:24:12 UTC
The fix works for me except using user patches (/etc/portage/patches) I had to patch Makefile.in rather than Makefile.am as autoreconf is called before user patches are applied.
Comment 3 Cynede (RETIRED) gentoo-dev 2016-10-27 13:09:15 UTC
please send patch to overlay on github, thank you
Comment 4 Mike Auty (RETIRED) gentoo-dev 2016-11-02 12:37:39 UTC
The offending ebuild was added (masked) to the main portage tree recently.  Updating the summary and reassigning accordingly.
Comment 5 Gilles Dartiguelongue gentoo-dev 2016-11-02 23:49:16 UTC
This bump was pushed by error, please keep gnome-shell and mutter (at least) masked for now.
Comment 6 Pacho Ramos gentoo-dev 2016-11-03 10:25:35 UTC
*** Bug 598816 has been marked as a duplicate of this bug. ***
Comment 7 Harris Landgarten 2016-11-03 16:31:01 UTC
workaround:

create /etc/env.d/99mutter with the contents:

LDPATH="/usr/lib64/mutter"

then env-update

You can check it worked:

ldconfig -p | grep libmutter:

	libmutter.so.0 (libc6,x86-64) => /usr/lib64/libmutter.so.0
	libmutter.so (libc6,x86-64) => /usr/lib64/libmutter.so
	libmutter-cogl.so (libc6,x86-64) => /usr/lib64/mutter/libmutter-cogl.so
	libmutter-cogl-path.so (libc6,x86-64) => /usr/lib64/mutter/libmutter-cogl-path.so
	libmutter-cogl-pango.so (libc6,x86-64) => /usr/lib64/mutter/libmutter-cogl-pango.so
	libmutter-clutter-1.0.so (libc6,x86-64) => /usr/lib64/mutter/libmutter-clutter-1.0.so

After this gnome-shell will install
Comment 8 Pacho Ramos gentoo-dev 2016-11-04 12:23:50 UTC
*** Bug 598846 has been marked as a duplicate of this bug. ***
Comment 9 Gilles Dartiguelongue gentoo-dev 2016-11-12 10:47:05 UTC
Patch applied in https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=a4358aee4a36b9c9eeef3e487ea9c3459218c0cf

Thanks for reporting.