Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 59779 - esound plays .wav files with noices
Summary: esound plays .wav files with noices
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: Lowest trivial (vote)
Assignee: Gentoo Linux Gnome Desktop Team
: 60945 (view as bug list)
Depends on:
Blocks: 59768 64135 66864 72798
  Show dependency tree
Reported: 2004-08-08 08:54 UTC by Selecter
Modified: 2005-07-24 12:32 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Selecter 2004-08-08 08:54:43 UTC
$ file /usr/share/sounds/k3b_success1.wav
/usr/share/sounds/k3b_success1.wav: RIFF (little-endian) data, WAVE audio, Microsoft PCM, 8 bit, mono 8000 Hz

esdplay, xmms...

And I got 70% in alsamixer.

Reproducible: Always
Steps to Reproduce:
Comment 1 foser (RETIRED) gentoo-dev 2004-08-09 03:16:39 UTC
can you be more complete in your description ? What happens, where does it happen, does it only happen with this file ?

And _always_ provide your 'emerge info' in bugreports.
Comment 2 Ernst Sjöstrand 2004-08-16 14:21:37 UTC
I've got something like this too.
aplay plays the sound nice, "mplayer -vo alsa" sounds nice.

esdplay however plays the sound with noises and so does rhythmbox.

I'll do some testing on this..
Comment 3 Ernst Sjöstrand 2004-08-16 14:34:25 UTC
I usually compile things with GCC 3.4 and CFLAGS="-O3 -pipe -march=k8 -fomit-frame-pointer -ftracer"
The first thing I did was to recompile esound with "-02 -march=k8". That didn't help.
I switched back to GCC 3.3 and compiled it with CFLAGS="-O3 -pipe -march=athlon-xp -fomit-frame-pointer", and now it's working again.

gcc-config -l
[1] i686-pc-linux-gnu-3.3.4
[2] i686-pc-linux-gnu-3.4.1

emerge info
Portage 2.0.51_pre17 (gcc34-x86-2004.2, gcc-3.4.1, glibc-, 2.6.7-gentoo-r13 i686 AMD Athlon(tm) 64 Processor 3200+)
System uname: 2.6.7-gentoo-r13 i686 AMD Athlon(tm) 64 Processor 3200+
Gentoo Base System version 1.5.2
Autoconf: sys-devel/autoconf-2.59-r4
Automake: sys-devel/automake-1.8.5-r1
Binutils: sys-devel/binutils-
Headers:  sys-kernel/linux26-headers-2.6.7-r4
Libtools: sys-devel/libtool-1.5.2-r5
CFLAGS="-O3 -pipe -march=k8 -fomit-frame-pointer -ftracer"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/config /var/qmail/control"CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -pipe -march=k8 -fomit-frame-pointer -ftracer"
FEATURES="autoaddcvs ccache sandbox"
PORTDIR_OVERLAY="/usr/local/private_overlay /usr/local/bmg_gnome_current /usr/local/bmg_overlay"
USE="X aac alsa apache2 apm avi berkdb bonobo cdr crypt cups curl dga doc dvd encode esd evo faad fam fbcon ffmpeg foomaticdb gcj gdbm gif gimp gimpprint glade glut gnome gnomedb gnutls gphoto2 gpm gtk2 gtkhtml howl icq imap imlib imlib2 jabber java jit jpeg kde ldap libg++ libwww mad mikmod mmap mmx mng mono mozilla mpeg mpeg4 msn ncurses nls nptl objc offensive oggvorbis openal opengl oscar pam pdflib perl plotutils png pthreads python qt readline samba scanner sdk sdl slang spell ssl stencil-buffer svg svga tcltk tcpd theora threads tiff truetype type1 uml unicode usb x86 xine xml2 xv zlib"

Sound driver is ALSA with snd_via82xx driver-module.
I had been experimenting with esound 0.2.35 too, don't know if that could have affected anything.
Comment 4 Selecter 2004-08-17 01:13:41 UTC
No noises with such files:
/usr/share/psi/sound/ft_complete.wav: RIFF (little-endian) data, WAVE audio, Microsoft PCM, 16 bit, mono 44100 Hz
/usr/kde/3.2/share/sounds/KDE_Startup.wav: RIFF (little-endian) data, WAVE audio, Microsoft PCM, 16 bit, mono 22050 Hz
Comment 5 Ernst Sjöstrand 2004-08-19 09:36:05 UTC
Now that esound .35 is in portage I tried some more.
It seems like .34 allways work and .35 produces noises no matter what I compile it with.
Comment 6 Ernst Sjöstrand 2004-09-20 01:46:23 UTC
Tried some more now.
Totem with it's AC3 passthrough doesn't have this problem, but everything that goes through esound sounds strange. The sound is a bit faster, and has some static in it.

What could it be.. the new mmap support? 

esound changelog:
2004-06-11  Frederic Crozat  <>

	* docs/
	* esddsp.c: (dsp_init), (mmapemu_flush), (open), (dspctl), (close),
	(mmap), (munmap):
	MMAP support for esddsp (from artsdsp) (bug #144157,
	patch from Olivier Blin <>).
Comment 7 Gene Ruebsamen 2004-10-08 12:48:42 UTC
Could this be a duplicate of bug (60945)?
Comment 8 Ernst Sjöstrand 2004-10-09 05:15:11 UTC
Yes, yes, in my case it could very well be!
Comment 9 foser (RETIRED) gentoo-dev 2004-10-09 05:25:00 UTC
*** Bug 60945 has been marked as a duplicate of this bug. ***
Comment 10 foser (RETIRED) gentoo-dev 2004-10-12 15:25:48 UTC
for now we go with esound .25 masked for gnome 2.8, given the current esound activity we might close this bug with that.
Comment 11 John N. Laliberte (RETIRED) gentoo-dev 2005-07-03 08:03:06 UTC
does this problem still occur?
Comment 12 Leonardo Boshell (RETIRED) gentoo-dev 2005-07-03 09:13:55 UTC
This may be related to this bug:

esound-0.2.35 is buggy, but please try esound-0.2.36 (recently committed,
although still hard-masked for testing) and check if it shows the same problem.
Comment 13 Leonardo Boshell (RETIRED) gentoo-dev 2005-07-24 12:32:26 UTC
The only version of esound in which I have noticed noise problems is 0.2.35.
Version 0.2.36 seems to work fine, so I've unmasked it in preparation for

Please test it and let us know if you encounter any problems with it. Thanks.