Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 597744 - =dev-python/m2crypto-0.25.1-r2 dev-python/typing keyword request
Summary: =dev-python/m2crypto-0.25.1-r2 dev-python/typing keyword request
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Keywording (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Python Gentoo Team
URL:
Whiteboard:
Keywords: KEYWORDREQ
: 605282 (view as bug list)
Depends on:
Blocks: 597710
  Show dependency tree
 
Reported: 2016-10-22 03:18 UTC by bugsgentoo
Modified: 2020-04-06 16:30 UTC (History)
10 users (show)

See Also:
Package list:
dev-python/typing-3.7.4.1 dev-python/m2crypto-0.35.2
Runtime testing required: No


Attachments
log file of emerge command and output (build.log,5.09 KB, text/plain)
2016-10-22 03:19 UTC, bugsgentoo
no flags Details
emerge --info output (emerge.info,6.54 KB, text/plain)
2016-10-22 03:20 UTC, bugsgentoo
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description bugsgentoo 2016-10-22 03:18:28 UTC
Trying to install gentoo from scratch, emerge failed installing net-wireless/crda.
The problem is that the M2Crypto python module cannot be load, because it misses the typing module:
ERROR: Failed to import the "M2Crypto" module: No module named typing

I.e. the dev-python/typing is not installed automatically as a dependency of dev-python/m2crypto

Reproducible: Always
Comment 1 bugsgentoo 2016-10-22 03:19:36 UTC
Created attachment 450968 [details]
log file of emerge command and output
Comment 2 bugsgentoo 2016-10-22 03:20:22 UTC
Created attachment 450970 [details]
emerge --info output
Comment 3 Alex Brandt (RETIRED) gentoo-dev 2016-10-23 01:52:17 UTC
Updating assignee since m2crypto is a python package not just mine.
Comment 4 Tiago Macedo 2016-10-25 07:53:36 UTC
Ran into this on a fresh installation, adding dev-python/typing as a dependency does indeed fix it.
Comment 5 Albert Brown 2016-10-27 05:54:16 UTC
I ran into this issue as well (new install, default/linux/amd64/13.0 profile, accepting ~amd64 keyword, a half hour ago) installing net-wireless/wpa_supplicant, which pulls in net-wireless/crda and had the same results as bugsgentoo@jwdt.org and Tiago.  Installing dev-python/typing fixes the build error.  I just figured I'd mention it for the record.
Comment 6 Jonathan Scruggs (RETIRED) gentoo-dev 2016-10-28 09:46:33 UTC
I hit this as well. Just add dev-pythong/typing to the rdepends list. Easy fix. :)
Comment 7 Toralf Förster gentoo-dev 2016-10-28 09:52:21 UTC
*** Bug 597710 has been marked as a duplicate of this bug. ***
Comment 8 Jonathan Scruggs (RETIRED) gentoo-dev 2016-10-28 11:04:47 UTC
With Soap's command I submitted a PR here: https://github.com/gentoo/gentoo/pull/2686
Comment 9 David Seifert gentoo-dev 2016-10-28 22:35:28 UTC
Due to the necessary new RDEPEND now, please start keywording dev-python/typing, arch teams.

commit 88f92032cd9768fff8af37c8fd68ede1a7241879
Author: Jonathan Scruggs <j.scruggs@gmail.com>
Date:   Fri Oct 28 11:46:47 2016 +0100

    dev-python/m2crypto: Add missing RDEPEND on dev-python/typing
    
    Gentoo-bug: 597744
    * EAPI=6
    * Removing old ebuild as it doesn't have the
      dependency, so m2crypto will not work right.
    
    Signed off by: Jonathan Scruggs (j.scruggs@gmail.com)
    Closes: https://github.com/gentoo/gentoo/pull/2686
    
    Signed-off-by: David Seifert <soap@gentoo.org>
Comment 10 Steffen Hau 2016-11-02 11:31:49 UTC
I have 3.5 for PYTHON_SINGLE_TARGET, PYTHON_TARGETS and USE_PYTHON in my make.conf and crda still reported the failure. Adding 2.7 to dev-python/typing via package.env solved the issue.

So please require dev-python/typing[${PYTHON_USEDEP}] in order to pull in the needed modules for m2crypto to work.
Comment 11 Jonathan Scruggs (RETIRED) gentoo-dev 2016-11-02 11:35:33 UTC
(In reply to Steffen Hau from comment #10)
> I have 3.5 for PYTHON_SINGLE_TARGET, PYTHON_TARGETS and USE_PYTHON in my
> make.conf and crda still reported the failure. Adding 2.7 to
> dev-python/typing via package.env solved the issue.
> 
> So please require dev-python/typing[${PYTHON_USEDEP}] in order to pull in
> the needed modules for m2crypto to work.

Ah missed that. Thanks!
Comment 12 Jonathan Scruggs (RETIRED) gentoo-dev 2016-11-02 11:46:40 UTC
Created a Pull Request to fix this:
https://github.com/gentoo/gentoo/pull/2718
Comment 13 Tobias Klausmann (RETIRED) gentoo-dev 2016-11-24 17:46:50 UTC
Stable on alpha.
Comment 14 Stabilization helper bot gentoo-dev 2017-01-13 14:53:33 UTC
An automated check of this bug failed - the following atom is unknown:

dev-python/typing

Please verify the atom list.
Comment 15 Stabilization helper bot gentoo-dev 2017-01-13 15:41:25 UTC
An automated check of this bug succeeded - the previous repoman errors are now resolved.
Comment 16 Jeroen Roovers (RETIRED) gentoo-dev 2017-01-15 19:48:19 UTC
*** Bug 605282 has been marked as a duplicate of this bug. ***
Comment 17 Jeroen Roovers (RETIRED) gentoo-dev 2017-01-15 20:07:05 UTC
Marked ~ppc64.
Comment 18 Jeroen Roovers (RETIRED) gentoo-dev 2017-01-15 20:11:43 UTC
Marked ~hppa.
Comment 19 Markus Meier gentoo-dev 2017-02-22 21:34:28 UTC
~arm64 added.
Comment 20 Markus Meier gentoo-dev 2017-02-27 20:12:13 UTC
~arm added.
Comment 21 Sergei Trofimovich (RETIRED) gentoo-dev 2017-07-01 10:16:38 UTC
~ia64 keyworded
Comment 22 Sergei Trofimovich (RETIRED) gentoo-dev 2017-09-10 19:13:29 UTC
~ppc keyworded
Comment 23 Matt Turner gentoo-dev 2017-11-10 03:51:13 UTC
added ~mips
Comment 24 Thomas Deutschmann (RETIRED) gentoo-dev 2017-11-19 19:51:35 UTC
~x86 added
Comment 25 Sergei Trofimovich (RETIRED) gentoo-dev 2017-12-10 00:34:13 UTC
~sparc keyworded (thanks to Rolf Eike Beer)
Comment 26 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2018-02-24 10:24:36 UTC
(updating package versions)
Comment 27 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2018-07-01 14:45:43 UTC
~s390 done
Comment 28 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2020-03-26 14:07:55 UTC
SuperH port disbanded.
Comment 29 Michael 'veremitz' Everitt 2020-04-02 09:13:21 UTC
@python: please CC arches to reset the stablebot test. Thanks.
Comment 30 NATTkA bot gentoo-dev 2020-04-06 15:26:17 UTC
Unable to check for sanity:

> no match for package: =dev-python/typing-3.6.4-r1
Comment 31 Mike Gilbert gentoo-dev 2020-04-06 16:30:51 UTC
It looks like all archs finished this.