Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 597422 - sys-block/thin-provisioning-tools-0.6.1 : thin-provisioning/restore_emitter.cc:145:11: error: cannot convert ‘persistent_data::btree<1u, thin_provisioning::device_tree_detail::device_details_traits>::maybe_value {aka boost::optional<thin_provisioning::d
Summary: sys-block/thin-provisioning-tools-0.6.1 : thin-provisioning/restore_emitter.c...
Status: RESOLVED DUPLICATE of bug 593922
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Robin Johnson
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-6
  Show dependency tree
 
Reported: 2016-10-18 10:09 UTC by Toralf Förster
Modified: 2016-10-26 07:00 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
config.log (config.log,24.64 KB, text/plain)
2016-10-18 10:09 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,122.51 KB, text/plain)
2016-10-18 10:09 UTC, Toralf Förster
Details
environment (environment,111.33 KB, text/plain)
2016-10-18 10:09 UTC, Toralf Förster
Details
sys-block:thin-provisioning-tools-0.6.1:20161017-221018.log (sys-block:thin-provisioning-tools-0.6.1:20161017-221018.log,91.73 KB, text/plain)
2016-10-18 10:09 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2016-10-18 10:09:27 UTC
x86_64-pc-linux-gnu-g++ -c -I. -I. -I./thin-provisioning -march=native -O2 -pipe -g -Wall -fno-strict-aliasing   -DSTRERROR_R_CHAR_P  -o thin-provisioning/restore_emitter.o thin-provisioning/restore_emitter.cc
thin-provisioning/restore_emitter.cc: In member function ‘bool {anonymous}::restorer::device_exists(thin_provisioning::thin_dev_t) const’:
thin-provisioning/restore_emitter.cc:145:11: error: cannot convert ‘persistent_data::btree<1u, thin_provisioning::device_tree_detail::device_details_traits>::maybe_value {aka boost::optional<thin_provisioning::device_tree_detail::device_details>}’ to ‘bool’ in return
    return v;
           ^
In file included from ./persistent-data/block.h:154:0,


$ cat emerge-info.txt
  -----------------------------------------------------------------

  This is an unstable amd64 chroot image (named amd64-hardened-unstable_20161015-114118) at a hardened host acting as a tinderbox.

  -----------------------------------------------------------------
  USE flags ...

  ... in make.conf:
USE="  pax_kernel xtpax -cdinstall -oci8 -bindist ssp X a52 aac aes-ni alsa apache2 avx avx2 cgroups consolekit corefonts cron cups custom-cflags custom-optimization dbus dnssec dvb dvd ecc encode exif fam ffmpeg flac fontconfig fpm gif git glamor gnuplot gpg gtk gui help hwaccel icu isag jpeg lcms libnotify libvirtd logrotate mad matroska mbox minizip mng mp3 mp4 mpeg mpg123 nfsv4 nfsv41 ogg orc pcre16 pdf png policykit pwquality qemu qml qt3support qt5 rtsp samba script scrypt sddm snmp spice sse2 sse4 sse4_1 sse4_2 ssh-askpass ssse3 startup-notification svg system-cairo system-ffmpeg system-harfbuzz system-icu system-jpeg system-libevent system-libvpx system-sqlite theora thinkpad tiff tls tor-hardening tracepath traceroute truetype udev uml usb usbredir uxa v4l v4l2 vaapi vcdx vorbis vpx widgets x264 xa xcb xinerama xkb xml xscreensaver xvfb xvid xz zenmap -bindist -bluetooth -hpn -ldap -qt4 -semantic-desktop -sslv2 -sslv3 -urandom"

  ... in /etc/portage/package.use/*:
  mail-mta/ssmtp      mta ssl
  net-misc/wget       ssl
  app-editors/xemacs  -nopie
  app-crypt/pinentry  -gtk -qt4
  app-editors/emacs   -dbus -gtk -gtk3 -ssl -svg
  app-text/xmlto      -latex
  dev-libs/boehm-gc   threads
  dev-libs/libpcre    pcre16
  dev-lang/python     threads
  dev-qt/qtgui        egl eglfs
  dev-util/cmake      -qt4 -qt5
  dev-vcs/git         -gtk -perl
  gnome-base/librsvg  -tools
  media-libs/mesa     -vaapi
  net-nds/openldap    -sasl
  sys-apps/kmod       tools
  sys-libs/ncurses    -gpm
  x11-libs/gtk+       -cups
  net-misc/iputils -caps -filecaps
  app-editors/xemacs        -nopie

  entries in /etc/portage/package.unmask/*:
  ~sys-apps/sandbox-2.11
  media-video/ffmpeg
  sys-devel/gcc:6.2.0
  -----------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-4.9.3
 [2] x86_64-pc-linux-gnu-4.9.3-hardenednopie
 [3] x86_64-pc-linux-gnu-4.9.3-hardenednopiessp
 [4] x86_64-pc-linux-gnu-4.9.3-hardenednossp
 [5] x86_64-pc-linux-gnu-4.9.3-vanilla
 [6] x86_64-pc-linux-gnu-6.2.0 *
llvm-config --version:
3.8.1
Available Java Virtual Machines:
  [1]   icedtea-bin-8  system-vm
Available Python interpreters, in order of preference:
  [1]   python3.4
  [2]   python2.7 (fallback)

  -----------------------------------------------------------------

Portage 2.3.2 (python 3.4.5-final-0, hardened/linux/amd64, gcc-6.2.0, glibc-2.23-r2, 4.7.7-hardened x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.7.7-hardened-x86_64-Intel-R-_Core-TM-_i7-3930K_CPU_@_3.20GHz-with-gentoo-2.3
KiB Mem:    65285480 total,   2583604 free
KiB Swap:   67108860 total,  67066972 free
Timestamp of repository gentoo: Mon, 17 Oct 2016 18:10:39 +0000
sh bash 4.4-r1
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.4-r1::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.0-r1::gentoo
dev-lang/python:          2.7.12::gentoo, 3.4.5::gentoo
dev-util/cmake:           3.6.2::gentoo
dev-util/pkgconfig:       0.29.1::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/openrc:          0.22.2::gentoo
sys-apps/sandbox:         2.11-r2::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r2::gentoo
sys-devel/automake:       1.11.6-r2::gentoo, 1.13.4-r1::gentoo, 1.14.1-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo, 2.26.1::gentoo
sys-devel/gcc:            4.9.3::gentoo, 6.2.0-r1::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r2::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.7::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r2::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: 1

local
    location: /usr/local/portage
    masters: gentoo
    priority: 2

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/fax /usr/share/config /usr/share/easy-rsa /usr/share/gnupg/qualified.txt /var/spool/fax/etc /var/yp/Makefile"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/var/tmp/distfiles"
EMERGE_DEFAULT_OPTS="--verbose --verbose-conflicts --color=n --nospinner --tree --quiet-build"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync network-sandbox parallel-fetch preserve-libs protect-owned sandbox sfperms strict test-fail-continue unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.uni-erlangen.de/pub/mirrors/gentoo rsync://mirror.netcologne.de/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gor.bytemark.co.uk/gentoo/ rsync://ftp.snt.utwente.nl/gentoo"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl aes-ni alsa amd64 apache2 avx avx2 berkdb bzip2 cgroups cli consolekit corefonts cracklib cron crypt cups custom-cflags custom-optimization cxx dbus dnssec dri dvb dvd ecc encode exif fam ffmpeg flac fontconfig fpm gdbm gif git glamor gnuplot gpg gtk gui hardened help hwaccel iconv icu ipv6 isag jpeg justify lcms libnotify libvirtd logrotate mad matroska mbox minizip mmx mmxext mng modules mp3 mp4 mpeg mpg123 multilib ncurses nfsv4 nfsv41 nls nptl ogg openmp orc pam pax_kernel pcre pcre16 pdf pie png policykit pwquality qemu qml qt3support qt5 readline rtsp samba script scrypt sddm seccomp session snmp spice sse sse2 sse4 sse4_1 sse4_2 ssh-askpass ssl ssp ssse3 startup-notification svg system-cairo system-ffmpeg system-harfbuzz system-icu system-jpeg system-libevent system-libvpx system-sqlite tcpd theora thinkpad tiff tls tor-hardening tracepath traceroute truetype udev uml unicode usb usbredir uxa v4l v4l2 vaapi vcdx vorbis vpx widgets x264 xa xattr xcb xinerama xkb xml xscreensaver xtpax xvfb xvid xz zenmap zlib" ABI_X86="32 64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" L10N="az fil ja or ve" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="amdgpu fbdev intel nouveau radeon radeonsi vesa dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Toralf Förster gentoo-dev 2016-10-18 10:09:34 UTC
Created attachment 450634 [details]
config.log
Comment 2 Toralf Förster gentoo-dev 2016-10-18 10:09:37 UTC
Created attachment 450636 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2016-10-18 10:09:40 UTC
Created attachment 450638 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2016-10-18 10:09:43 UTC
Created attachment 450640 [details]
sys-block:thin-provisioning-tools-0.6.1:20161017-221018.log
Comment 6 Alex Parker 2016-10-23 19:22:30 UTC
So do we do static_cast<bool>(v) or bool(v); what to people prefer?
Comment 7 nvinson234 2016-10-24 00:35:49 UTC
(In reply to Alex Parker from comment #6)
> So do we do static_cast<bool>(v) or bool(v); what to people prefer?

Since it's C++, I'd probably use static_cast<bool>(v) with the thought that it would help fend off any objections to using the C-style cast here.
Comment 8 Alex Parker 2016-10-25 22:55:01 UTC
Duplicate of bug #596210
Comment 9 Alex Parker 2016-10-25 22:55:49 UTC
(In reply to Alex Parker from comment #8)
> Duplicate of bug #596210

Er, I meant bug #593922
Comment 10 Toralf Förster gentoo-dev 2016-10-26 07:00:48 UTC

*** This bug has been marked as a duplicate of bug 593922 ***