Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 596310 - app-antivirus/clamav-0.99.2 USE=clamdtop with sys-libs/ncurses[tinfo] - ld: clamdtop.o: undefined reference to symbol 'halfdelay'
Summary: app-antivirus/clamav-0.99.2 USE=clamdtop with sys-libs/ncurses[tinfo] - ld: c...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Antivirus Team
URL:
Whiteboard:
Keywords:
: 608250 (view as bug list)
Depends on:
Blocks: tinfo
  Show dependency tree
 
Reported: 2016-10-06 07:18 UTC by Wolfram Schlich (RETIRED)
Modified: 2017-04-23 20:27 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,505.86 KB, text/plain)
2017-02-19 22:37 UTC, Kai Krakow
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Wolfram Schlich (RETIRED) gentoo-dev 2016-10-06 07:18:22 UTC
See bug #457530
Comment 1 Tomáš Mózes 2016-10-07 04:15:46 UTC
Can you please attach the build log?
Comment 2 Michael Palimaka (kensington) gentoo-dev 2017-02-11 08:08:57 UTC
*** Bug 608250 has been marked as a duplicate of this bug. ***
Comment 3 Kai Krakow 2017-02-19 22:37:55 UTC
Created attachment 464378 [details]
build.log

Attaching build.log of 0.99 here because my original bug report was marked as duplicate.
Comment 4 Helmut Jarausch 2017-03-15 14:51:52 UTC
Unfortunately, I am not acquainted with the autoconf business.
It sets the curseslib variable wrong - it misses -ltinfo

As a work-around one can do the following:

ebuild /usr/portage/app-antivirus/clamav/clamav-0.99.2.ebuild configure

then patch (edit) the file  
/var/tmp/portage/app-antivirus/clamav-0.99.2/work/clamav-.99.2/clamdtop/Makefile

according to
--- clamdtop/Makefile.bck	2017-03-15 12:54:58.754529748 +0100
+++ clamdtop/Makefile	2017-03-15 12:54:58.754529748 +0100
@@ -486,7 +486,7 @@
 
 AM_CFLAGS = 
 AM_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/shared -I$(top_srcdir)/libclamav    
-clamdtop_LDADD =  -lssl -lcrypto -lz -lncurses $(top_builddir)/libclamav/libclamav_internal_utils_nothreads.la
+clamdtop_LDADD =  -lssl -lcrypto -lz -lncurses -ltinfo $(top_builddir)/libclamav/libclamav_internal_utils_nothreads.la
 EXTRA_DIST = clamdtop.c
 all: all-am


Finally, run
ebuild /usr/portage/app-antivirus/clamav/clamav-0.99.2.ebuild merge
Comment 5 Jeroen Roovers gentoo-dev 2017-04-23 20:27:28 UTC
Fixed in 0.99.2-r1.