Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 595838 - net-nds/yp-tools-4.2.2: version bump
Summary: net-nds/yp-tools-4.2.2: version bump
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL: https://github.com/thkukuk/yp-tools/r...
Whiteboard:
Keywords: EBUILD
Depends on:
Blocks: 371387
  Show dependency tree
 
Reported: 2016-10-02 01:07 UTC by Ted Rodgers
Modified: 2017-07-24 15:31 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
net-nds/yp-tools-4.2.2 (yp-tools-4.2.2.ebuild,653 bytes, text/plain)
2016-10-02 01:08 UTC, Ted Rodgers
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ted Rodgers 2016-10-02 01:07:45 UTC
Submitting ebuild for current yp-tools version

Reproducible: Always

Steps to Reproduce:
1. download ebuild
2. emerge =yp-tools-4.2.2




Version bump for yp-tools with ebuild rewrite

Supports previous nls flag + adds "static" IUSE

Tested on ~amd64 and ~x86 systems but limited access to/for other archs


Bug 371387 remains open for pervious version
Comment 1 Ted Rodgers 2016-10-02 01:08:49 UTC
Created attachment 448748 [details]
net-nds/yp-tools-4.2.2
Comment 2 Pacho Ramos gentoo-dev 2016-10-08 09:53:42 UTC
are you willing to proxy maintain this?
https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers

Thanks
Comment 3 Ted Rodgers 2016-10-17 13:11:11 UTC
I could proxy maintain this for now.  Really need an updated up ypserv to match --current from portage doesn't build.
Comment 4 Matt Whitlock 2016-10-17 21:33:13 UTC
(In reply to Ted Rodgers from comment #3)
> Really need an updated up ypserv to match --current from portage doesn't build.

While I do agree that it would be really great to have a modern ypserv in Portage, as 2.26 is many years out of date, I do not concur with the assertion "current from Portage doesn't build." I am able to build net-nds/ypserv-2.26-r1 on ~amd64 with GCC 5.4.0 just fine.
Comment 5 Ted Rodgers 2016-10-18 05:45:55 UTC
Concur current from portage builds.  Must have been a problem that new install on my build box fixed.

>>> Source compiled.
>>> net-nds/ypserv-2.26-r1 merged.
Comment 6 Pacho Ramos gentoo-dev 2016-10-18 18:06:25 UTC
CCing proxy maint people
Comment 7 Pacho Ramos gentoo-dev 2017-07-19 08:29:45 UTC
[master 3810c4ac9d8] net-nds/yp-tools: Version bump
 2 files changed, 32 insertions(+)
 create mode 100644 net-nds/yp-tools/yp-tools-4.2.2.ebuild
Comment 8 peteru 2017-07-23 17:59:28 UTC
This change completely breaks any existing Gentoo installation that runs a complete NIS setup.

The problem is that both ypserv and ypbind in portage are too old to work correctly with the updated yp-tools package.

For example:

> # ypwhich
> Error: unsupported version (-1) from ypbind on 'localhost'

A workaround would be to specify version 2:

> # ypwhich -V2
> localhost

But even this type of kludge still requires changes to the init.d script in net-nds/ypbind

I suggest that either all NIS packages (yp-tools, ypbind and ypserv) are all updated at the same time or the new (and incomaptible) yp-tools is masked for the time being.
Comment 9 Pacho Ramos gentoo-dev 2017-07-24 09:17:08 UTC
Open bug reports asking to bump that packages then
Comment 10 peteru 2017-07-24 15:31:46 UTC
Done.

I hope bugs #626050 and #626052 are sufficient for this purpose.