Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 59528 - root cannot attach strace to Postfix master process
Summary: root cannot attach strace to Postfix master process
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High critical (vote)
Assignee: Net-Mail Packages
Depends on:
Reported: 2004-08-05 08:44 UTC by Davin Boling
Modified: 2004-08-10 07:39 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Davin Boling 2004-08-05 08:44:07 UTC
Attempts to attach the Postfix master process to the strace debugger fail and leave the master process in a non-working state. One must then individually kill all Postfix processes before restarting it.

Reproducible: Always
Steps to Reproduce:
1. Start postfix.
2. Determine pid of the "master" process.
3. strace -p masterpid

Actual Results:  
'strace -p 14234' results in the following:
Process 14234 attached - interrupt to quit
trace: ptrace(PTRACE_SYSCALL, ...): Operation not permitted
detach: ptrace(PTRACE_DETACH, ...): Operation not permitted
Process 14234 detached

Expected Results:  
strace should connect to the process and begin to print debugging output to the

Comment 1 Tuan Van (RETIRED) gentoo-dev 2004-08-05 09:23:01 UTC
have you tried to run this as root? I don't have any problem running `strace -p $(pidof master)`. BTW, I don't have a stable system.
Comment 2 Davin Boling 2004-08-05 09:55:32 UTC
I was running it as root - but su root. To make sure su wasn't the problem, I just logged into the terminal directly as root and tried again. Same problem.

This is, for certain, being run as root.
Comment 3 Tim Yamin (RETIRED) gentoo-dev 2004-08-05 12:05:56 UTC
What kernel are you running and are you using any security enhancement patches such as GRSecurity, SELinux, etc...?
Comment 4 Davin Boling 2004-08-06 10:10:29 UTC
root # cat /proc/version
Linux version 2.4.20-gentoo-r6 ( (gcc version 3.2.3 20030422 (Gentoo Linux 1.4 3.2.3-r1, propolice)) #1 SMP Fri Sep 12 12:51:27 EDT 2003
Comment 5 Tim Yamin (RETIRED) gentoo-dev 2004-08-06 10:52:16 UTC
Can you please try gentoo-sources-2.4.26?
Comment 6 Davin Boling 2004-08-10 07:39:57 UTC
I've confirmed that this problem stems from not having recent enough kernel sources. All people experiencing this problem should update their kernel sources to a more recent version.