Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 595090 - media-sound/mixxx-2.0.0-r1 fails to compile with gcc-6.2.0 - /usr/lib/gcc/x86_64-pc-linux-gnu/6.2.0/include/g++-v6/math.h:63:11: error: ‘std::util_fpclassify’ has not been declared
Summary: media-sound/mixxx-2.0.0-r1 fails to compile with gcc-6.2.0 - /usr/lib/gcc/x86...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Professional Audio Applications Maintainers
URL:
Whiteboard:
Keywords: PATCH
Depends on:
Blocks: gcc-6
  Show dependency tree
 
Reported: 2016-09-25 11:31 UTC by jospezial
Modified: 2017-05-06 22:51 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
mixxx-2.0.0-r1 fix compilation with gcc-6.2 patch (include_cmath_math.h_for_gcc-6.2.patch,726 bytes, patch)
2016-09-25 11:33 UTC, jospezial
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description jospezial 2016-09-25 11:31:27 UTC
Upstream fix:
https://github.com/mixxxdj/mixxx/pull/957


In file included from src/effects/native/reverb/basics.h:42:0,
                 from src/effects/native/reverb/Reverb.h:52,
                 from src/effects/native/reverbeffect.h:13,
                 from src/effects/native/nativebackend.cpp:13:
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.0/include/g++-v6/math.h:63:11: error: ‘std::util_fpclassify’ has not been declared
 using std::fpclassify;
           ^~~~~~~~~~~~   
In file included from src/effects/native/reverb/basics.h:42:0,
                 from src/effects/native/reverb/Reverb.h:52,
                 from src/effects/native/reverbeffect.h:13,
                 from src/effects/native/nativebackend.cpp:13:
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.0/include/g++-v6/math.h:64:11: error: ‘std::util_isfinite’ has not been declared
 using std::isfinite;
           ^~~~~~~~~~   
In file included from src/effects/native/reverb/basics.h:42:0,
                 from src/effects/native/reverb/Reverb.h:52,
                 from src/effects/native/reverbeffect.h:13,
                 from src/effects/native/nativebackend.cpp:13:
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.0/include/g++-v6/math.h:65:11: error: ‘std::util_isinf’ has not been declared
 using std::isinf;
           ^~~~~~~   
In file included from src/effects/native/reverb/basics.h:42:0,
                 from src/effects/native/reverb/Reverb.h:52,
                 from src/effects/native/reverbeffect.h:13,
                 from src/effects/native/nativebackend.cpp:13:
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.0/include/g++-v6/math.h:66:11: error: ‘std::util_isnan’ has not been declared
 using std::isnan;
           ^~~~~~~   
In file included from src/effects/native/reverb/basics.h:42:0,
                 from src/effects/native/reverb/Reverb.h:52,
                 from src/effects/native/reverbeffect.h:13,
                 from src/effects/native/nativebackend.cpp:13:
/usr/lib/gcc/x86_64-pc-linux-gnu/6.2.0/include/g++-v6/math.h:67:11: error: ‘std::util_isnormal’ has not been declared
 using std::isnormal;
           ^~~~~~~~~~   
scons: *** [lin64_build/effects/native/nativebackend.o] Error 1
scons: building terminated because of errors.
 * ERROR: media-sound/mixxx-2.0.0-r1::gentoo failed (compile phase):
 *   escons failed.
 * 
 * Call stack:
 *     ebuild.sh, line  115:  Called src_compile
 *   environment, line 2230:  Called escons 'prefix=/usr' 'qtdir=/usr/lib64/qt5' 'faad=1' 'ffmpeg=1' 'hid=1' 'hifieq=1' 'm4a=1' 'mad=1' 'optimize=native' 'qdebug=0' 'qt5=1' 'shoutcast=1' 'vinylcontrol=1' 'wv=1'
 *   environment, line 1069:  Called die
 * The specific snippet of code:
 *                   die -n "escons failed."
 * 


=================================================================
                        Package Settings
=================================================================

sys-devel/gcc-6.2.0-r1::gentoo was built with the following:
USE="cxx fortran graphite (multilib) nls nptl openmp pch sanitize vtv (-altivec) (-awt) -cilk -debug -doc (-fixed-point) -gcj -go (-hardened) (-jit) (-libssp) -mpx -objc -objc++ -objc-gc (-pie) -regression-test -ssp -vanilla" ABI_X86="64"
Comment 1 jospezial 2016-09-25 11:33:33 UTC
Created attachment 447838 [details, diff]
mixxx-2.0.0-r1 fix compilation with gcc-6.2 patch
Comment 2 Lars Wendler (Polynomial-C) gentoo-dev 2017-05-06 22:51:26 UTC
commit 13cb9bf35c722ff7207da51ecdd16d24df710aab (HEAD -> master, origin/master, origin/HEAD)
Author: Lars Wendler <polynomial-c@gentoo.org>
Date:   Sun May 7 00:50:37 2017

    media-sound/mixxx: Revbump to fix compilation with gcc-6 (bug #595090).
    
    This revbump also comes with a couple of fixes backported and provided
    by David Guglielmi (sunny-overlay) in bug #608430.
    
    Package-Manager: Portage-2.3.5, Repoman-2.3.2