Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 594760 - x11-misc/sddm.0.13.0-r3 - black screen after start
Summary: x11-misc/sddm.0.13.0-r3 - black screen after start
Status: RESOLVED DUPLICATE of bug 584960
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: LxQt maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-09-22 11:42 UTC by Yu Tzu Wu
Modified: 2017-10-21 19:51 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
/var/log/sddm.log (file_594760.txt,81.07 KB, text/plain)
2016-09-22 11:42 UTC, Yu Tzu Wu
Details
/etc/sddm.conf (file_594760.txt,2.04 KB, text/plain)
2016-09-22 17:00 UTC, Yu Tzu Wu
Details
/etc/conf.d/xdm (file_594760.txt,573 bytes, text/plain)
2016-09-22 17:02 UTC, Yu Tzu Wu
Details
/etc/X11/xorg.conf (file_594760.txt,377 bytes, text/plain)
2016-09-22 17:06 UTC, Yu Tzu Wu
Details
sddm.log (sddm.log,1.56 KB, text/x-log)
2016-10-31 02:18 UTC, Peter Kunze
Details
xorg log file (Xorg.0.log,19.66 KB, text/x-log)
2016-10-31 02:19 UTC, Peter Kunze
Details
emerge --info (emerge-info.txt,5.69 KB, text/plain)
2016-10-31 02:20 UTC, Peter Kunze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yu Tzu Wu 2016-09-22 11:42:32 UTC
Created attachment 447312 [details]
/var/log/sddm.log

When /etc/init.d/xdm start, I got a black screen on VT7.
There is no error in /var/log/Xorg.0.log but some in /var/log/sddm.log.
Comment 1 Yu Tzu Wu 2016-09-22 17:00:59 UTC
Created attachment 447348 [details]
/etc/sddm.conf
Comment 2 Yu Tzu Wu 2016-09-22 17:02:00 UTC
Created attachment 447368 [details]
/etc/conf.d/xdm
Comment 3 Yu Tzu Wu 2016-09-22 17:06:35 UTC
Created attachment 447444 [details]
/etc/X11/xorg.conf
Comment 4 Michael Palimaka (kensington) gentoo-dev 2016-10-29 14:07:11 UTC
Did it work previously? Can you try 0.14.0-r1 and see if it helps?
Comment 5 Peter Kunze 2016-10-31 02:15:18 UTC
I am facing the same problem. 

sddm worked fine before an system update (emerge -NDu world).
After the update I got a blank screen when starting xdm.

startx launches twm and works fine. So, it is not graphics card or xorg related.
No log file contains an error message. What I noticed in sddm log is that after after "Message received from greeter: Connect" a second later PAM closes the session and the greeter stops.

I use sddm-0.14.0-r1
Comment 6 Peter Kunze 2016-10-31 02:18:28 UTC
Created attachment 451949 [details]
sddm.log
Comment 7 Peter Kunze 2016-10-31 02:19:19 UTC
Created attachment 451951 [details]
xorg log file
Comment 8 Peter Kunze 2016-10-31 02:20:38 UTC
Created attachment 451953 [details]
emerge --info
Comment 9 Dennis Schridde 2017-05-13 20:39:39 UTC
Duplicate of bug #584960 ?
Comment 10 Yu Tzu Wu 2017-05-13 20:50:42 UTC
(In reply to Dennis Schridde from comment #9)
> Duplicate of bug #584960 ?

Yes. The same.
Comment 11 Andreas Sturmlechner gentoo-dev 2017-10-21 19:51:06 UTC

*** This bug has been marked as a duplicate of bug 584960 ***