Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 594716 - sys-devel/autoconf-2.13 - respect EPREFIX
Summary: sys-devel/autoconf-2.13 - respect EPREFIX
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-09-21 18:35 UTC by Martin Mokrejš
Modified: 2019-09-09 06:07 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Mokrejš 2016-09-21 18:35:55 UTC
>>> Completed installing autoconf-2.13 into /scratch/mmokrejs/gentoo_rap/var/tmp/portage/sys-devel/autoconf-2.13/image/

 * Final size of build directory: 1092 KiB
 * Final size of installed tree: 61 KiB

 * QA Notice: the following files are outside of the prefix:
 * /usr
 * /usr/bin
 * /usr/bin/autoscan-2.13
 * /usr/bin/ifnames-2.13
 * /usr/bin/autoheader-2.13
 * /usr/bin/autoreconf-2.13
 * /usr/bin/autoconf-2.13
 * /usr/bin/autoupdate-2.13
 * ERROR: sys-devel/autoconf-2.13::gentoo failed:
 *   Aborting due to QA concerns: there are files installed outside the prefix
 * 
 * Call stack:
 *   misc-functions.sh, line 603:  Called install_qa_check
 *   misc-functions.sh, line 217:  Called source 'install_symlink_html_docs'
 *            05prefix, line 114:  Called install_qa_check_prefix
 *            05prefix, line  27:  Called die
 * The specific snippet of code:
 *                      die "Aborting due to QA concerns: there are files installed outside the prefix"
 * 
 * If you need support, post the output of `emerge --info '=sys-devel/autoconf-2.13::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=sys-devel/autoconf-2.13::gentoo'`.
 * The complete build log is located at '/scratch/mmokrejs/gentoo_rap/var/tmp/portage/sys-devel/autoconf-2.13/temp/build.log'.
 * The ebuild environment file is located at '/scratch/mmokrejs/gentoo_rap/var/tmp/portage/sys-devel/autoconf-2.13/temp/environment'.
 * Working directory: '/scratch/mmokrejs/gentoo_rap/var/tmp/portage/sys-devel/autoconf-2.13/image/scratch/mmokrejs/gentoo_rap'
 * S: '/scratch/mmokrejs/gentoo_rap/var/tmp/portage/sys-devel/autoconf-2.13/work/autoconf-2.13'
Comment 1 Jan B. 2019-09-09 01:01:58 UTC
I can't reproduce this issue on prefix.
This was probably already fixed by

https://gitweb.gentoo.org/repo/gentoo.git/commit/sys-devel/autoconf?id=ffcd38e7d281a84821df62a23b4b30ea729db200

commit ffcd38e7d281a84821df62a23b4b30ea729db200
Author: Benda Xu <heroxbd@gentoo.org>
Date:   Tue Oct 25 10:05:30 2016 +0900

    sys-devel/autoconf: trivial Prefix update.
    
    Package-Manager: portage-2.3.0
Comment 2 Fabian Groffen gentoo-dev 2019-09-09 06:07:19 UTC
yep, that's very likely, thanks!