Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 59434 - GL with nvidia drivers refuse to work after some period of time
Summary: GL with nvidia drivers refuse to work after some period of time
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: x86 Linux
: High critical (vote)
Assignee: Gentoo X packagers
Depends on:
Reported: 2004-08-04 11:46 UTC by Jurek Bartuszek (RETIRED)
Modified: 2004-08-13 14:50 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Jurek Bartuszek (RETIRED) gentoo-dev 2004-08-04 11:46:21 UTC
After doing opengl-update nvidia and then some period of time, GL refuses to work. I suspect connection with updatedb executed every 24 hours at night. Running opengl-update nvidia again is kinda workaround, but this is very annoying. Oh - and I've noticed that after emerging some stuff I have to run opengl-update nvidia  in order to make things work.

Reproducible: Always
Steps to Reproduce:
1. Run opengl-update
2. Go to sleep in the evening
3. Wake up in the morning and try to run anything w/ GL

Actual Results:  
Applications that use GL crash.

Portage 2.0.50-r9 (default-x86-2004.2, gcc-3.3.3, glibc-, 2.6.7
System uname: 2.6.7-gentoo-r11 i686 Intel(R) Pentium(R) 4 CPU 3.40GHz
Gentoo Base System version 1.4.16
ccache version 2.3 [enabled]
Autoconf: sys-devel/autoconf-2.59-r4
Automake: sys-devel/automake-1.8.3
CFLAGS="-Os -march=pentium4 -pipe"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.2
/share/config /usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/
config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/shar
e/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf
/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-Os -march=pentium4 -pipe"
FEATURES="autoaddcvs ccache sandbox"
USE="3dnow X aalib acpi acpi4linux alsa arts audiofile autofs avi berkdb bidi cd
r crypt cups devfs dga divx4linux doc dvb dvd dvdr encode escreen esd fbcon flac
 flash foomaticdb gdbm gif gimpprint gpm gtk gtk2 imlib ipv6 java jpeg kadu-modu
les kadu-voice kde libg++ libwww linguas_pl lirc mad md5sum mikmod mmx motif moz
illa mpeg ncurses nls oggvorbis opengl oss pam pcmcia pda pdflib perl png pnp pp
ds python qt quicktime readline ruby samba sdl slang spell sse ssl svga tcltk tc
pd tetex tiff truetype type1 usb videos vim-with-x wxwindows x86 xml xml2 xmms x
v xvid zlib"
Comment 1 Jurek Bartuszek (RETIRED) gentoo-dev 2004-08-04 13:20:17 UTC
Oh. One more thing to say: I use xorg-x11-6.7.0-r2
Comment 2 Jonathan Heaney 2004-08-04 17:24:52 UTC
Getting the same issue here.  Started with the new 6106 nvidia drivers.  X periodically 'forgets' the nvidia drivers leading to GL app segfaults, e.g. glxinfo segfaults, GL xscreensavers sigsegv.  I also noticed xscreensaver doesn't compile the GL hacks if the system is in the 'fail' state.

'opengl-update nvidia' _usually_ fixes the problem, but sometimes restarting X is also required.

There might be something in the updatedb theory but I've found this problem hard to characterise.



emerge info
Portage 2.0.50-r9 (default-x86-2004.2, gcc-3.3.4, glibc-, 2.6.8-rc3-alsa)
System uname: 2.6.8-rc3-alsa i686 AMD Athlon(tm) XP 3200+
Gentoo Base System version 1.5.2
Autoconf: sys-devel/autoconf-2.59-r4
Automake: sys-devel/automake-1.8.5-r1
CFLAGS="-march=athlon-xp -mcpu=athlon-xp -O2 -fomit-frame-pointer -fprefetch-loop-arrays -ftracer -pipe"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.3/share/config /usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=athlon-xp -mcpu=athlon-xp -O2 -fomit-frame-pointer -fprefetch-loop-arrays -ftracer -pipe"
FEATURES="autoaddcvs ccache sandbox"
USE="3dnow X aalib acpi alsa avi berkdb cdr crypt cups dga divx4linux dvd encode esd flac foomaticdb gdbm gif gnome gpm gtk gtk2 imlib joystick jpeg libg++ libwww linguas_en_GB mad mikmod mmx motif mozilla mpeg ncurses nls nptl oggvorbis opengl oss pam pdflib perl png ppds python quicktime readline sdl slang spell sse ssl svga tcpd theora tiff truetype unicode usb x86 xml2 xmms xv xvid zlib"
Comment 3 Andrew Bevitt 2004-08-05 18:05:29 UTC
Please test this with 6111 which just went into cvs.

Report back on success or failures.

Comment 4 Jonathan Heaney 2004-08-06 05:41:40 UTC
OK upgraded to 6111.  Doesn't initially look promising-

Reboot system after upgrade, log in, run glxinfo -> segfaults.

opengl-update nvidia, run glxinfo -> get lots of 'Xlib:  extension "GLX" missing on display ":0.0".' errors and a segmentation fault.

re-starts X, works OK.

This is basically the behaviour with the previous drivers.  I'll leave the box up and running now, but I'd expect this to go into the fail state at some point within the next 24 hours.

I've also got Debian unstable on this box using the same (well, 6106) drivers installed using the normal nvidia installer, and no problems on it.  Major differences between Gentoo/Debian are xorg-x11 on Gentoo vs. XFree on Debian, plus I use udev on Gentoo.  Kernels are the same.

Also completed an emerge -e world a couple of days ago to see if that fixed the problem but obviously it didn't.
Comment 5 Andrew Bevitt 2004-08-06 06:04:51 UTC
I have xorg-x11, 6111, udev on amd64 and also dual booting to a native x86 environment with the same settings and honestly I cannot get this to happen...

If you are getting GLX not available errors it probably means you need to upgrade your nvidia-glx version aswell, or that something iffy is happening in the load of GLX itself -- check your xorg log and see if glx loads properly.
Comment 6 Jonathan Heaney 2004-08-06 06:54:06 UTC
I've just gone into /var/log to have a look at my X log, and I noticed nvidia-installer.log dated April 23, which shouldn't be there as I don't recall ever installing the nvidia drivers with anything other than the ebuild in the ~2 years I've been using Gentoo, but it's there anyway.  I probably did it when I was drunk and an updated ebuild was not forthcoming.

I wonder if maybe there is some 'residual' files left over from this.  Is there any way I can check - I seem to recall this being mentioned in some forum somewhere, and a neat grep line (I'm no expert w/ grep) that checked for downlevel versions.

As for the actual X log itself, I'm pretty sure that there is an error when X loads in the 'fail' state, so I'll grab that the next time it happens, assuming my system still has the problem.  The log looks normal otherwise.
Comment 7 Jonathan Heaney 2004-08-06 07:37:19 UTC
Further to that last post

cd /usr
find . -name *5341*

I wonder if there is any other cruft lying around?  I've deleted those files anyway.
Comment 8 Jonathan Heaney 2004-08-06 07:46:13 UTC
Again, further to that, in 


There are now two dangling symlinks: -> ->

After deleting the file

I've deleted those and re-emerged nvidia-glx.
Comment 9 Jonathan Heaney 2004-08-07 17:32:36 UTC
Just an update, that's a couple of days after the 'cleanup' and I've not had a repeat of the problems.  So (touch wood) it looks like that's fixed it for me.

Jurek, have you tried this on your own system, and if so, how did you get on?  Still got the problem?
Comment 10 Jurek Bartuszek (RETIRED) gentoo-dev 2004-08-08 04:49:33 UTC
Well, unfortunately ( ;-D ) I'm on vacation now, so I am unable to follow the steps you've taken, Jonathan, but as soon as I'm back home I'll check it out. I'm planning my return on Tuesday/Wednesday, so I'll post the results then.
Comment 11 ben 2004-08-10 05:40:01 UTC
I have a similar problem, maybe: running glxinfo results in a segfault after a long list of "Xlib:  extension GLX missing on display 0.0" messages.  There's an error in my Xorg.0.log saying it failed to load GLX.  I'm already using 6111.  

I get periodic X crashes or kernel panics, too.
Comment 12 Jonathan Heaney 2004-08-10 06:23:15 UTC

Did you try searching through your system for older files from previous driver revs. that might still be there?

Check for a file /var/log/nvidia-installer.log - if that exists, there are most likely downlevel drivers still kicking about somewhere.

Your X crashes _might_ be related to this, but I doubt the kernel panics are (what kernel are you running?)
Comment 13 Jurek Bartuszek (RETIRED) gentoo-dev 2004-08-11 14:32:03 UTC
Well, I've removed some *5336 stuff... I'll perform some tests and then let you know ;-)
Comment 14 Jurek Bartuszek (RETIRED) gentoo-dev 2004-08-12 04:11:13 UTC
Yeah, updated to 6111, removed the trash that was remaining after 5336 drivers and now everything is working perfectly :-)

Therefore, I am closing this bug.
Comment 15 Jurek Bartuszek (RETIRED) gentoo-dev 2004-08-12 04:14:13 UTC
I've decided to leave this as resolved fixed in case anyone had any problems regarding this bug.
Comment 16 Jurek Bartuszek (RETIRED) gentoo-dev 2004-08-13 14:50:35 UTC
Closing bug