Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 59422 - Warnings trying to exclude devfs from the kernel
Summary: Warnings trying to exclude devfs from the kernel
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: (DEPRECATED)
Depends on:
Reported: 2004-08-04 10:41 UTC by Adam
Modified: 2004-08-20 11:05 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Adam 2004-08-04 10:41:03 UTC
I tried to exclude devfs from the kernel by unchecking the "/dev file system support" option, because I recently installed udev and want to switch to it.  When trying to build the kernel afterwards, the following bunch of warnings appeared:

WARNING: /lib/modules/2.6.5-gentoo-r1/misc/svgalib_helper.ko needs unknown symbol devfs_mk_dir
WARNING: /lib/modules/2.6.5-gentoo-r1/misc/svgalib_helper.ko needs unknown symbol devfs_mk_cdev
WARNING: /lib/modules/2.6.5-gentoo-r1/misc/svgalib_helper.ko needs unknown symbol devfs_mk_symlink
WARNING: /lib/modules/2.6.5-gentoo-r1/misc/svgalib_helper.ko needs unknown symbol devfs_remove
WARNING: /lib/modules/2.6.5-gentoo-r1/video/nvidia.ko needs unknown symbol devfs_mk_cdev
WARNING: /lib/modules/2.6.5-gentoo-r1/video/nvidia.ko needs unknown symbol devfs_remove

The filenames and the emerge info as well as the heading when I go into "make menuconfig" seem to suggest that I'm using a 2.6.5 kernel, so I believe that's my kernel version.  But for some reason my version of "gentoo-dev-sources" is 2.6.7-r11.  I don't know why it isn't switching, but that's another issue.

Reproducible: Always
Steps to Reproduce:
1.Install udev
2.Start "make menuconfig"
3.Deselect the devfs option
4.Build the kernel

Actual Results:  
The above warnings were printed.

Expected Results:  
No warnings printed.

root>emerge info
Portage 2.0.50-r9 (default-x86-2004.0, gcc-3.3.3, glibc-,
System uname: 2.6.5-gentoo-r1 i686 AMD Athlon(tm) XP 2500+
Gentoo Base System version 1.4.16
Autoconf: sys-devel/autoconf-2.59-r4
Automake: sys-devel/automake-1.8.3
CFLAGS="-O2 -march=athlon-xp -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3.2/share/config /usr/kde/3/share/config /usr/lib/mozilla/defaults/pref
/usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=athlon-xp -fomit-frame-pointer"
FEATURES="autoaddcvs ccache sandbox sfperms strict userpriv usersandbox"
USE="X alsa apm arts avi berkdb cdr crypt cups dvd encode foomaticdb gdbm gif
gpm gtk2 imlib java jpeg kde libg++ libwww mad mikmod motif mozilla mpeg mysql
ncurses nls oggvorbis opengl pam pdflib perl png ppds python qt quicktime
readline scanner sdl slang spell ssl svga tcpd truetype usb x86 xml2 xmms xprint
xv zlib"
Comment 1 Adam 2004-08-20 11:05:48 UTC
I tried removing devfs from the kernel in version 2.6.8 now, and the svgalib_helper.ko warnings went away; only the nvidia.ko warnings remained.  Since I believe nvidia is a closed source driver, I guess there's nothing you guys can do about it if it requires devfs to be in the kernel (I can use nvidia without starting devfs, though).  So I'm changing this bug to CANTFIX.