Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 593348 - dev-perl/Lchown-1.10.0-r1 : * ERROR: dev-perl/Lchown-1.10.0-r1::gentoo failed (configure phase):
Summary: dev-perl/Lchown-1.10.0-r1 : * ERROR: dev-perl/Lchown-1.10.0-r1::gentoo faile...
Status: RESOLVED DUPLICATE of bug 41124
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Perl team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-09-10 07:31 UTC by Toralf Förster
Modified: 2016-09-10 07:43 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
dev-perl:Lchown-1.10.0-r1:20160909-230216.log (dev-perl:Lchown-1.10.0-r1:20160909-230216.log,2.17 KB, text/plain)
2016-09-10 07:31 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,24.91 KB, text/plain)
2016-09-10 07:31 UTC, Toralf Förster
Details
environment (environment,100.41 KB, text/plain)
2016-09-10 07:31 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2016-09-10 07:31:15 UTC
Can't locate Module/Build.pm in @INC (you may need to install the Module::Build module) (@INC contains: /etc/perl /usr/local/lib64/perl5/5.24.0/x86_64-linux /usr/local/lib64/perl5/5.24.0 /usr/lib64/perl5/vendor_perl/5.24.0/x86_64-linux /usr/lib64/perl5/vendor_perl/5.24.0 /usr/lib64/perl5/5.24.0/x86_64-linux /usr/lib64/perl5/5.24.0 .) at Build.PL line 3.
BEGIN failed--compilation aborted at Build.PL line 3.
 * ERROR: dev-perl/Lchown-1.10.0-r1::gentoo failed (configure phase):
 *   Unable to build!
 * 
 * Call stack:


$ cat emerge-info.txt
  -----------------------------------------------------------------

  This is an unstable amd64 chroot image (named amd64-plasma-unstable_20160909-101903) at a hardened host acting as a tinderbox.

  -----------------------------------------------------------------
  USE flags ...

  ... in make.conf:
USE="  pax_kernel xtpax -cdinstall -oci8 -bindist alisp alsa avformat bzip2 -cairo cdda cddb cups drmkms dvd evdev ffmpeg gif glamor gpg gstreamer gtk2 haptic hdf5 hpn infinality ipv6 jpeg kvm llvm minimal mp4 mpg123 -nls nss odbc -openssl opus -pam php pkcs11 plasma postscript printsupport pulseaudio python qt3support sasl sddm sdl smartcard sourceview spice sql sqlite sqlite3 ssh-askpass ssl sslv2 svg system-ffmpeg system-libevent system-llvm system-sqlite tcpd tracepath truetype -udisks usb utils v4l2 -video vim vorbis wav xcb -xscreensaver xvfb zip"

  ... in /etc/portage/package.use/*:
  mail-mta/ssmtp      ssl mta
  net-misc/wget       ssl
  app-editors/emacs   -dbus -svg -ssl -gtk -gtk3
  app-text/xmlto      -latex
  dev-libs/boehm-gc   threads
  dev-libs/libpcre    pcre16
  dev-util/cmake      -qt4 -qt5
  dev-vcs/git         -perl
  gnome-base/librsvg  -tools
  media-libs/mesa     -vaapi
  <=net-misc/openssh-7.3_p1-r2    -hpn
  net-misc/iputils -caps -filecaps

  entries in /etc/portage/package.unmask/*:
  media-video/ffmpeg
  -----------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-4.9.3
 [2] x86_64-pc-linux-gnu-5.4.0 *

Available Python interpreters, in order of preference:
  [1]   python3.4
  [2]   python2.7 (fallback)

  -----------------------------------------------------------------

Portage 2.2.28 (python 3.4.5-final-0, default/linux/amd64/13.0/desktop/plasma, gcc-5.4.0, glibc-2.23-r2, 4.7.3-hardened x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.7.3-hardened-x86_64-Intel-R-_Core-TM-_i7-3930K_CPU_@_3.20GHz-with-gentoo-2.3
KiB Mem:    65285352 total,   3267904 free
KiB Swap:   67108860 total,  67108860 free
Timestamp of repository gentoo: Fri, 09 Sep 2016 22:06:11 +0000
sh bash 4.3_p46
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.3_p46::gentoo
dev-lang/perl:            5.24.0-r1::gentoo
dev-lang/python:          2.7.12::gentoo, 3.4.5::gentoo
dev-util/cmake:           3.6.2::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/openrc:          0.21.7::gentoo
sys-apps/sandbox:         2.10-r1::gentoo
sys-devel/autoconf:       2.69-r2::gentoo
sys-devel/automake:       1.13.4-r1::gentoo, 1.14.1-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo, 2.26.1::gentoo
sys-devel/gcc:            4.9.3::gentoo, 5.4.0::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r2::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.7::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r2::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: 1

local
    location: /usr/local/portage
    masters: gentoo
    priority: 2

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/var/tmp/distfiles"
EMERGE_DEFAULT_OPTS="--verbose --verbose-conflicts --color=n --nospinner --tree --quiet-build"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync network-sandbox parallel-fetch preserve-libs protect-owned sandbox sfperms strict test-fail-continue unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.uni-erlangen.de/pub/mirrors/gentoo rsync://mirror.netcologne.de/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gor.bytemark.co.uk/gentoo/ rsync://ftp.snt.utwente.nl/gentoo"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alisp alsa amd64 avformat berkdb bluetooth branding bzip2 cdda cddb cdr cli consolekit cracklib crypt cups cxx dbus declarative dri drmkms dts dvd dvdr emboss encode evdev exif fam ffmpeg firefox flac fortran gdbm gif glamor gpg gpm gstreamer gtk gtk2 haptic hdf5 hpn iconv infinality ipv6 jpeg kde kipi kvm lcms ldap libnotify llvm mad minimal mmx mmxext mng modules mp3 mp4 mpeg mpg123 multilib ncurses nptl nss odbc ogg opengl openmp opus pango pax_kernel pcre pdf phonon php pkcs11 plasma png policykit postscript ppds printsupport pulseaudio python qml qt3support qt4 qt5 readline sasl sddm sdl seccomp semantic-desktop session smartcard sourceview spell spice sql sqlite sqlite3 sse sse2 ssh-askpass ssl sslv2 startup-notification svg system-ffmpeg system-libevent system-llvm system-sqlite tcpd tiff tracepath truetype udev unicode upower usb utils v4l2 vim vorbis wav widgets wxwidgets x264 xattr xcb xcomposite xinerama xml xtpax xv xvfb xvid zip zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" L10N="en es-MX et ga hne ur-PK" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="amdgpu fbdev intel nouveau radeon radeonsi vesa dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Toralf Förster gentoo-dev 2016-09-10 07:31:18 UTC
Created attachment 445358 [details]
dev-perl:Lchown-1.10.0-r1:20160909-230216.log
Comment 2 Toralf Förster gentoo-dev 2016-09-10 07:31:21 UTC
Created attachment 445360 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2016-09-10 07:31:23 UTC
Created attachment 445362 [details]
environment
Comment 4 Kent Fredric (IRC: kent\n) gentoo-dev 2016-09-10 07:39:04 UTC
dev-perl/Lchown depends on Module-Build, so this is yet-another-case of portage refusing to schedule slot rebuilds soon enough.
Comment 5 Toralf Förster gentoo-dev 2016-09-10 07:43:45 UTC
(In reply to Kent Fredric (IRC: kent\n) from comment #4)
Indeed, at that tinderbox image were a lot more other perl failures tonight - I  stopped that image and will spin up a new one.

*** This bug has been marked as a duplicate of bug 41124 ***