Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 592554 - sys-fs/lxcfs-2.0.2 : make[2]: *** [Makefile:1239: lxcfs.1] Error 2
Summary: sys-fs/lxcfs-2.0.2 : make[2]: *** [Makefile:1239: lxcfs.1] Error 2
Status: RESOLVED DUPLICATE of bug 592880
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Erik Mackdanz
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-08-31 08:37 UTC by Toralf Förster
Modified: 2016-09-04 16:11 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-history.txt (emerge-history.txt,109.84 KB, text/plain)
2016-08-31 08:37 UTC, Toralf Förster
Details
environment (environment,90.11 KB, text/plain)
2016-08-31 08:38 UTC, Toralf Förster
Details
sys-fs:lxcfs-2.0.2:20160831-083444.log (sys-fs:lxcfs-2.0.2:20160831-083444.log,16.98 KB, text/plain)
2016-08-31 08:38 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2016-08-31 08:37:57 UTC
Can't locate Locale/gettext.pm in @INC (you may need to install the Locale::gettext module) (@INC contains: /etc/perl /usr/local/lib64/perl5/5.24.0/x86_64-linux-thread-multi /usr/local/lib64/perl5/5.24.0 /usr/lib64/perl5/vendor_perl/5.24.0/x86_64-linux-thread-multi /usr/lib64/perl5/vendor_perl/5.24.0 /usr/lib64/perl5/5.24.0/x86_64-linux-thread-multi /usr/lib64/perl5/5.24.0 .) at /usr/bin/help2man 
BEGIN failed--compilation aborted at /usr/bin/help2man line 29.
make[2]: *** [Makefile:1239: lxcfs.1] Error 2
make[2]: Leaving directory '/var/tmp/portage/sys-fs/lxcfs-2.0.2/work/lxcfs-2.0.2'


$ cat emerge-info.txt
  -----------------------------------------------------------------

  This is an unstable amd64 chroot image (named amd64-plasma-systemd-unstable_20160829-163430) at a hardened host acting as a tinderbox.

  -----------------------------------------------------------------
  USE flags defined in ...

  ... make.conf:
USE="  pax_kernel xtpax -cdinstall -oci8 -bindist avformat cdda cddb cgi cups declarative evdev exif fontconfig fortran freetds gnome-keyring gtk gtk2 gudev havege hdf5 icu imap imlib infinality ithreads javaxml lapack latex ldap libvirtd midi mp3 mp4 mpeg -mpi mysql -networking openexr png postgres -postproc pulseaudio -python qemu -qt4 -qt5 smpeg sockets -tcpd threads usb vaapi video vlc wayland -webstart widgets xinerama xscreensaver xslt ziffy"

  ... /etc/portage/package.use/*:
  mail-mta/ssmtp    ssl mta
  net-misc/wget     ssl
  app-editors/emacs   -dbus -svg -ssl -gtk -gtk3
  dev-libs/boehm-gc   threads
  dev-libs/libpcre    pcre16
  dev-util/cmake      -qt4 -qt5
  gnome-base/librsvg  -tools
  media-libs/mesa     -vaapi
  >=sys-auth/polkit-qt-0.112.0-r1 qt5

  unmasked packages in /etc/portage/package.unmask/*:

  -----------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-4.9.3
 [2] x86_64-pc-linux-gnu-5.4.0 *
Available Java Virtual Machines:
  [1]   icedtea-bin-8  system-vm
Available Python interpreters, in order of preference:
  [1]   python3.4
  [2]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby20 (with Rubygems)
  [2]   ruby21 (with Rubygems) *
  -----------------------------------------------------------------

Portage 2.2.28 (python 3.4.5-final-0, default/linux/amd64/13.0/desktop/plasma/systemd, gcc-5.4.0, glibc-2.23-r2, 4.7.2-hardened x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.7.2-hardened-x86_64-Intel-R-_Core-TM-_i7-3930K_CPU_@_3.20GHz-with-gentoo-2.2
KiB Mem:    65285352 total,   2154764 free
KiB Swap:   67108860 total,  67108860 free
Timestamp of repository gentoo: Wed, 31 Aug 2016 06:05:21 +0000
sh bash 4.3_p46
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.3_p46::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.0-r1::gentoo
dev-lang/python:          2.7.12::gentoo, 3.4.5::gentoo
dev-util/cmake:           3.6.1::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.2-r1::gentoo
sys-apps/openrc:          0.21.5::gentoo
sys-apps/sandbox:         2.10-r2::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r2::gentoo
sys-devel/automake:       1.9.6-r4::gentoo, 1.11.6-r2::gentoo, 1.13.4-r1::gentoo, 1.14.1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo, 2.26.1::gentoo
sys-devel/gcc:            4.9.3::gentoo, 5.4.0::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r2::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.7::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r2::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: 1

local
    location: /usr/local/portage
    masters: gentoo
    priority: 2

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/var/tmp/distfiles"
EMERGE_DEFAULT_OPTS="--verbose --verbose-conflicts --color=n --nospinner --tree --quiet-build"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync network-sandbox parallel-fetch preserve-libs protect-owned sandbox sfperms strict test-fail-continue unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.uni-erlangen.de/pub/mirrors/gentoo rsync://mirror.netcologne.de/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gor.bytemark.co.uk/gentoo/ rsync://ftp.snt.utwente.nl/gentoo"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 avformat berkdb bluetooth branding bzip2 cairo cdda cddb cdr cgi cli cracklib crypt cups cxx dbus declarative dri dts dvd dvdr emboss encode evdev exif fam firefox flac fontconfig fortran freetds gdbm gif glamor gnome-keyring gpm gtk gtk2 gudev havege hdf5 iconv icu imap imlib infinality ipv6 ithreads javaxml jpeg kde kipi lapack latex lcms ldap libnotify libvirtd mad midi mmx mmxext mng modules mp3 mp4 mpeg multilib mysql ncurses nls nptl ogg openexr opengl openmp pam pango pax_kernel pcre pdf phonon plasma png policykit postgres ppds pulseaudio qemu qml qt3support readline sdl seccomp semantic-desktop session smpeg sockets spell sse sse2 ssl startup-notification svg systemd threads tiff truetype udev udisks unicode upower usb vaapi video vlc vorbis wayland widgets wxwidgets x264 xattr xcb xcomposite xinerama xml xscreensaver xslt xtpax xv xvid ziffy zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" L10N="as dz ja pl" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="amdgpu fbdev intel nouveau radeon radeonsi vesa dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Toralf Förster gentoo-dev 2016-08-31 08:37:59 UTC
Created attachment 444576 [details]
emerge-history.txt
Comment 2 Toralf Förster gentoo-dev 2016-08-31 08:38:02 UTC
Created attachment 444578 [details]
environment
Comment 3 Toralf Förster gentoo-dev 2016-08-31 08:38:05 UTC
Created attachment 444580 [details]
sys-fs:lxcfs-2.0.2:20160831-083444.log
Comment 4 Erik Mackdanz gentoo-dev 2016-08-31 14:06:55 UTC
'perl-cleaner --all' should fix that.  I've found that perl-cleaner is required for most world updates on my systems, at least for the last several months.
Comment 5 Kent Fredric (IRC: kent\n) gentoo-dev 2016-09-04 16:11:49 UTC

*** This bug has been marked as a duplicate of bug 592880 ***