Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 592540 - gnome-base/gnome-vfs fails to build with >=dev-libs/openssl-1.1.0
Summary: gnome-base/gnome-vfs fails to build with >=dev-libs/openssl-1.1.0
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: openssl-1.1
  Show dependency tree
 
Reported: 2016-08-31 08:09 UTC by Lars Wendler (Polynomial-C)
Modified: 2018-10-24 13:08 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,267.79 KB, text/plain)
2016-08-31 08:09 UTC, Lars Wendler (Polynomial-C) (RETIRED)
Details
gnome-vfs-2.24.4-openssl-1.1.patch (gnome-vfs-2.24.4-openssl-1.1.patch,839 bytes, patch)
2018-06-15 07:27 UTC, Lars Wendler (Polynomial-C) (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Lars Wendler (Polynomial-C) (RETIRED) gentoo-dev 2016-08-31 08:09:58 UTC
Created attachment 444544 [details]
build.log

libtool: compile:  x86_64-pc-linux-gnu-gcc -m32 -DHAVE_CONFIG_H -I. -I/var/tmp/portage/gnome-base/gnome-vfs-2.24.4-r5/work/gnome-vfs-2.24.4/libgnomevfs -I.. -I/var/tmp/portage/gnome-base/gnome-vfs-2.24.4-r5/work/gnome-vfs-2.24.4 -I.. -pthread -I/usr/include/gconf/2 -I/usr/include/libxml2 -I/usr/include/dbus-1.0 -I/usr/lib32/dbus-1.0/include -I/usr/include/glib-2.0 -I/usr/lib32/glib-2.0/include -I/usr/include/glib-2.0 -I/usr/lib32/glib-2.0/include -DXDG_PREFIX=_gnome_vfs_xdg -DDBUS_API_SUBJECT_TO_CHANGE -D_FILE_OFFSET_BITS=64 -D_BSD_SOURCE -D_LARGEFILE64_SOURCE -D_POSIX_PTHREAD_SEMANTICS -D_REENTRANT -DGNOME_VFS_PREFIX=\"/usr\" -DGNOME_VFS_BINDIR=\"/usr/bin\" -DGNOME_VFS_DATADIR=\"/usr/share\" -DGNOME_VFS_LIBDIR=\"/usr/lib32\" -DGNOME_VFS_LOCALEDIR=\"/usr/share/locale\" -DGNOME_VFS_SYSCONFDIR=\"/etc\" -DG_LOG_DOMAIN=\"libgnomevfs\" -march=native -mtune=native -O2 -pipe -c /var/tmp/portage/gnome-base/gnome-vfs-2.24.4-r5/work/gnome-vfs-2.24.4/libgnomevfs/gnome-vfs-ssl.c  -fPIC -DPIC -o .libs/gnome-vfs-ssl.o
In file included from /usr/include/limits.h:25:0,
                 from /usr/lib/gcc/x86_64-pc-linux-gnu/5.4.0/include-fixed/limits.h:168,
                 from /usr/lib/gcc/x86_64-pc-linux-gnu/5.4.0/include-fixed/syslimits.h:7,
                 from /usr/lib/gcc/x86_64-pc-linux-gnu/5.4.0/include-fixed/limits.h:34,
                 from /usr/lib32/glib-2.0/include/glibconfig.h:11,
                 from /usr/include/glib-2.0/glib/gtypes.h:32,
                 from /usr/include/glib-2.0/glib/galloca.h:32,
                 from /usr/include/glib-2.0/glib.h:30,
                 from /var/tmp/portage/gnome-base/gnome-vfs-2.24.4-r5/work/gnome-vfs-2.24.4/libgnomevfs/gnome-vfs-socket.h:32,
                 from /var/tmp/portage/gnome-base/gnome-vfs-2.24.4-r5/work/gnome-vfs-2.24.4/libgnomevfs/gnome-vfs-ssl.h:29,
                 from /var/tmp/portage/gnome-base/gnome-vfs-2.24.4-r5/work/gnome-vfs-2.24.4/libgnomevfs/gnome-vfs-ssl.c:33:
/usr/include/features.h:148:3: warning: #warning "_BSD_SOURCE and _SVID_SOURCE are deprecated, use _DEFAULT_SOURCE" [-Wcpp]
 # warning "_BSD_SOURCE and _SVID_SOURCE are deprecated, use _DEFAULT_SOURCE"
   ^
/var/tmp/portage/gnome-base/gnome-vfs-2.24.4-r5/work/gnome-vfs-2.24.4/libgnomevfs/gnome-vfs-ssl.c: In function ‘ssl_init’:
/var/tmp/portage/gnome-base/gnome-vfs-2.24.4-r5/work/gnome-vfs-2.24.4/libgnomevfs/gnome-vfs-ssl.c:128:2: warning: implicit declaration of function ‘SSL_library_init’ [-Wimplicit-function-declaration]
  SSL_library_init ();
  ^
/var/tmp/portage/gnome-base/gnome-vfs-2.24.4-r5/work/gnome-vfs-2.24.4/libgnomevfs/gnome-vfs-ssl.c: In function ‘gnome_vfs_ssl_create_from_fd’:
/var/tmp/portage/gnome-base/gnome-vfs-2.24.4-r5/work/gnome-vfs-2.24.4/libgnomevfs/gnome-vfs-ssl.c:381:38: error: dereferencing pointer to incomplete type ‘SSL {aka struct ssl_st}’
                 if (ssl->private->ssl->ctx)
                                      ^
make[3]: *** [Makefile:1032: gnome-vfs-ssl.lo] Error 1
make[3]: Leaving directory '/var/tmp/portage/gnome-base/gnome-vfs-2.24.4-r5/work/gnome-vfs-2.24.4-abi_x86_32.x86/libgnomevfs'
make[2]: *** [Makefile:845: all] Error 2
make[2]: Leaving directory '/var/tmp/portage/gnome-base/gnome-vfs-2.24.4-r5/work/gnome-vfs-2.24.4-abi_x86_32.x86/libgnomevfs'
make[1]: *** [Makefile:615: all-recursive] Error 1
make[1]: Leaving directory '/var/tmp/portage/gnome-base/gnome-vfs-2.24.4-r5/work/gnome-vfs-2.24.4-abi_x86_32.x86'
make: *** [Makefile:518: all] Error 2
Comment 1 Lars Wendler (Polynomial-C) (RETIRED) gentoo-dev 2018-06-15 07:27:03 UTC
Created attachment 535944 [details, diff]
gnome-vfs-2.24.4-openssl-1.1.patch

Working patch from NetBSD. Dunno if that was upstreamed already.
Comment 2 Larry the Git Cow gentoo-dev 2018-10-24 13:08:33 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=ac43ef9f87e64583606d6654b1ede19a16d3abdd

commit ac43ef9f87e64583606d6654b1ede19a16d3abdd
Author:     Lars Wendler <polynomial-c@gentoo.org>
AuthorDate: 2018-10-24 13:07:38 +0000
Commit:     Lars Wendler <polynomial-c@gentoo.org>
CommitDate: 2018-10-24 13:08:25 +0000

    gnome-base/gnome-vfs: Fixed build with openssl-1.1
    
    Closes: https://bugs.gentoo.org/592540
    Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
    Package-Manager: Portage-2.3.51, Repoman-2.3.11

 .../files/gnome-vfs-2.24.4-openssl-1.1.patch       | 26 ++++++++++++++++
 gnome-base/gnome-vfs/gnome-vfs-2.24.4-r5.ebuild    | 35 +++++++++++++---------
 2 files changed, 47 insertions(+), 14 deletions(-)